15:01:57 <DaveBarach> #startmeeting fdio vpp
15:01:57 <collabot> Meeting started Tue Oct 25 15:01:57 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:57 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:57 <collabot> The meeting name has been set to 'fdio_vpp'
15:02:21 <dwallacelf> #info Dave Wallace
15:02:31 <DaveBarach> #topic CSIT Maciek Reporting
15:02:49 <DaveBarach> #info infra upgrade: 16.04 migration complete
15:03:32 <DaveBarach> #info performance testbed results next week
15:04:31 <DaveBarach> #info still observing infra issues - critical csit test failures
15:05:19 <DaveBarach> #info Dave Wallace reports lf cleans out logs aggressively, which means lost info on test failures
15:05:35 <DaveBarach> #info switching to a scheme where logs stick around for 6 months
15:06:10 <DaveBarach> #info csit "setup" test fails - trivial test "is VPP running" - couldn't repro offline
15:07:11 <DaveBarach> #info setup test vpp start timeout appears not to be the definitive root cause
15:14:28 <DaveBarach> #info request for damjan to attend csit meetings
15:15:18 <DaveBarach> #action Damjan signs up to attend the beginning of the csit meeting
15:15:39 <DaveBarach> #topic Honeycomb, Marek reporting
15:15:47 <DaveBarach> #info working on infrastructure
15:16:17 <DaveBarach> #info vpe.api working on typeonly support for jvpp
15:16:37 <DaveBarach> #info working on Coverity warnings
15:22:46 <DaveBarach> #info considering whether to move jvpp to a separate project
15:26:43 <tfherbert> #info +1 on Ed's comment.
15:29:05 <DaveBarach> #info Ed W. suggests taking the language binding discussion to the mailing list
15:30:27 <DaveBarach> #topic Keith Burns NSH/SFC report
15:30:40 <DaveBarach> #info merged nsh proxy patch
15:31:32 <DaveBarach> #info want to avoid hard-coding nsh data into e.g. buffer metadata
15:36:13 <DaveBarach> #info variations on the theme from Florin
15:40:59 <DaveBarach> #action keith to set up call about policy imposition
15:44:00 <DaveBarach> #topic Florin reports on ONE-LISP
15:44:26 <DaveBarach> #info policy-based LISP forwarding now in master
15:44:37 <DaveBarach> #info fixes to be merged into ODL
15:45:38 <DaveBarach> #info finishing control-plane, shout-out to Neale for dual-looping FIB innards
15:48:30 <DaveBarach> #topic Sandbox
15:49:12 <DaveBarach> #info flowtable work at IETF in the sandbox
15:49:41 <DaveBarach> #topic TLDK Keith Wiles reporting
15:49:46 <DaveBarach> #info meeting tomorrow
15:50:01 <DaveBarach> #info Keith / Ray discussing project goals
15:50:21 <DaveBarach> #info Ray was completely consumed last week w/ DPDK summit
15:50:44 <alagalah> #topic VPPSB
15:50:44 <alagalah> #link https://gerrit.fd.io/r/#/c/3564/ floatable
15:50:44 <alagalah> #info Interesting approach to doing VPP work in the Sandbox i.e. a patch ratter than fork
15:50:53 <alagalah> #topic VPP packaging
15:51:11 <alagalah> #info tfherbert reports things for RPM packaging going well but...
15:51:15 <DaveBarach> #topic Tom H on DPDK packaging
15:51:20 <alagalah> #info upstream DPDK spec file needs  work ....
15:51:31 <DaveBarach> #info vpp spec file not suitable for upstreaming
15:53:15 <DaveBarach> #info might help to have Fedora Jenkins slaves
15:53:52 <DaveBarach> #topic Ed on LF Infra status
15:54:09 <DaveBarach> #info Ed keeping a spreadsheet of issues, traceback to root causes
15:54:23 <edwarnicke> #link https://docs.google.com/spreadsheets/d/1b01KrMDSlXFkyBDbKd7a0ITvfPtwUWFbZHDJ9Zfc5ck/edit#gid=0 <- infra root cause spreadsheet
15:55:22 <alagalah> #info edwarnicke Can you add a reporter and LF HD owner field ?
15:55:33 <alagalah> edwarnicke: That sheet is view only
15:55:35 <DaveBarach> #info gerrit server has been slow, pls add to tracking
15:56:14 <keith_wiles> #info ping Ed and report the times the slowness occurs
15:57:27 <DaveBarach> #topic Damjan on 17.01 release planning
15:58:20 <DaveBarach> #info dpdk 16.11 RC1 available, Damjan in the middle of cranking it up
15:59:55 <DaveBarach> #info kni interface dpdk code. Want to clean up, or shall we remove it?
16:00:39 <DaveBarach> #info Ray mentions kni was historically used for slow-path cases
16:01:02 <DaveBarach> #agreed to remove kni support in vpp 17.01
16:03:15 <DaveBarach> #info looks like dpdk 16.11 RC1 working as of a few mins ago
16:04:25 <DaveBarach> #info will push patch to unify / reorg feature path support, enable SPAN support
16:09:09 <DaveBarach> #endmeeting