#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 14:58:22 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 14:58:47)
    2. TF Herbert (tfherbert, 14:59:02)
    3. public holiday today in much of Europe (DaveBarach, 15:02:52)

  1. CSIT Maciek Reporting (DaveBarach, 15:03:06)
    1. most perf metrics increased w/ csit transition from 14.04 -> 16.04 (DaveBarach, 15:05:54)
    2. https://wiki.fd.io/view/CSIT/VPP-ubuntu-compare-1404to1604 (mackonstan, 15:06:02)

  2. nsh/sfc (DaveBarach, 15:20:14)
    1. request to cherry-pick / re-cut 16.09 release, none of the players on the call (DaveBarach, 15:21:13)
    2. commmunity policy meeting upcoming (Keith, Ole, Hongjun) (DaveBarach, 15:23:23)

  3. Florin reports on ONE-LISP (DaveBarach, 15:23:56)
    1. control-plane protocol work in progress (DaveBarach, 15:24:07)

  4. Keith reports on sandbox (DaveBarach, 15:24:44)
    1. flowlet switching patch uploaded to sandbox (DaveBarach, 15:25:39)

  5. TLDK report (DaveBarach, 15:26:53)
    1. dwallace reports that last week's TLDK mtg was very short (DaveBarach, 15:27:20)
    2. keith burns reports on a Friday follow-up with Ray K.; interesting DDoS mitigation design (DaveBarach, 15:27:59)

  6. DPDK packaging Tom Herbert reporting (DaveBarach, 15:28:38)
    1. initial commit done (DaveBarach, 15:29:00)
    2. build diff .gzip, which could help w/ upstream tarball download (DaveBarach, 15:29:40)

  7. Documentation (DaveBarach, 15:35:35)
    1. alagalah commented that we made big improvements in Docs in general in VPP 16.09 but its necessary but not sufficient to meet the punters needs. (alagalah, 15:36:22)
    2. For instance, we have a great doxygen generation system but folks need a decent User Guide and we need an API Users Guide (alagalah, 15:36:58)
    3. we have lots of tutorials etc for Developers IN VPP (YouTube, DevBoot etc) but we need to address consumability (alagalah, 15:37:28)
    4. the broader question is do we want VPPCTL to be the interface of record for these User Guides or should we be looking at things like HoneyComb to provide some user docs from a RESTCONF perspective (alagalah, 15:38:16)
    5. DaveBarach notes that he has been addressing the vpe.api size ... this is a common cause of patch git conflict (alagalah, 15:38:59)
    6. DaveBarach Notes that there is a DRAFT patch that folks can view on request, it isn't published due to it not building and not wanting to waste build cycles. (alagalah, 15:39:27)
    7. we have 55 issues ... there is a JIRA ticket (looking it up) (alagalah, 15:41:05)
    8. https://jira.fd.io/browse/VPP-486 Coverity JIRA 17.01 (alagalah, 15:43:57)
    9. +1 on user guide. (tfherbert, 15:44:01)
    10. ACTION: alagalah needs to follow up with DPDK team to see if they still want VPP to present at DPDK devboot this month (alagalah, 15:47:56)


Meeting ended at 15:48:17 UTC (full logs).

Action items

  1. alagalah needs to follow up with DPDK team to see if they still want VPP to present at DPDK devboot this month


Action items, by person

  1. alagalah
    1. alagalah needs to follow up with DPDK team to see if they still want VPP to present at DPDK devboot this month


People present (lines said)

  1. DaveBarach (19)
  2. alagalah (14)
  3. collabot` (3)
  4. tfherbert (2)
  5. mackonstan (1)
  6. dwallacelf (1)


Generated by MeetBot 0.1.4.