15:59:10 <DaveBarach> #startmeeting fdio vpp
15:59:10 <collabot`> Meeting started Tue Nov 15 15:59:10 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:10 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:10 <collabot`> The meeting name has been set to 'fdio_vpp'
16:02:00 <Jong_> #topic CSIT - Maciek
16:02:22 <Jong_> #info Good progress on Make Test.
16:03:28 <Jong_> #info test framework module documentation up and running
16:03:54 <Jong_> #info Damjan and Maciek agreed on how to run verify job
16:04:36 <Jong_> #info Next step is to publish the VPP Test Framework on FD.io wiki
16:04:47 <DaveBarach> #action Ed needs to merge ci patch to enable "make test"
16:05:44 <Jong_> #info Performance test - ongoing efforts with vhost
16:05:58 <Jong_> #info CentOS - work in progress
16:06:24 <Jong_> #info CSIT infra problems - there have been intermitten connectivity issues
16:07:07 <Jong_> #info Infra issues keep coming back
16:07:45 <DaveBarach> #info csit on latest branch (11/13)
16:08:13 <Jong_> #topic Honeycomb - Jerome
16:08:21 <DaveBarach> #topic Jerome reporting on Honeycomb
16:08:55 <Jong_> #info Jerome trying to gather information whether request from SFC project
16:09:44 <Jong_> #info Awaiting java plugin APIs from iOAM project
16:10:18 <Jong_> # topic NSH / SFC
16:10:27 <Jong_> #topic NSH / SFC
16:10:58 <DaveBarach> #info Frank Brockners metadata type 2 required for ioam
16:11:24 <Jong_> #topic ONE-LSIP
16:11:41 <Jong_> #info Florin couldn't attend meeting.. expect busy as usual
16:11:56 <Jong_> #topic Sandbox - no reporting
16:12:04 <Jong_> #topic TLDK
16:12:13 <Jong_> #info meeting tomorrow w/ Ray
16:13:06 <Jong_> #info expect to look at VPP integration in December
16:13:42 <Jong_> #info looking at the performance.. expect rework on timer code
16:15:22 <Jong_> #info DB has experience in timer code
16:17:46 <Jong_> #action DB will mail out timer code to Ray for potential leverage
16:19:10 <Jong_> #info two sets of conversation regarding TLDK... Keith Wiles working to merging into one
16:19:44 <Jong_> #topic DPDK packaging project - Thomas H.
16:19:59 <Jong_> #info working on packaging 16.11 DPDK - main activity
16:20:08 <Jong_> #info 16.11 DPDK released now
16:20:32 <Jong_> #topic Webex security enhancement - DB
16:20:56 <Jong_> #info expect to not affect this call... but will keep everyone informed
16:21:11 <Jong_> #topic Infrastructure
16:21:20 <Jong_> #info no reporting
16:21:40 <Jong_> #topic External crypto library default build dependencies
16:22:19 <Jong_> #info Should VPP instance be restarted often, seldom, or never?
16:23:04 <Jong_> #info Cleaning up resources, doing the delete the resources need to be verified.  Need to ensure the delete is successful.
16:24:04 <Jong_> #info All the resources that you create in the test case need to be removed.  Not a big ask.
16:33:44 <Jong_> #info test cases need to be written in a way that it cleans-up after themselves
16:34:05 <Jong_> #info need to define 'what is nothing left'
16:35:56 <Jong_> #action Neale took the action to do this method
16:36:07 <Jong_> #topic VPP 17.01 - Damjan
16:40:28 <Jong_> #topic Crypto library
16:40:46 <Jong_> #info DPDK won't build without this library
16:43:58 <Jong_> #info Damjan's question - Should we build DPDK in every single VPP build?
16:45:07 <Jong_> #info Thomas's question - Should it be in the DPDK RPM? Yes-Damjan
16:46:38 <Jong_> #info Damjan feels that this could be in the 17.01 release.. question is should we do it?
16:49:22 <Jong_> #info Damjan's proposal - for 17.01 - keep it diabled by default. Too short notice.  For next release, 17.xx, re-evalate.
16:49:29 <tfherbert1> #info +1
16:50:33 <Jong_> #info VPP 17.01 Release - Damjan
16:50:44 <Jong_> #topic VPP 17.01 release - Damjan
16:51:19 <Jong_> #info Verify jobs are fine, need to do some manual testing after getting results from CSIT
16:52:13 <Jong_> #topic Language binding build work - Ole
16:53:42 <Jong_> #info work-in-progess.  can now run  new api messages without having to do clients.
16:54:45 <Jong_> #info much more independence between language bindings and vpp
16:57:01 <Jong_> #info Expect some flux for couple of weeks.  May impact Jerome's work.
16:58:02 <Jong_> #info Intent is to have much more robust language binding.  Easier to get plug-ins.
16:58:29 <Jong_> #info Jerome to invite Ole to ML2 call to set expectations.
16:59:47 <Jong_> #info Need to decide whether to merge this into 17.01... need to minimize risk.
17:02:35 <Jong_> #info Please contact Ole if suggestions or improvements.. esp if you are the user
17:02:44 <Jong_> #topic Static Analysis
17:02:59 <Jong_> #info Looks like Coverity hasn't run in 4 days... any update?
17:04:01 <DaveBarach> #endmeeting