#fdio-vpp: fdio vpp

Meeting started by Jong_ at 16:02:56 UTC (full logs).

Meeting summary

  1. CSIT - Maciek reporting (Jong_, 16:03:08)
    1. dpdk 16.11 causing CSIT test failures (DaveBarach, 16:03:28)
    2. infra/reorg related test failures calmed down (DaveBarach, 16:04:17)
    3. making progress optimizing vhost in CSIT (Jong_, 16:06:55)

  2. Honecomb - Marek reporting (Jong_, 16:08:25)
    1. jvpp for acl plugin should be pushed in next couple of days (DaveBarach, 16:08:57)

  3. NSH/SFC - Keith B. reporting (Jong_, 16:16:36)
    1. classifier code merge done (DaveBarach, 16:16:55)
    2. looking good for 17.01 (DaveBarach, 16:17:01)

  4. LISP - Florin reporting (Jong_, 16:17:33)
    1. all changes that involve API are in (Jong_, 16:17:49)
    2. looking good for 17.01 (Jong_, 16:18:02)
    3. Are there downstream users? some internal in Cisco so far. (Jong_, 16:18:43)

  5. TLDK - Keith W reporting (Jong_, 16:19:06)
  6. DPDK packaging (Jong_, 16:19:38)
    1. Billy M: not much update on DPDK packaging. Thomas more focused on CentOS work. (Jong_, 16:20:24)
    2. Making progress on CSIT vhost work - will be updating progress on CSIT call tomorrow (Jong_, 16:20:49)

  7. Infra (Jong_, 16:21:22)
    1. seems calmer lately. (Jong_, 16:21:37)
    2. monitoring script running now (DaveBarach, 16:21:42)
    3. TWS calls to agree on a set of vhostuser use case and test case scenarios (mackonstan, 16:22:26)
    4. https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios (mackonstan, 16:22:29)
    5. next TWS call tomorrow at 9am PST (mackonstan, 16:22:40)
    6. https://wiki.fd.io/view/TWS (mackonstan, 16:22:51)
    7. above TWS link contains audio bridge details for "CSIT - vHost user test scenarios for CSIT" (mackonstan, 16:24:01)
    8. ACTION: hagbard to test staging branches before release (DaveBarach, 16:25:00)

  8. 17.01 release - Damjan reporting (Jong_, 16:25:12)
    1. Plan in place to address Honeycomb related bug issues by tomorrow (Jong_, 16:30:56)
    2. Merge activities in progress (Jong_, 16:34:29)
    3. looking good for 17.01, nothing critical to highlight (Jong_, 16:34:43)
    4. Coverity run is stalling again... (Jong_, 16:34:54)
    5. Ed: make test is not turned on as part of VPP verify yet. dependent on language bindings work (Jong_, 16:36:21)

  9. vhost user performance - Pierre reporting (Jong_, 16:37:23)
    1. Pierre shared graph showing significant vhost performance improvement (Jong_, 16:40:02)

  10. DPDK hash performance (Jong_, 16:43:09)
  11. Documentation (Jong_, 16:45:16)
    1. nothing outstanding (Jong_, 16:45:25)

  12. Code base activity (Jong_, 16:45:46)
    1. good progress ~ 60 merges a week (Jong_, 16:46:07)
    2. goal is to stabilize the master branch after F0. Any major changes would need to wait till next release (Jong_, 16:47:00)


Meeting ended at 16:47:21 UTC (full logs).

Action items

  1. hagbard to test staging branches before release


People present (lines said)

  1. Jong_ (30)
  2. DaveBarach (7)
  3. mackonstan (5)
  4. collabot` (3)
  5. florinc (1)


Generated by MeetBot 0.1.4.