#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 15:52:24 UTC (full logs).

Meeting summary

    1. preparing tests on CentOS (jong, 16:02:30)
    2. Done proxy Arp/SNAT/DHCP updates (jong, 16:03:31)
    3. In progress: v3po.yang model split (follows vpe.api split); (jong, 16:04:29)
    4. https://rt.linuxfoundation.org/Ticket/Display.html?id=36808 (valderrv, 16:04:32)
    5. In-progress: policer yang model discussion; (jong, 16:04:36)
    6. In-progress: BGP in HC discussion (jong, 16:04:58)
    7. Dave Wallace (dwallacelf, 16:05:49)
    8. In-progress: support for Yang model... (jong, 16:08:17)
    9. made API changes (jong, 16:09:12)
    10. will be completed with API changes by next week's freeze (jong, 16:10:39)
    11. making progress. merging patches to DPDK 17.02. (jong, 16:11:20)
    12. next step is to build vpp rpm.. so dependency is based on dpdk rpm (jong, 16:12:25)
    13. Please implement pretty-print / custom-dump fns in plugins! (jong, 16:15:55)
    14. important for control plane (jong, 16:16:38)
    15. Add config parameter to change loop%d to Loopback%d (interface naming) (jong, 16:16:42)
    16. Add new api ("create_loopback2" or some such) w/ instance number control (jong, 16:16:58)
    17. Deprecate current API in 17.07 (jong, 16:17:02)
    18. ACTION: DB to write-up a paragraph re loopback create API discussion and send to vpp-dev mailer (jong, 16:26:16)
    19. https://gerrit.fd.io/r/#/c/5547 (jong, 16:28:18)
    20. starting file, not a file. folks can nominate themselves during commits (jong, 16:30:52)
    21. ACTION: Damjan to send maintainers file gerrit to vpp-dev (jong, 16:31:14)
    22. 17.01 - Damjan (jong, 16:32:50)
    23. started the rebuild process for 17.01. will publish soon (jong, 16:33:14)
    24. VPP Jira dashboard aligned with maintainers file (jong, 16:34:41)
    25. https://jira.fd.io/secure/Dashboard.jspa?selectPageId=10700 (jong, 16:35:04)
    26. https://scan.coverity.com/projects/fd-io-vpp (jong, 16:37:09)
    27. doxygen issue/limitation wrt interpolated macros... there's work around (fixed string..) (jong, 16:45:17)
    28. inerpolation issue recorded at https://jira.fd.io/browse/VPP-417 since september (Chrisy_, 16:47:26)


Meeting ended at 02:48:54 UTC (full logs).

Action items

  1. DB to write-up a paragraph re loopback create API discussion and send to vpp-dev mailer
  2. Damjan to send maintainers file gerrit to vpp-dev


People present (lines said)

  1. jdl (54)
  2. jong (43)
  3. OleTroan (32)
  4. collabot` (4)
  5. Chrisy_ (3)
  6. DaveBarach (2)
  7. valderrv (1)
  8. dwallacelf (1)


Generated by MeetBot 0.1.4.