14:51:41 <DaveBarach> #startmeeting fdio vpp
14:51:41 <collabot> Meeting started Tue Aug  8 14:51:41 2017 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:51:41 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:51:41 <collabot> The meeting name has been set to 'fdio_vpp'
14:51:59 <DaveBarach> #topic agenda additions
14:59:09 <dwallacelf> #info Dave Wallace
15:01:31 <jong_> #topic CSIT - Dave W. reporting
15:01:50 <DaveBarach> #topic csit Dave Wallace reporting
15:02:05 <DaveBarach> #info 17.07 report 90% automatically generated
15:04:38 <DaveBarach> #action Dave Wallace to ask csit team about deprecating virl testing
15:05:28 <DaveBarach> #info virl needs dpdk patch to avoid MSIX interrupt hassle
15:06:11 <jong_> #info topic Honeycomb - Marek reporting
15:06:27 <DaveBarach> #info HC 17.07 released, without major issues
15:06:38 <DaveBarach> #info working on NAT64, LISP improvements
15:06:48 <DaveBarach> #info some issues with ODL integration
15:07:29 <jong_> #topic NSH-SFC
15:07:52 <DaveBarach> #action dbarach ask ray about NSH / SFC info from Danny
15:08:06 <jong_> #topic ONE-LISP - Floring
15:08:17 <DaveBarach> as opposed to ceiling?
15:08:38 <jong_> #topic ONE-LISP - Florin
15:09:03 <DaveBarach> #info map server fallback if > 1 server configured
15:09:13 <DaveBarach> #info adding apis for 17.10
15:09:51 <DaveBarach> #topic TCP / host stack
15:10:25 <DaveBarach> #info active-open thread-safe data structures, multi-thread builtin active-open client
15:10:54 <DaveBarach> #info session / transport layer cleanups
15:11:00 <DaveBarach> #info tx buffer allocation cleanup
15:17:49 <DaveBarach> #info horizontal session scaling result: 2x core (client, server) 2M sessions, 200K setups/sec
15:18:11 <DaveBarach> #topic DPDK packaging Tom H reporting
15:18:20 <DaveBarach> #info now building 17.08-rc0
15:18:46 <DaveBarach> #info want these packages to work with Centos, Rel
15:19:29 <DaveBarach> #info don't want to break legacy build system
15:19:42 <DaveBarach> #info enable folks to build local packages for local install
15:20:52 <jong_> #topic VPP release 17.07 - Neale reporting
15:21:22 <DaveBarach> #info 17.07.1 will ship when ACL plugin work (Andrew Y) is ready
15:21:39 <jong_> #topic VPP release 17.10 - Florin reporting
15:22:02 <DaveBarach> #info 17.10 release plan added
15:22:29 <DaveBarach> #info some deliverables listed, please give Florin a list of expected features
15:22:51 <jong_> #topic Infra status - Ed Kern reporting
15:23:14 <DaveBarach> #info container POC: hard drive failure, need to reimage
15:25:37 <jong_> #topic Static Analysis
15:26:36 <DaveBarach> #info Marek on Coverity complaints re: java API
15:27:05 <DaveBarach> #action dbarach to write email re: coverity java complaints
15:28:24 <DaveBarach> #info we tried to disable coverity for java built artifacts, bug supposedly "to be fixed..."
15:29:17 <jong_> #topic Switch to zoom teleconferencing
15:30:18 <jong_> #info will try zoom for next meeting
15:31:32 <florinc_> #info 17.10 release plan: https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_17.10
15:33:09 <jong_> #topic Upcoming fd.io Events
15:34:24 <jong_> #topic Others
15:34:41 <DaveBarach> #topic Billy H on internal performance
15:34:53 <BillyM> #topic Internal testing show degradation in performance from 17.04 to 17.07
15:34:53 <BillyM> #info l2-bridge testing - PVP - 0.002% Drop Rate
15:34:53 <BillyM> #info VPP-17.04: 256 Flow 7.8 MP/s  10k Flow 7.3 MP/s  1m Flow 5.2 MP/s
15:34:53 <BillyM> #info VPP-17.07: 256 Flow 7.7 MP/s  10k Flow 2.7 MP/s  1m Flow 1.8 MP/s
15:38:46 <florinc_> https://docs.fd.io/csit/rls1707/report/vpp_performance_tests/packet_throughput_graphs/l2.html#ndr-throughput
15:45:11 <DaveBarach> #endmeeting