15:58:35 <DaveBarach> #startmeeting fdio vpp
15:58:35 <collabot> Meeting started Tue Dec 12 15:58:35 2017 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:58:35 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:58:35 <collabot> The meeting name has been set to 'fdio_vpp'
16:01:28 <DaveBarach> #topic agenda additions
16:02:34 <DaveBarach> #topic CSIT Maciek K reporting
16:03:01 <DaveBarach> #info 18.01 work in process, plan on wiki being updated regularly
16:03:25 <DaveBarach> #info more vpp container topologies w/ memif, k8s, ligato
16:03:59 <DaveBarach> #info orchestration mostly done
16:04:15 <DaveBarach> #info looking to onboard vpp TCP host-stack testing
16:04:33 <DaveBarach> #info working with both WRK and Trex
16:04:43 <DaveBarach> #info srv6 perf testing
16:05:36 <DaveBarach> #info arm folks onboarding hardware
16:06:21 <mackonstan> #info CSIT 1801 plan
16:06:24 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1801_plan
16:06:59 <DaveBarach> #topic NSH / SFC no news Ray K reporting
16:07:33 <DaveBarach> #info Maciek thanks Sergio for helping w/ IPSEC / crypto test integration into CSIT
16:08:05 <DaveBarach> #topic host stack (Florin reporting)
16:08:26 <DaveBarach> #info lots of prep work for Kubecon demo / preso
16:08:38 <DaveBarach> #info Florin's preso on the website
16:08:57 <DaveBarach> #info one important patch to standardize session / transport APIs
16:09:12 <DaveBarach> #info transport leakage into session layer addressed
16:09:45 <DaveBarach> #info Keith on vppcom + ld_preload cleanups
16:10:30 <DaveBarach> #info keith adding event-log to vppcom, for integrated pictures with the vpp stack
16:10:54 <DaveBarach> #info dwallace refactoring vppcom to facilitate direct use by clients
16:12:01 <DaveBarach> #info Ray K asks about direct memif access from Golang
16:13:27 <DaveBarach> #info for vcl, configuration via a config file (heap size, etc)
16:13:48 <DaveBarach> #info a few environment variables also used
16:16:01 <DaveBarach> #topic 18.01 release Dave Wallace reporting
16:16:06 <DaveBarach> #info please review the release plan
16:16:34 <DaveBarach> #info API changes by next Weds pls keep Dave Wallace in the loop
16:18:01 <DaveBarach> #topic Infrastructure
16:18:19 <DaveBarach> #info container POC equipment finally cleared Canadian customs
16:18:25 <DaveBarach> #info installation next
16:23:20 <DaveBarach> #action Ed Kern to work through splitting the make verify clang build so it can run in parallel
16:25:27 <DaveBarach> #info tina now audible, asks about CSIT whitepaper Maciek working w/ Intel about
16:25:59 <DaveBarach> #info current whitepaper not ARM-relevant
16:26:43 <DaveBarach> #info after equipment onboarded, expect to update whitepaper w/ arm data thereafter
16:30:39 <DaveBarach> #topic Kubecon mini-summit report from Ed Warnicke
16:31:00 <DaveBarach> #info lots of interest
16:31:02 <florinc> mini summit agenda: http://events.linuxfoundation.org/events/kubecon-and-cloudnativecon-north-america/extend-the-experience/mini-summits
16:31:15 <DaveBarach> #info lots of social media
16:31:59 <DaveBarach> #info Florin's talk drew lots of questions, after talk and at the booth
16:32:24 <DaveBarach> #info showed vpp/contiv, nginx; something like 20K calls/sec
16:32:47 <DaveBarach> #topic upcoming fd.io events
16:33:26 <DaveBarach> #info ray k: FOSDEM will have a strong fd.io set of topic
16:34:00 <DaveBarach> #info ed W: ONS call for papers open, CFP closes 1/14
16:34:36 <DaveBarach> #info ray k: need to target ONS due to open-source networking consolidation
16:35:15 <DaveBarach> #topic AWS integrations (Jerome)
16:35:50 <DaveBarach> #info ubuntu 16.04 w/ Elastic Network Arch: vpp + dpdk on interfaces
16:36:53 <DaveBarach> #info Jira ticket VPP-1093
16:41:09 <DaveBarach> #endmeeting