16:00:56 <DaveBarach> #startmeeting fd.io vpp
16:00:56 <collabot> Meeting started Tue Jan  9 16:00:56 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:56 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:56 <collabot> The meeting name has been set to 'fd_io_vpp'
16:03:18 <DaveBarach> #topic agenda additions?
16:03:58 <DaveBarach> #topic CSIT (Peter Mikus reporting)
16:04:10 <DaveBarach> #info expect measurement data tomorrow
16:05:50 <DaveBarach> #topic NSH/SFC
16:05:58 <DaveBarach> #info PTL election in progress, hope to hear soon
16:06:11 <DaveBarach> #topic ONE/LISP (Florin)
16:06:18 <DaveBarach> #info maintenance mode for the moment
16:06:42 <DaveBarach> #action dbarach remove ONE/LISP from weekly agenda
16:06:59 <DaveBarach> #topic host stack (Florin)
16:07:26 <DaveBarach> #info binary API / vlibmemory work on socket transport refactoring
16:07:46 <DaveBarach> #info can now connect via socket and bootstrap a pairwise shared-memory connection to vpp
16:08:45 <DaveBarach> #info big patch pending to refactor vlibmemory in simple ways
16:08:58 <DaveBarach> #info better client/server isolation
16:09:39 <DaveBarach> #info separate vlib API code from (memory,socket) transport
16:10:07 <florinc> https://gerrit.fd.io/r/#/c/9976/
16:10:59 <DaveBarach> #info Dave Wallace on LD_PRELOAD work
16:11:20 <DaveBarach> #info elog events added by Keith
16:11:45 <DaveBarach> #info Dave Wallace refactoring LD_PRELOAD: make the library stateless
16:12:13 <DaveBarach> #info 4KLOC removed
16:12:34 <DaveBarach> #info "no more hash tables!"
16:13:59 <DaveBarach> #info mixed vpp/kernel select, epoll: split bitmaps, etc.
16:15:17 <DaveBarach> #info better tracing so people will find out that "X is unimplemented" in an obvious way
16:15:49 <DaveBarach> #info Keith will be updating wiki with elog info
16:16:20 <DaveBarach> #info demo at Kubecon - thanks to Ed, Jan - native integration with Envoy in progress
16:16:36 <DaveBarach> #info working on native VCL integration into apps
16:19:40 <DaveBarach> #info discussion around Spectre and Meltdown perf implications
16:20:43 <DaveBarach> #topic arm / aarch64 (Tina T reporting)
16:21:26 <DaveBarach> #info CSIT added support for aarch64
16:21:55 <DaveBarach> #info next two weeks, continue w/ testing, perf benchmarking
16:22:43 <DaveBarach> #topic 18.01 release (Dave Wallace)
16:22:51 <DaveBarach> #info RC1 branch cut last week
16:23:36 <DaveBarach> #info OpenSUSE artifacts not being published yet
16:24:17 <DaveBarach> #info request to Marco: don't build old branches since they won't work
16:26:45 <DaveBarach> #topic Coverity SA currently broken
16:27:26 <DaveBarach> #info seems like disk breakage knock-on effects
16:27:59 <DaveBarach> #info not in bad shape, we'll see if we can "get to zero" before final release
16:29:44 <DaveBarach> #topic fd.io events (Ed, Ray)
16:30:07 <DaveBarach> #info Ray mentions 4 vpp talks at FOSDEM (Feb, Brussels)
16:31:19 <DaveBarach> #info ONS 2018 CFP opaque. Ed working to construct an fd.io minisummit
16:32:07 <DaveBarach> #info Kubecon Europe (May) CFP closes Jan 12
16:32:21 <DaveBarach> #action Ed to add Kubecon Europe details to wiki
16:34:39 <DaveBarach> #topic Damjan on native driver for Macchiato
16:35:26 <DaveBarach> #info use Marvell user-mode SDK. Driver working, need to resolve shared-memory base VA issue
16:36:42 <DaveBarach> #info vpp overusing prefetch slots. vpp 3.5 mpps vs. sample app 9 mpps
16:45:34 <DaveBarach> #topic Damjan on tap v2 driver
16:46:02 <DaveBarach> #info ring size tuning may be required. Default 256 is intended to keep older kernels happy
16:46:52 <DaveBarach> #endmeeting