16:00:57 <DaveBarach> #startmeeting fdio vpp
16:00:57 <collabot`> Meeting started Tue Feb  6 16:00:57 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:57 <collabot`> The meeting name has been set to 'fdio_vpp'
16:01:44 <DaveBarach> #topic CSIT (maciek reporting)
16:02:35 <DaveBarach> #info performance regression commentary
16:02:48 <DaveBarach> #info fix in 18.01.01
16:03:02 <DaveBarach> #info report to be issued beginning of next week
16:04:02 <bbrian> I would like to talk about compiler builtins for atomics regarding https://gerrit.fd.io/r/#/c/10293/
16:04:49 <DaveBarach> #info git bisect of release branch. Perf delta exactly at branch pull, not clear why 18.01 differs by about 5% from master
16:05:15 <DaveBarach> #info dpdk 17.11 artifacts posted in master / built out of 18.01 branch are different sizes
16:05:54 <DaveBarach> #info no obvious root-cause from that exercise
16:06:55 <DaveBarach> #info test indicates perf delta between POC and LF infra. When built on local haswell machine, 18.01 identical to master
16:08:24 <alagalah> #info DaveBarach - suggests disassembling code between perf/non-perf binaries
16:08:57 <florinc> bbrian: definitely! Are you connected to zoom?
16:09:16 <alagalah> #info @dwallacelf did digging into ELF files etc and thought it might be a micro-architecture issue
16:10:27 <alagalah> #info Discussion about building locally (and building DPDK from source) or in LF infra.
16:12:13 <alagalah> #info @mackonstan2 believes main issue is in NAT eating 7k clocks ... mentioned the std dev is good (sic) but still have performance gap (@alagalah - editorial - trying to follow what @mackonstan2 is actually saying... if its where we are building it or if its just NAT)
16:12:50 <alagalah> #info
16:13:14 <alagalah> #info @DaveBarach seems like NAT was enabling an input node that wasn't needed until feature was enabled.
16:14:00 <jdl> We recently saw events being sent to a process before it was ready to receive them.
16:14:04 <bbrian> florinc: yes
16:14:09 <florinc> bbrian: perfect!
16:14:30 <DaveBarach> #topic Honeycomb (Marek reporting)
16:14:36 <DaveBarach> #info 18.01 released
16:14:51 <florinc> bbrian: typically we finish before the top of the hour so we can have the discussion then
16:15:18 <bbrian> ok
16:15:26 <DaveBarach> #topic Host stack
16:15:38 <DaveBarach> #info continuing integration w/ Envoy
16:16:31 <DaveBarach> #info compatibility w/ libevent2
16:20:51 <alagalah> #action @alagalah to update Wiki to reflect a) how to use VCL and LDPRELOAD b) by corollary of demonstrating that LDPRELOAD works with Envoy / Istio, which actually use glibc (socket, bind etc) and libevent (read, write) which uses epoll_ etc, its probably more accurate to say VCL/LDPRELOAD supports glibc calls and to a large extent, libevent (can list libevent calls that Envoy uses that we know we support etc) ....
16:22:04 <alagalah> #info @dwallacelf points out that there are a large number of set|getsockopts() we need to actually support which were implemented to a use-case (Envoy/Istio) rather than the full gamut of options
16:22:31 <alagalah> @florinc I was typing ^^^ when you were speaking so if you feel like info'ing ....
16:22:31 <collabot`> alagalah: Error: "florinc" is not a valid command.
16:22:42 <alagalah> florinc: I was typing ^^^ when you were speaking so if you feel like info'ing ....
16:22:46 <DaveBarach> #topic aarch64 (Tina reporting)
16:24:51 <florinc> #info hoststack updates: refactor of builtin apps, rw lock implementation that replaces the custom implementation in the session layer, refactored segment manager and usage of valloc as a central segment base va manager
16:25:24 <DaveBarach> #info DHL can't find well-known shipping address
16:27:15 <DaveBarach> #topic 18.01 release
16:28:07 <DaveBarach> #info 18.01.01 release to deal e.g. w/ csit performance issues, 4 or 5 commits
16:30:24 <DaveBarach> #info pls edit wiki w/ 18.04 release deliverables
16:30:35 <alagalah> Do we want that in JIRA too ?
16:30:40 <alagalah> With a link to the JIRA ?
16:30:51 <DaveBarach> that'd be nice...
16:30:57 <alagalah> dwallacelf: ^^^ thoughts ?
16:31:33 <alagalah> #info We should be putting these "new features" into JIRA and put a link to that into the Release Deliverables...
16:32:32 <alagalah> #info Ultimately thats the 18.04 RelMgr's call but generally seen as a positive. dwallacelf speaking on behalf of Chrisy
16:33:04 <alagalah> dwallacelf: ^ sorry mate, I realised after punching that in it makes it seem like you said that .... should be ok though
16:33:59 <DaveBarach> #topic container build POC
16:34:04 <DaveBarach> #info hardware all set
16:34:46 <DaveBarach> #info no performance alarms in place
16:35:39 <DaveBarach> #info configure jobs to actually use the container minions
16:36:40 <DaveBarach> #info merged patch to avoid container-unfriendly manipulation of /proc
16:37:19 <DaveBarach> #info current JJB master either sends all streams to current infra OR to POC
16:37:47 <DaveBarach> #info reluctant to throw big switch
16:38:25 <DaveBarach> #info two restructurings of JJB pending, to send less than every job to container infra
16:41:36 <bbrian> florinc: maybe we have a one-off meeting to discuss not only compiler builtins but also correctness of shared memory synchronization of things like locks and queues
16:43:30 <florinc> bbrian: sure! If we don't manage to plan something in zoom now, let's sync over email. We'll need DaveBarach to join that as well
16:44:36 <DaveBarach> #action DaveW to email list w/ cut-over date
16:44:48 <florinc> BillyM: I've added an 18.04 release to Jira (or at least I think I did), does it work for you
16:45:03 <alagalah> #topic moving mailer
16:45:20 <alagalah> #info transition to groups.io
16:45:42 <DaveBarach> #info need to ping LF, et al to figure out status
16:45:54 <alagalah> #topic Static Analysis
16:46:14 <alagalah> #info DaveBarach : SCTP has a number of Coverity defects ... who would be contact?
16:46:26 <alagalah> #action florinc to contact Marco (original submitter)
16:46:33 <alagalah> #topic Events
16:46:43 <alagalah> #info FOSDEM: Ray reports:
16:47:04 <DaveBarach> #info Jerome demo of vpp went great
16:47:07 <BillyM> florinc: Yes, Thanks.
16:47:08 <alagalah> #info full rooms for most presos, great feedback, Highlight was Jerome Tollet's impromptu demo of VPP (I think with TAPv2 40G ?)
16:47:30 <alagalah> #info interest in general for VPP + TCP
16:49:00 <DaveBarach> #topic Brian Brooks on __sync builtins
16:58:02 <DaveBarach> #endmeeting