16:01:49 <DaveBarach> #startmeeting fdio-vpp
16:01:49 <collabot`> Meeting started Tue Mar  6 16:01:49 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:49 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:49 <collabot`> The meeting name has been set to 'fdio_vpp'
16:03:43 <DaveBarach> #topic csit (Maciek reporting)
16:04:05 <DaveBarach> #info a number of csit jobs stopped working yesterday
16:04:32 <DaveBarach> #info missing dependencies, being fixed
16:06:13 <mackonstan> #info "api-segment { gid vpp }" in startup.conf, not recognized
16:08:24 <DaveBarach> #info ... I'm not seeing the "api-segment..." issue, TBH...
16:17:10 <DaveBarach> #topic Honeycomb (Marek reporting)
16:17:27 <DaveBarach> #info merged vpp-1184, including api generation fixes
16:18:16 <DaveBarach> #topic host stack (Keith, Florin)
16:18:22 <DaveBarach> #info async event handling in VCL
16:19:20 <DaveBarach> #info make-test added cuth-through and host-to-host testing
16:19:37 <DaveBarach> #info basic + extended tests
16:22:43 <DaveBarach> #info test script can run iperf - should we add to make test dependencies?
16:25:39 <DaveBarach> #topic host stack TLS implementation
16:25:48 <DaveBarach> #info early version in master/latest now
16:26:25 <DaveBarach> #info TLS "recursive application" support
16:26:37 <DaveBarach> #info using mbedTLS at this point
16:30:50 <DaveBarach> #info CentOS downstream packaging pain w/ mbedTLS
16:33:14 <DaveBarach> #topic 18.04 2 weeks from API freeze!
16:35:01 <DaveBarach> #topic infrastructure
16:35:20 <DaveBarach> #info merge job fails due to make-test multiple vpp instance detection, found workaround
16:36:46 <DaveBarach> #action Ed and Dave W to set up email when merge job fails
16:42:11 <DaveBarach> #topic encryption algorithms
16:44:27 <DaveBarach> #info crypto algorithm need list of algorithms used and coded
16:45:29 <Chrisy> mbed tls export compliance statement: https://tls.mbed.org/kb/generic/export-control-eccn-number-for-mbedtls
16:48:24 <Chrisy> PolarSSL
16:52:10 <DaveBarach> #topic Ubuntu 18.04 LTS
16:52:36 <DaveBarach> #info need to decide what/when to support it
16:58:03 <DaveBarach> #endmeeting