#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:58:53 UTC (full logs).

Meeting summary

  1. agenda additions (DaveBarach, 15:06:26)
  2. CSIT (maciek reporting) (DaveBarach, 15:07:55)
    1. dot1q, dot1ad regression (DaveBarach, 15:08:15)
    2. Damjan mentions specific dot1ad, dot1q perf issues in ethernet_input, tx path (DaveBarach, 15:12:39)
    3. https://docs.fd.io/csit/rls1804/report/vpp_performance_tests/csit_release_notes.html (mackonstan, 15:15:36)
    4. https://docs.fd.io/csit/master/trending/introduction/index.html# (mackonstan, 15:16:01)

  3. honeycomb Marek reporting (DaveBarach, 15:16:15)
    1. 18.04 released! (DaveBarach, 15:16:23)
    2. 18.07 more yang models, update NAT model (DaveBarach, 15:16:37)
    3. SR-V6, improvements to netconf support (DaveBarach, 15:16:56)
    4. AGREED: to remove NSH/SFC from roundable (DaveBarach, 15:18:01)

  4. host-stack (Florin reporting) (DaveBarach, 15:18:24)
    1. UDP reworked, to do proper datagram mode (DaveBarach, 15:18:42)
    2. vcl needs improvement to work in datagram mode (DaveBarach, 15:19:05)
    3. rework of session output node - only generate one frame for all sessions (DaveBarach, 15:19:33)
    4. important: after all fine-tuning, 21gbit/core throughput w/ standard ethernet MTU (DaveBarach, 15:20:07)
    5. UDP saturates a 40g NIC w/ 1 core (DaveBarach, 15:20:20)

  5. VCL (Dave Wallace reporting) (DaveBarach, 15:21:34)
    1. resource constrained, working on Envoy refactoring (DaveBarach, 15:21:48)
    2. POC working, several outstanding issues on back burner (DaveBarach, 15:22:11)

  6. ARM64 (Tina Tsou reporting) (DaveBarach, 15:22:41)
    1. fido-lab issues: using USB adapters (DaveBarach, 15:23:07)
    2. Marvell working to upstream patches (DaveBarach, 15:24:29)

  7. RPM / CentOS upstream (billy reporting) (DaveBarach, 15:25:58)
    1. 18.01.1 -> CentOS (DaveBarach, 15:26:14)
    2. bugzilla filed to clean up internal directory structure (DaveBarach, 15:26:36)
    3. slow due to small team, delayed w/ release in progress (DaveBarach, 15:27:00)
    4. CentOS 7.5 will fix problem (DaveBarach, 15:27:17)
    5. Jerome T asks about export control issues (DaveBarach, 15:28:12)
    6. Billy: only applies to "rel", licensing to be blessed later this week (DaveBarach, 15:28:41)
    7. haven't done much w/ Fedora. On the list, Tom H working on it (DaveBarach, 15:30:07)
    8. CentOS setup doc overdue (DaveBarach, 15:31:09)
    9. ACTION: Billy McFall to create a CentOS vpp setup HowTo (DaveBarach, 15:31:31)

  8. fd.io interns (DaveBarach, 15:42:32)


Meeting ended at 15:43:28 UTC (full logs).

Action items

  1. Billy McFall to create a CentOS vpp setup HowTo


People present (lines said)

  1. DaveBarach (36)
  2. collabot` (3)
  3. mackonstan (2)
  4. OleTroan (2)


Generated by MeetBot 0.1.4.