#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 15:02:12 UTC (full logs).

Meeting summary

  1. CSIT (Maciek K reporting) (DaveBarach, 15:03:00)
    1. infra work in progress (DaveBarach, 15:03:09)
    2. Progressing with CSIT infra work and new integration tests: (mackonstan, 15:03:13)
    3. i) Xeon Skylake servers onboarding - some delays due to HW/firmware issues - still targetting initial results for rls1807, both trending and in report. (mackonstan, 15:03:20)
    4. ii) VIRL test porting to VPP_make_test - P0 tests almost done, completion ETA this week. (mackonstan, 15:03:36)
    5. skylake servers delayed, still plan to issue skylake report w/ 18.07 report (DaveBarach, 15:03:41)
    6. virl transition P0 tests expect to complete this week (DaveBarach, 15:03:55)
    7. iii) New functional tests on hardware [VPP_Device] - dedicated two 1-Node Xeon Skylake servers are live, CSIT framework work started. (mackonstan, 15:04:01)
    8. New anomaly detection scheme in operation on main trending pages. (mackonstan, 15:04:21)
    9. New alias being setup for reporting trending failures and regressions: csit-report@lists.fd.io. (mackonstan, 15:04:27)
    10. new alias on the way for trending report emails, approved, in progress w/ LF (DaveBarach, 15:04:41)
    11. re dpdk18.05 regression on x520 NICs - patch merged making dpdk18.05 a default, no regressions detected in trending jobs (mackonstan, 15:05:09)
    12. dpdk 18.05 regression: will merge, still looking for patches from dpdk community (DaveBarach, 15:05:37)
    13. but we do see regression in testpmd and l3fwd tests - awaiting more feedback from dpdk folks/Ray (mackonstan, 15:05:39)

  2. Honeycomb no report this week (DaveBarach, 15:07:56)
  3. Host Stack (Florin reporting) (DaveBarach, 15:08:08)
    1. VCL refactoring in progress, no more pushes due to F0 code freeze (DaveBarach, 15:08:36)

  4. Documentation (John D., Ray K. reporting) (DaveBarach, 15:10:33)
    1. minor "checkstyle.sh" change to avoid verifying doc-only patches (DaveBarach, 15:15:28)
    2. ACTION: Ed Kern to fix checkstyle.sh to "fail" doc-only patches in an obvious way (DaveBarach, 15:18:32)
    3. ACTION: Ed Kern to investigate adding doc reviewers to patches above a certain size (DaveBarach, 15:20:16)

  5. ARM (Tina Tsou reporting) (DaveBarach, 15:21:57)
    1. ip4 forwarding work in progress (DaveBarach, 15:22:31)
    2. hard to hear... (DaveBarach, 15:23:29)

  6. 18.07 release - on schedule, need to clean up coverity warnings (DaveBarach, 15:25:57)
  7. infra status (DaveBarach, 15:26:02)
    1. build system seems stable for the last 2 weeks (DaveBarach, 15:26:44)
    2. merge jobs backing up (DaveBarach, 15:26:52)
    3. LF reboot / updates coming this afternoon (DaveBarach, 15:28:02)


Meeting ended at 15:33:39 UTC (full logs).

Action items

  1. Ed Kern to fix checkstyle.sh to "fail" doc-only patches in an obvious way
  2. Ed Kern to investigate adding doc reviewers to patches above a certain size


People present (lines said)

  1. DaveBarach (23)
  2. mackonstan (9)
  3. collabot (3)


Generated by MeetBot 0.1.4.