14:59:49 <DaveBarach> #startmeeting fido-vpp
14:59:49 <collabot> Meeting started Tue Sep  4 14:59:49 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:49 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:49 <collabot> The meeting name has been set to 'fido_vpp'
15:03:16 <DaveBarach> #topic Agenda Additions
15:04:23 <DaveBarach> #topic CSIT (maciek reporting)
15:05:03 <DaveBarach> #info CSIT release milestones realigned to track vpp releases
15:05:04 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1810_plan
15:05:54 <DaveBarach> #info csit report release two weeks after vpp releases
15:06:18 <DaveBarach> #info Skylake perf test more complete
15:06:48 <DaveBarach> #info Switch to Ubuntu 18.04 for skylake, haswell testbeds
15:07:54 <DaveBarach> #agreed to switch to 18.04 on haswell for csit
15:09:02 <DaveBarach> #info need to make sure "make test" actually works
15:09:12 <DaveBarach> #action ed kern to check out make test on 18.04
15:10:11 <DaveBarach> #info short performance tests about to be available, first by text trigger
15:11:43 <DaveBarach> #info looking at extended soak-testing for throughput - an hour or more - hopefully for 18.10
15:12:11 <DaveBarach> #info container-based functional testing
15:12:26 <DaveBarach> #info some containter tests hopefully in 18.10
15:13:55 <DaveBarach> #topic Honeycomb (michal cmarada reporting)
15:14:30 <DaveBarach> #info nsh plugin moving to vpp tree, Honjun also moving jvpp code
15:14:50 <DaveBarach> #info ODL release this friday
15:15:04 <DaveBarach> #topic Host Stack (Florin Coras reporting)
15:15:23 <DaveBarach> #info support for multiple application worker threads, both in session layer and in VCL
15:16:11 <DaveBarach> #info app can register (bind) multiple worker threads, multiple worker processes (fork cases) upcoming
15:16:41 <DaveBarach> #info SO_REUSE cases
15:17:29 <DaveBarach> #info refactored vcl tests to use multiple workers, aka multiple binds. App has multiple workers, needs vpp load balancing
15:17:40 <DaveBarach> #info round-robin load-balancing
15:18:18 <DaveBarach> #topic Documentation (John DeNisco reporting)
15:18:29 <DaveBarach> #info release notes move to "new" doc format
15:18:59 <DaveBarach> #action john to contact Marco offline to set up release notes
15:19:47 <DaveBarach> #info how to land documentation somewhere in the fd.io tree
15:20:14 <DaveBarach> #info Ed Warnicke mentions mechnical issues
15:20:30 <DaveBarach> #action Ed and John to work out a good place to land the docs offline
15:25:16 <DaveBarach> #topic cmake
15:25:47 <DaveBarach> #info centos has an old version
15:26:53 <DaveBarach> #topic aarch64 (Tina T reporting)
15:27:01 <DaveBarach> #Info mellanox issues resolved
15:27:27 <DaveBarach> #info make verify was failing, Huawei to validate
15:27:59 <DaveBarach> #info dual / quad loop: looking into dynamic (runtime) node function selection
15:28:26 <DaveBarach> #topic Release 18.07 (Ed W. reporting)
15:28:41 <DaveBarach> #info looking at creating a dot release next week
15:29:30 <DaveBarach> #info csit interface up/down issue might be worth holding dot release
15:29:47 <DaveBarach> #action maciek, Ed W to decide about holding 18.07 dot release
15:30:00 <DaveBarach> #topic 18.10 (Marco V reporting)
15:30:10 <DaveBarach> #info schedule agreed last meeting
15:30:36 <DaveBarach> #info 7 days between milestones, Oct 24 release date
15:30:48 <DaveBarach> #info reminder: 4 weeks from API freeze
15:31:10 <DaveBarach> #info please add features to release page, or email Marco V
15:31:49 <DaveBarach> #action dbarach to add 10.18 release dates to the vpp meeting agenda
15:32:37 <BillyM> #info cmake - In VPP, 'src/CMakeLists.txt' requires cmake 3.5. CentOS 7.5 base repo has cmake 2.8. I tried changing the required version in 'src/CMakeLists.txt' to 2.8 but hit a command that was introduced in cmake 3.1. Also, ninja-build is only in epel (can't use in downstream CentOS). epel looks to have cmake3 3.12.
15:32:45 <DaveBarach> #topic cmake (Dave, Billy)
15:34:32 <DaveBarach> #action Damjan to sync up with Billy / Tom Herbert to understand Centos cmake version issues
15:35:50 <DaveBarach> #topic Infra
15:36:10 <DaveBarach> #info packagecloud much better at version tracking than nexus
15:36:36 <DaveBarach> #info moving the nsh plugin  into vpp simplifies the transition
15:37:42 <DaveBarach> #topic fd.io events (Ed W. reporting)
15:37:52 <DaveBarach> #info ed goes through the list
15:38:25 <DaveBarach> #info fd.io minisummit on December 10th
15:38:36 <DaveBarach> #info CFP open now
15:40:01 <DaveBarach> #topic Hyperscan (Hongjun)
15:41:09 <DaveBarach> #info pattern matching algorithm
15:41:22 <DaveBarach> #info regex matching
15:43:03 <DaveBarach> #info C++ compiler w/ C API
15:52:38 <DaveBarach> #info basic technology to sit on multiple different feature arcs
15:54:23 <DaveBarach> #topic LTS releases (Marco V)
15:54:53 <DaveBarach> #info vpp using short-term DPDK release strategy
15:55:03 <DaveBarach> #info dpdk 18.11 will be an LTS release
15:55:59 <DaveBarach> #info continue to support dpdk LTS release until next dpdk LTS release
15:56:51 <DaveBarach> #info Tom H: ovs uses dpdk LTS releases
15:58:22 <DaveBarach> #info Marco: perf fixes go into LTS releases
16:01:08 <DaveBarach> #info damjan needs to participate in this discussion
16:07:55 <DaveBarach> #endmeeting