#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:58:48 UTC (full logs).

Meeting summary

    1. agenda additions (DaveBarach, 15:01:57)

  1. CSIT (Maciek reporting) (DaveBarach, 15:02:42)
    1. packetcloud working, congrats to Ed & Ed (DaveBarach, 15:03:10)
    2. as of 18.10, will have proper driver tests (DaveBarach, 15:04:16)
    3. skylake perf trending jobs online (DaveBarach, 15:04:30)
    4. question: would like to do more automated comparisons (DaveBarach, 15:05:07)
    5. question: what else would the community like to have A-B compared? (DaveBarach, 15:05:27)
    6. fib scaling, ACL scaling as examples (DaveBarach, 15:05:52)
    7. Ray K: rx/tx loopback test, already in according to Maciek (DaveBarach, 15:07:58)
    8. patch-to-patch trending job results being analyzed by humans, currently too many false positives to enable voting (DaveBarach, 15:08:53)
    9. dbarach suggests chi-square testing (DaveBarach, 15:11:46)

  2. Honeycomb (Michal C reporting) (DaveBarach, 15:12:03)
    1. a couple of failing tests, expect fixed this week (DaveBarach, 15:12:23)
    2. issues adding L2 fib table entries, Neale looking at it (DaveBarach, 15:12:36)

  3. Host Stack (Florin reporting) (DaveBarach, 15:13:05)
    1. multiple worker bind support working (DaveBarach, 15:13:28)
    2. improving stability and performance (vcl, plus host stack) (DaveBarach, 15:13:44)
    3. merged patch to do multi-arch support for svm fifos, specifically to improve memcpy performance (DaveBarach, 15:14:10)

  4. Documentation (John D, Ray K) (DaveBarach, 15:14:34)
    1. met w/ LF about main website (DaveBarach, 15:14:54)
    2. will need help from Ed Kern, Vanessa to upload per-patch docs (DaveBarach, 15:15:29)
    3. ACTION: John D and Ed Kern to discuss building / moving docs (DaveBarach, 15:15:48)
    4. working with LF marketing folks to change top-level site (DaveBarach, 15:16:29)

  5. aarch64 (Tina T reporting) (DaveBarach, 15:17:59)
    1. mellanox library has issues w/ cmake (DaveBarach, 15:18:18)
    2. VPP-1391 make verify failure (DaveBarach, 15:18:33)
    3. ken from Huawei looking at this failure (DaveBarach, 15:18:46)
    4. vectorization work - patch submitted (DaveBarach, 15:19:01)
    5. dual vs. quad loop worth ~3% in performance (DaveBarach, 15:19:21)
    6. still waiting for power-cycler cost estimate for macciato-bin systems (DaveBarach, 15:20:09)

  6. 18.07 release (DaveBarach, 15:21:02)
    1. 18.07.1 point release done (DaveBarach, 15:21:09)

  7. 18.10 (Marco reporting) (DaveBarach, 15:21:48)
    1. two-week warning email to go out (DaveBarach, 15:22:05)
    2. ACTION: Marco V to send 2-week warning email at midweek (DaveBarach, 15:24:10)
    3. Maciek asks for heads-up on incompatible API changes (DaveBarach, 15:25:15)

  8. LTS releases (Marco V, Damjan) (DaveBarach, 15:29:45)
    1. Suggestion: vpp should stick with dpdk LTS releases (default build) (DaveBarach, 15:30:34)
    2. Damjan says we can start w/ 18.11 (next DPDK LTS release) (DaveBarach, 15:31:21)
    3. Ray asks how do we track dpdk fixes in LTS releases? (DaveBarach, 15:32:17)
    4. Marco: patches make it back into DPDK LTS releases (DaveBarach, 15:33:01)

  9. CentOS / RH Rel toolchain issues (Damjan, DaveB, Tom H, Billy McF) (DaveBarach, 15:37:15)
    1. Tom H: can we see what happens w/ csit if we try gcc-4 (DaveBarach, 15:38:42)
    2. Maciek: csit is Ubuntu-based (DaveBarach, 15:39:04)
    3. Tom H: supposedly CentOS + gcc-4 builds working vpp binaries (DaveBarach, 15:41:20)

  10. Infra (DaveBarach, 15:58:47)
    1. packagecloud transition making progress, nexus still being used (DaveBarach, 15:59:12)
    2. will reenable arm voting for builds but not "make test" (DaveBarach, 16:01:35)
    3. Marco V will be at ONS, who else (DaveBarach, 16:03:21)
    4. Billy McFall will be there (DaveBarach, 16:03:26)


Meeting ended at 16:03:49 UTC (full logs).

Action items

  1. John D and Ed Kern to discuss building / moving docs
  2. Marco V to send 2-week warning email at midweek


People present (lines said)

  1. DaveBarach (52)
  2. collabot (3)
  3. mortderire (1)


Generated by MeetBot 0.1.4.