15:59:14 <DaveBarach> #startmeeting fdio-vpp
15:59:14 <collabot`> Meeting started Tue Nov 13 15:59:14 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:14 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:14 <collabot`> The meeting name has been set to 'fdio_vpp'
16:05:30 <DaveBarach> #topic CSIT (Maciek reporting)
16:05:49 <DaveBarach> #info 18.10 report released on time
16:07:39 <mackonstan> #info mackonstan
16:08:01 <mackonstan> #info VPP performance graphs
16:08:13 <mackonstan> #topic http://bit.ly/2OwQPEn
16:08:28 <mackonstan> #topic Throughput:
16:08:35 <DaveBarach> #link  http://bit.ly/2OwQPEn
16:08:49 <mackonstan> #topic Speedup Multi-Core:
16:08:56 <mackonstan> #link http://bit.ly/2zztqgi
16:09:01 <DaveBarach> #info better job on multicore
16:09:18 <mackonstan> #info Latency:
16:09:27 <DaveBarach> #info should be able to tell NIC/PCIe vs. software limitation
16:09:28 <mackonstan> #link http://bit.ly/2F9j4K6
16:10:03 <DaveBarach> #info ip4/6 paths show near linear scaling, others not so much
16:10:14 <mackonstan> #info VPP performance comparisons
16:10:24 <mackonstan> #link http://bit.ly/2RGBvXM
16:10:48 <DaveBarach> #info imix better on vhost
16:12:16 <DaveBarach> #topic Honeycomb (Michal Cmarada reporting)
16:12:25 <DaveBarach> #info HC released
16:12:45 <DaveBarach> #info nexus images OK, some issue w/ packagecloud
16:13:54 <DaveBarach> #topic host stack (Florin reporting)
16:14:21 <DaveBarach> #info Cubic congestion control merged
16:14:48 <DaveBarach> #info Fast recovery improvements on the TCP path: improve ack traffic handling
16:15:21 <DaveBarach> #info able to saturate a 40gbit interface!
16:15:49 <DaveBarach> #info more cubic-related patches on the way
16:17:47 <DaveBarach> #topic 18.10 release (Marco V reporting)
16:18:14 <DaveBarach> #info pretty painful, could use a post-mortem to learn about issues
16:18:59 <DaveBarach> #info a couple of patches merged on stable/18.10
16:19:39 <DaveBarach> #info issues with Nexus server: permissions -> upload failures
16:20:05 <DaveBarach> #info jar files weren't right
16:20:26 <DaveBarach> #info not entirely clear where the (incorrect) jar files came from
16:21:38 <DaveBarach> #action dbarach to set up call w/ Marco, Ed to document detailed issues
16:23:11 <DaveBarach> #info +florin on post-mortem call
16:23:42 <DaveBarach> #topic python 3 transition discussion (Marco V)
16:24:14 <DaveBarach> #info end of 2019, python2 will be end-of-life; big deal for downstream distros
16:26:40 <DaveBarach> #action dbarach to send email w.r.t. switching to python3
16:29:22 <DaveBarach> #topic old stats API discussion
16:30:39 <mortderire> I am here - eventually, and still alive.
16:32:27 <DaveBarach> #action otroan email vpp-dev with stake in the ground as to when the old stats APIs will vanish
16:33:21 <DaveBarach> #topic Nexus vs. packagecloud
16:33:40 <DaveBarach> #info Ed Kern: packages go to both places
16:34:04 <DaveBarach> #info Nexus causes O(99%) of the reported issues
16:35:16 <DaveBarach> #action Ed K will look at jar file locations
16:36:06 <DaveBarach> #info release process for Nexus is about 90% script-based, 10% manual. Issues from the 10% manual portion
16:49:42 <DaveBarach> #topic ed kern reports xenial memory spikes killing containers fixed and/or worked around...
16:50:51 <DaveBarach> #endmeeting