16:01:38 <DaveBarach> #startmeeting fdio-vpp
16:01:38 <collabot> Meeting started Tue Mar  5 16:01:38 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:38 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:38 <collabot> The meeting name has been set to 'fdio_vpp'
16:03:09 <mackonstan> #info mackonstan
16:03:17 <DaveBarach> #topic csit (maciek reporting)
16:03:37 <mackonstan> #info CSIT-1901 maintenance report published last week, main delta is addition of VPP link bonding test results after two fixes applied
16:03:53 <mackonstan> #link https://docs.fd.io/csit/rls1901/report/index.html
16:05:11 <DaveBarach> #info 1-button install for csit testing (yay!)
16:05:12 <mackonstan> #info CSIT work in progress: test suite auto-generation (adding NIC variations, throughput methodologies), testbed auto-installer, VAT to PAPI migration.
16:05:44 <mackonstan> #info VPP IPSec tests went broken after API changes, now fixed
16:06:16 <mackonstan> #info Looking for an automated way to address the client-side VPP API versions and change awareness, started to work with Dave W. on a proposal
16:06:20 <DaveBarach> #info try to catch API changes which break CSIT tests
16:06:33 <mackonstan> #info Some VPP master trending failures, working on root causing that
16:06:46 <mackonstan> #link https://docs.fd.io/csit/master/trending/introduction/failures.html
16:07:07 <mackonstan> #info New testbeds: Arm and Atom testbeds are still onboarding, LFN DC dependencies
16:07:25 <DaveBarach> #topic Honeycomb (Michal reporting)
16:07:39 <DaveBarach> #info working on bionic jobs for HC / jvpp
16:07:53 <DaveBarach> #info now have official bionic images
16:08:41 <DaveBarach> #topic Host Stack (Florin reporting)
16:08:47 <DaveBarach> #info session layer cleanups
16:09:09 <DaveBarach> #info refactor of local sessions into a cut-through transport
16:09:24 <DaveBarach> #info helps unify interaction between apps and sessions
16:09:44 <DaveBarach> #topic Documentation (John D. reporting)
16:09:52 <DaveBarach> #info not heard anything this week
16:10:29 <DaveBarach> #topic ARM (Sirshak reporting)
16:10:42 <DaveBarach> #info svm fifo rework / review in progress
16:11:34 <DaveBarach> #info summary: change from cursize -> head/tail manipulation
16:12:13 <DaveBarach> #topic 19.01 release
16:12:35 <DaveBarach> #info a couple of fixes which necessitate a dot release
16:12:45 <DaveBarach> #info iommu patch
16:12:54 <DaveBarach> #info crypto-dev / ipsec patch
16:13:10 <DaveBarach> #info cherry-picks are done for these
16:13:47 <DaveBarach> #action dbarach to ask andrew when we can cut a 19.01.01 release
16:16:53 <DaveBarach> #action dwallace to cut 19.01.01 point release (backup for Andrew)
16:17:37 <DaveBarach> #topic 19.04 release (Dave W)
16:17:45 <DaveBarach> #info please update wiki feature list
16:18:20 <DaveBarach> #info approx 4 week from FC0 (api freeze)
16:18:53 <DaveBarach> #topic Python 3.0 transition (Dave Wallace)
16:19:18 <DaveBarach> #info test framework, packaging in progress
16:19:58 <DaveBarach> #info Paul V owns most of the work, not clear we'll be able to switch for 19.04
16:20:30 <DaveBarach> #action Ole to ask Paul V to update vpp-dev w/ current status
16:21:08 <DaveBarach> #info test framework support for Python-2 can end soon, but probably not 19.04
16:25:02 <DaveBarach> #topic Coverity
16:25:08 <DaveBarach> #info please clean up ipsec
16:26:02 <DaveBarach> #topic Infra / patch validation (Ed Kern)
16:26:44 <DaveBarach> #info 2x jenkins "accidents" fixed by Vexhost migrating the jenkins vm
16:27:31 <DaveBarach> #info this led to two bursts of rechecks.
16:33:42 <DaveBarach> #endmeeting