#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:01:08 UTC (full logs).

Meeting summary

  1. csit Maciek reporting (DaveBarach, 15:02:11)
    1. CSIT-1901.1 maintenance report to be published shortly (mackonstan, 15:02:26)
    2. Update on major work items: (mackonstan, 15:03:07)
    3. test suite auto-gen completed (any NIC variations, any throughput methodologies), (mackonstan, 15:03:29)
    4. VAT to PAPI migration in full swing, introduced "thin-VM" for all vhost tests. (mackonstan, 15:04:06)
    5. Tracking and verifying VPP API/PAPI changes - see gerrit link, discussion later led by Dave Wallace (mackonstan, 15:04:38)
    6. https://gerrit.fd.io/r/#/c/18356/ (mackonstan, 15:04:44)

  2. host stack (Florin) (DaveBarach, 15:07:37)
    1. switch to cut-through transport vs. apps mapping multi-queues (DaveBarach, 15:08:24)
    2. lots of cleanup patches pushed (DaveBarach, 15:08:36)
    3. consolidate generation of tcp packets, setup work for a more generalized pacing scheme (DaveBarach, 15:09:05)

  3. Docs (DaveBarach, 15:09:53)
    1. Paul V reports make test docs already in the tree (DaveBarach, 15:11:28)
    2. ACTION: dbarach to chase down releasing test docs through usual "make docs" run (DaveBarach, 15:12:58)

  4. Arm (Sirshak reporting) (DaveBarach, 15:13:31)
    1. cache-line size 128 (thx2) packaging issue (DaveBarach, 15:14:08)
    2. build from source => host (DaveBarach, 15:20:34)
    3. Damjan suggest aligining thread structures to 128 to reduce the pain involved (DaveBarach, 15:21:33)

  5. Releases (Dave Wallace reporting) (DaveBarach, 15:22:15)
    1. 19.01.1 released (DaveBarach, 15:22:22)
    2. request for 19.01.2 to add patches (DaveBarach, 15:22:41)
    3. csit cycles are a rate limiter. Once we get to 3/27, won't be able to spend csit resources on 19.01.X (DaveBarach, 15:23:12)
    4. need to track down who needs 19.01.2 and work with them offline (DaveBarach, 15:24:14)
    5. sounds like Yichen and company (DaveBarach, 15:27:42)
    6. we need to close this before next Weds. (DaveBarach, 15:28:08)
    7. ACTION: dbarach to facilitate email offline (DaveBarach, 15:28:18)

  6. 19.04 (Dave Wallace) (DaveBarach, 15:29:33)
    1. reminder of F0 (API freeze) date 4/3/2019 (DaveBarach, 15:29:56)

  7. Python3.0 transition (Dave Wallace) (DaveBarach, 15:30:58)
    1. leave 2.7 support in place until 3.0 hardening done (DaveBarach, 15:31:25)
    2. Paul V: 2.7 not removed except in Makefiles (DaveBarach, 15:31:53)
    3. planning to switch in the 19.08 time frame (DaveBarach, 15:32:23)
    4. documentation runs (only) in 3.0 (DaveBarach, 15:32:35)
    5. vppapigen runs over Py v3 (DaveBarach, 15:32:49)
    6. requirements.txt controls the Py version (DaveBarach, 15:33:30)
    7. Py 2 => 2.7 only. Py 3 => 3.5...3.8 or similar (DaveBarach, 15:36:05)
    8. easier to go to 3.6 or above (DaveBarach, 15:36:46)

  8. API Flag Day (Dave Wallace) (DaveBarach, 15:54:26)
    1. try to avoid having csit-incompatible API patches merged (DaveBarach, 15:54:51)
    2. identify / notify vpp API changes (DaveBarach, 15:55:07)


Meeting ended at 16:03:55 UTC (full logs).

Action items

  1. dbarach to chase down releasing test docs through usual "make docs" run
  2. dbarach to facilitate email offline


People present (lines said)

  1. DaveBarach (36)
  2. mackonstan (6)
  3. collabot (3)


Generated by MeetBot 0.1.4.