#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:59:28 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:01:12)
    1. CSIT rls1904 branch pulled, dry runs of vpp-19.04 starting (mackonstan, 15:02:25)
    2. Content of CSIT-1904 in wiki (mackonstan, 15:02:41)
    3. https://wiki.fd.io/view/CSIT/csit1904_plan (mackonstan, 15:02:46)
    4. Two issues in trending: (mackonstan, 15:02:56)
    5. i) IPsec tunnel-interface test failures, VPP fix https://gerrit.fd.io/r/#/c/18834/ to be verified (mackonstan, 15:03:03)
    6. ii) VPP with DPDK driving physical interfaces: packets not passing in VPP configs with large number of rx queues and workers (over 16rxq/multi-queues) that require high values of buffers-per-numa, resolution in progress. The same tests with native VPP AVF driver work fine. (mackonstan, 15:03:49)

  2. Honeycomb (Michal C reporting) (DaveBarach, 15:05:00)
    1. tomorrow code freeze for 19.04 (DaveBarach, 15:05:07)

  3. Host Stack (florin c reporting) (DaveBarach, 15:05:26)
    1. 19.04 host stack stable (DaveBarach, 15:05:38)
    2. 19.08 development: refactor svm infra to support dynamic fifo sizing (DaveBarach, 15:06:14)
    3. autotuning algorithm not currently in-scope (DaveBarach, 15:06:34)
    4. fifos need to change. Thanks Sirshak for help (DaveBarach, 15:07:18)
    5. added a basic rb-tree implementation to vppinfra (DaveBarach, 15:07:28)

  4. aarch64 (Sirshak) (DaveBarach, 15:08:43)
    1. removing 2**n fifo size restriction in patch (DaveBarach, 15:08:56)
    2. packaging change patch ready for review 19.08 delivery (DaveBarach, 15:09:28)

  5. 19.01 (Dave Wallace) (DaveBarach, 15:10:02)
    1. require 19.01.2, to start after 19.04 formal release, first week of May (DaveBarach, 15:10:27)

  6. 19.04 (Dave Wallace) (DaveBarach, 15:10:43)
    1. RC1 last week (DaveBarach, 15:10:47)
    2. a number of issues found + fixed, will update document / cookbook (DaveBarach, 15:11:02)
    3. freezing master [we don't really need to] (DaveBarach, 15:11:22)
    4. label position requirements will be documented (DaveBarach, 15:11:40)
    5. next time, we should need to freeze master for about ten minutes (DaveBarach, 15:12:35)
    6. issue w/ centos validation, thanks to tom/billy for help straightening it out (DaveBarach, 15:14:55)
    7. we don't have a patch validation requirement for centos. Workaround: hand-install packages (DaveBarach, 15:15:34)
    8. a hole when we install new features (DaveBarach, 15:16:08)
    9. Tom H has a patch ready for the spec file (DaveBarach, 15:16:23)
    10. minor issues: csit midly confused by labels, initial merge jobs failing because packagcloud repo had nothing in the "bionic" section (DaveBarach, 15:20:12)
    11. merge job failing because base pkg repo add uses master for dependencies, need to uninstall before trying to make 19.04 version (DaveBarach, 15:21:23)
    12. name of the next release discussion, cadence (DaveBarach, 15:22:17)
    13. any issue w/ revising the release cadence to 3/yr, aka 4 months (DaveBarach, 15:22:38)
    14. Considering a 12/18 formal release date (DaveBarach, 15:28:35)
    15. AGREED: release cadence going forward will be xx.1 xx.5 xx.9, with 19.08 as planned (DaveBarach, 15:32:33)
    16. RC2 tomorrow, please get fixes in ASAP, must have JIRA ticket numbers (DaveBarach, 15:33:36)

  7. Infra Status (Ed Kern reporting) (DaveBarach, 15:34:49)
    1. minor latency spike this morning (DaveBarach, 15:34:58)
    2. will release old arm nodes shortly (DaveBarach, 15:35:11)
    3. will update servers which have been up for > 300 days (DaveBarach, 15:35:39)


Meeting ended at 15:38:38 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. DaveBarach (37)
  2. mackonstan (6)
  3. collabot (3)


Generated by MeetBot 0.1.4.