15:01:14 <mackonstan> #startmeeting FD.io VPP meeting
15:01:14 <collabot`> Meeting started Tue Aug 20 15:01:14 2019 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:14 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:14 <collabot`> The meeting name has been set to 'fd_io_vpp_meeting'
15:01:44 <mackonstan> #info mackonstan
15:02:03 <mackonstan> #topic CSIT project - Maciek updates
15:02:11 <mackonstan> #info Lots of infra work completed:
15:02:20 <mackonstan> #info - VPP API gating with CRC checks ./job/vpp-csit-verify-api-crc-master/
15:03:03 <DaveBarach> Does anyone else see this?
15:03:14 <mackonstan> #info - VAT to PAPI migration, scale tests still require VAT
15:04:10 <mackonstan> #info - RF L2 Keywords alignment across 2-node and 3-node test topologies
15:04:32 <mackonstan> #info - migration of remaining VIRL functional tests to vpp_device container based test environment
15:05:05 <mackonstan> #info - Arm (Taishan) and Atom (Denverton) test environment CI/CD onboarding
15:05:19 <mackonstan> #info - Hardware failures: SSDs keep dying on us, but being replaced swiftly
15:05:29 <mackonstan> #info Quite a few new test cases:
15:05:47 <mackonstan> #info IPsec, dot1q+vxlan+vhost and http/tcp tests are back
15:05:54 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1908_plan
15:06:03 <mackonstan> #info vpp v19.08 rc1/rc2 dry runs, few issues spotted
15:06:16 <mackonstan> #info csit fixed: 3n-skx avf tests, 2link bonding, cleaning topology after avf tests
15:06:28 <mackonstan> #info open issues:
15:06:36 <mackonstan> #info - papi dump calls, remote socket connection not opening, intermittent, affects ~3% of tests
15:06:52 <mackonstan> #info - memif activation failures, intermittent
15:07:01 <mackonstan> #info - avf activation failures, intermittent
15:07:28 <mackonstan> #info vpp master trending issues:
15:07:37 <mackonstan> #info - all fib scale tests failing, tracked by: https://jira.fd.io/browse/VPP-1743, suspect: https://gerrit.fd.io/r/c/vpp/+/20004
15:10:09 <DaveBarach> #topic Host Stack (Florin reporting)
15:10:30 <DaveBarach> #info bunch of host-stack cherry-picks into 19.08
15:10:48 <DaveBarach> #info one more patch needed before 19.08
15:11:31 <DaveBarach> #topic Documentation (John D reporting)
15:11:48 <DaveBarach> #info meeting this afternoon w/ Ray
15:12:03 <DaveBarach> #info by the end of the week, goal: ready to go live
15:13:36 <DaveBarach> #topic aarch64 (Honnappa reporting)
15:13:54 <DaveBarach> #info tap interface issue root-caused, need to test patch
15:14:01 <DaveBarach> #info dual-loop being tested
15:15:31 <DaveBarach> #info bihash writeup coming
15:15:57 <DaveBarach> #topic 19.04 (Dave W reporting)
15:16:05 <DaveBarach> #info no schedule maint release in the near future
15:16:24 <DaveBarach> #topic 19.08 release (Andrew reporting)
15:16:34 <DaveBarach> #info on track for formal release tomorrow
15:17:22 <DaveBarach> #info discussion of release notes
15:19:07 <DaveBarach> #info John D to sync up w/ Andrew and decide what to do about release notes
15:21:00 <DaveBarach> #action Andrew to construct automation to look for missing cherry-picks into 19.08
15:22:12 <DaveBarach> #topic API changes
15:22:38 <DaveBarach> #info api checker merged, problems to Dave Wallace and/or Andrew Yourtchenko
15:31:29 <DaveBarach> #topic infra (Ed Kern)
15:31:52 <DaveBarach> #info make-test parallelization has been a big improvement
15:32:46 <DaveBarach> #action Ed Kern to turn on make-test parallelization in master/latest validation
15:34:16 <DaveBarach> #info some jobs hanging on log upload, mumble LF infra mumble
15:34:33 <DaveBarach> #info under investigation, if people notice pls ping Ed Kern
15:35:18 <DaveBarach> #info SSD errors causing individual machines to fail
15:37:27 <DaveBarach> #action EJK to invent a functional equivalent for "recheck" for database query purposes
15:43:37 <DaveBarach> #endmeeting
15:44:04 <DaveBarach> hey maciek try ending the meeting
15:44:32 <DaveBarach> #chair DaveBarach
16:10:10 <mackonstan> #endmeeting