15:01:34 <DaveBarach> #startmeeting fdio-vpp
15:01:34 <collabot`> Meeting started Tue Sep  3 15:01:34 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:34 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:34 <collabot`> The meeting name has been set to 'fdio_vpp'
15:02:44 <mackonstan> #topic CSIT project - Maciek updates
15:03:36 <mackonstan> #info Daily perf tests - failures:
15:03:53 <DaveBarach> #info daily perf runs throttled back due to 19.08 CSIT report generation / testbed capacity
15:03:59 <mackonstan> #info - papi dump calls, remote socket connection not opening, intermittent, affects ~3% of tests
15:04:12 <mackonstan> #info - memif activation failures, intermittent
15:04:23 <mackonstan> #info - avf activation failures, intermittent
15:04:34 <mackonstan> #info CSIT-1908 release status
15:04:45 <mackonstan> #info Draft version of CSIT-1908 test and benchmarking report is available on the CSIT master report link
15:04:58 <mackonstan> #link https://docs.fd.io/csit/master/report/index.html
15:05:19 <mackonstan> #info Most tests on Xeon, Atom and Arm testbed are completed, some are finishing tomorrow
15:05:32 <mackonstan> #info Some VPP throughput regressions and progressions spotted - see my email to vpp-dev and csit-dev yesterday
15:05:54 <mackonstan> #info Some are CSIT, some look like VPP, see latest analysis in CSIT gerrit commits:
15:06:01 <mackonstan> #info - csit1908_perf_analysis_2n_skx.md: https://gerrit.fd.io/r/c/csit/+/21637/
15:06:09 <mackonstan> #info - csit1908_perf_analysis_3n_skx.md: https://gerrit.fd.io/r/c/csit/+/21641/
15:06:16 <mackonstan> #info "Official" CSIT-1908 report will be published tomorrow, on schedule :)
15:06:21 <mackonstan> #link https://docs.fd.io/csit/rls1908/report/index.html
15:06:27 <mackonstan> #info Will send announce email per usual
15:07:15 <DaveBarach> #topic Host Stack (Florin reporting)
15:07:32 <DaveBarach> #info moving control API calls from binary API to the host stack message queue
15:08:00 <DaveBarach> #info old APIs are still operational, planning to remove them post 20.01
15:08:22 <DaveBarach> #info async / non-blocking connect added for Envoy
15:08:34 <DaveBarach> #info TCP improved mss handling for v4, v6
15:09:05 <DaveBarach> #info if anyone is interested in host-stack crypto, Nathan has been working on it for TLS
15:09:58 <DaveBarach> #info simon @ intel has a TSO patch in progress -major vector rate reduction for TX side
15:10:22 <DaveBarach> AKA yulong...
15:13:36 <DaveBarach> #topic Documentation (John, Ray)
15:13:50 <DaveBarach> #info RX marketing section feeback from Ray
15:16:17 <DaveBarach> #action jdenisco to try to pick a cut-over date
15:17:23 <DaveBarach> #topic aarch64 (Honnapa reporting)
15:17:41 <DaveBarach> #info dual-loop optimization, bihash optimization in progress
15:18:04 <DaveBarach> #topic 19.04 (Dave Wallace)
15:18:25 <DaveBarach> #info few patches no formal release planned at this time
15:18:46 <DaveBarach> #topic 19.08 (Andrew reporting)
15:18:56 <DaveBarach> #info 8 commits merged since formal release
15:20:04 <DaveBarach> #info possible change to api string type
15:20:09 <DaveBarach> #info question: can we merge it
15:26:48 <DaveBarach> #action ole hook up with ray to discuss the vppapigen VLA issue
15:27:48 <DaveBarach> #info "while we're at it" a couple of memif API issues could be resolved
15:28:29 <DaveBarach> #info zero-copy control disappeared, could fix it
15:33:35 <DaveBarach> #topic API changes
15:34:00 <DaveBarach> #info jerome: about to release vpp 19.08 openstack
15:35:39 <DaveBarach> #info acl add/replace had a CRC change - name of type of acl rule type caused the change
15:46:26 <dwallacelf> #link https://gerrit.fd.io/r/q/project:vpp+is:open+path:%5E.*/.api
15:47:37 <dwallacelf> #info Please ignore previous link -- it doesn't work with latest gerrit version.
15:49:50 <DaveBarach> #topic infra (Ed K)
15:50:01 <DaveBarach> #info "runtest" = "recheck,"
15:50:42 <mortderire> Need to run
15:52:16 <DaveBarach> #endmeeting