15:00:48 <DaveBarach> #startmeeting fdio-vpp
15:00:48 <collabot> Meeting started Tue Oct 15 15:00:48 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:48 <collabot> The meeting name has been set to 'fdio_vpp'
15:02:14 <DaveBarach> #topic CSIT (Maciek reporting)
15:02:47 <mackonstan> #info Daily perf tests - regular failures with artefacts upload and download to/from Nexus, issue worked by Vanessa/EdK
15:03:27 <mackonstan> #info CSIT-1908.1 maintenance release report published
15:03:34 <mackonstan> #link https://docs.fd.io/csit/rls1908_1/report/index.html
15:03:51 <mackonstan> #info CSIT-2001 plan - see highlights in minutes from last week csit project call
15:03:59 <mackonstan> #link http://ircbot.wl.linuxfoundation.org/meetings/fdio-csit/2019/fdio-csit.2019-10-09-14.04.html
15:04:07 <mackonstan> #info Will port to wiki shortly
15:04:15 <mackonstan> #info Current work areas:
15:04:42 <mackonstan> #info Infra/Framework: migration to Python 3.x, unprivileged VPP, higher latency resolution with HDRhistogram , auto-bisecting of perf regressions
15:05:17 <mackonstan> #info Testbeds: adding 100GE MLX5 NICs, Xeon CascadeLakes, more Arm ThunderX servers
15:05:36 <mackonstan> #info New tests: IPSec container tests, more coming
15:06:05 <DaveBarach> #topic host stack (Florin reporting)
15:06:35 <DaveBarach> #info TCP loss-recovery w/ lossy connections
15:07:17 <DaveBarach> #info Nathan patches to add app-layer certificate store
15:07:52 <DaveBarach> #topic Documentation (John D reporting)
15:08:30 <DaveBarach> #Info automate sphinx doc upload to netlify for auto inclusion in the main fd.io site
15:10:37 <alagalah> hello
15:10:41 <DaveBarach> #topic Release Management (Andrew, DaveW reporting)
15:11:00 <DaveBarach> #info 19.08 lagging master by a week-and-a-half
15:11:59 <DaveBarach> #info 19.04 has some cherry-picks above 19.04.2
15:12:08 <DaveBarach> #info no obvious pressure to cut 19.04.3
15:12:59 <DaveBarach> #info may need to recheck patches due to csit trigger malfunction
15:13:32 <DaveBarach> #action dbarach to remove API check item from agenda
15:14:11 <DaveBarach> #info 20.01 release plan F0: 1/8/2020
15:14:26 <DaveBarach> #info formal release 1/29/2020
15:16:13 <DaveBarach> #topic infra
15:16:24 <DaveBarach> #agreed remove 16.04 validation job
15:17:01 <DaveBarach> #info discussion of LF outage since last meeting
15:17:37 <DaveBarach> #info difficult to root-cause, multiple symptoms
15:18:50 <DaveBarach> #info nexus timeout issues continue
15:19:52 <DaveBarach> #info more CentOS package changes
15:20:16 <DaveBarach> #info having to hand-build ruby, etc. etc.
15:20:32 <DaveBarach> #info drift between "stock" CentOS and our build environment
15:22:44 <DaveBarach> #info question: what's the maintenance story for CentOS
15:23:55 <DaveBarach> #action dbarach to take CentOS EOL discussion to the TSC
15:29:04 <DaveBarach> #topic make test/test-debug (Andrew)
15:31:21 <DaveBarach> #info improved test fails due to
15:33:43 <DaveBarach> #topic py3 make test conversion (Dave W)
15:33:54 <DaveBarach> #info does the process have an owner?
15:34:45 <DaveBarach> #info hope to finish the transition in time for 20.01
15:37:12 <alagalah> pyenv ?
15:38:57 <DaveBarach> #endmeeting