15:59:21 <DaveBarach> #startmeeting fdio-vpp
15:59:21 <collabot`> Meeting started Tue Dec 10 15:59:21 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:21 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:21 <collabot`> The meeting name has been set to 'fdio_vpp'
16:03:00 <DaveBarach> #topic CSIT (Maciek reporting)
16:03:33 <DaveBarach> #info infra - upgrades happening, minor issues
16:03:47 <DaveBarach> #info Migration to Python3 complete
16:04:09 <DaveBarach> #info Please report any Python3 anomalies
16:04:25 <DaveBarach> #info added packet latency stats
16:04:38 <DaveBarach> #info Mellanox-4 tests added to physical testbeds
16:04:48 <DaveBarach> #info ip4/ip6 fib scale tests added
16:05:08 <DaveBarach> #info Vratko has perf test bisection working
16:05:13 <DaveBarach> #info on target for 20.01
16:05:57 <DaveBarach> #info TCP/Quicc test added, nsim added
16:07:03 <DaveBarach> #topic Host Stack (Florin reporting)
16:07:17 <DaveBarach> #info tcp checksum offload config option added
16:07:53 <DaveBarach> #info will add APIs to request checksum offload on/off for specific connections
16:08:16 <DaveBarach> #info control useful when combined w/ ipsec
16:08:37 <DaveBarach> #info tcp timer handler issue: stop all timers, only afterwards call handlers
16:08:48 <DaveBarach> #info some improvements to the pacer
16:09:40 <DaveBarach> #info binary API improvements w/ Dave to support multiple binary API connections per process
16:10:21 <DaveBarach> #info need to merge one or two more patches to finish BinAPI threading work
16:11:37 <DaveBarach> #topic Documentation (John D)
16:11:58 <DaveBarach> #info cleaning up commmand-line args documentation
16:13:06 <DaveBarach> #info maybe don't want to auto-push doc updates
16:13:16 <DaveBarach> #info script in doc/scripts,
16:13:52 <DaveBarach> #topic Releases (Andrew, Dave W)
16:14:34 <DaveBarach> #info API freeze coming up
16:14:41 <DaveBarach> #info for 20.01
16:15:43 <DaveBarach> #Info 19.08.2 - csit add 19.08 (perf) trending jobs?
16:16:02 <DaveBarach> #info no plan, maybe we need one?
16:16:44 <DaveBarach> #info December shutdown, if we want to do a 19.08.2 release we need to do it in the next 2 weeks or postpone until February
16:18:19 <DaveBarach> #info 19.04.3 shipped, two patches since then, probably won't do a 19.04.4
16:19:25 <DaveBarach> #info JDenisco asks if we can update docs to be sure we don't need e.g. 20.01 related changes
16:19:55 <DaveBarach> #action jdenisco, dwallace, ayourtch to meet briefly
16:20:55 <DaveBarach> #topic Infra (Ed K)
16:21:48 <DaveBarach> #info a bunch of upgrades / OS update
16:22:35 <DaveBarach> #info may see the word "suspended", should make no fundamental difference
16:23:07 <DaveBarach> #info reducing to a single cluster, should improve stability
16:23:56 <DaveBarach> #info CentOS 8 trial job to be added, will revisit in January
16:26:26 <DaveBarach> #topic New Project request (ping@intel, florin)
16:26:41 <DaveBarach> #info host-stack accelerated applications
16:26:52 <DaveBarach> #info start with nginx
16:26:57 <DaveBarach> #info may add envoy
16:28:38 <DaveBarach> #info discussion about how to package modified apps so we don't cause package conflicts
16:32:29 <DaveBarach> #endmeeting