16:04:45 <DaveBarach> #startmeeting fdio-vpp
16:04:45 <collabot`> Meeting started Tue Jan 14 16:04:45 2020 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:45 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:04:45 <collabot`> The meeting name has been set to 'fdio_vpp'
16:04:59 <DaveBarach> #topic CSIT (Maciek)
16:05:16 <mackonstan> #info move to Python 3.x completed
16:06:47 <mackonstan> #info VAT still used for fib scale tests and will be fixed in PAPI with Python3.x after CSIT-2001
16:07:10 <mackonstan> #info removed stale test code: HoneyComb, NSH_SFC, DMM, TLDK
16:07:23 <mackonstan> #info some highlights of work done and in CSIT production
16:07:32 <mackonstan> #info added per packet latency measurements resolution using TRex plus HDRhistogram
16:07:59 <mackonstan> #info added IPv4 and IPv6 FIB scale tests with random flows
16:08:10 <mackonstan> #info added 100GE MLX5 NICs tests using suite generator so all tests are now supported, waiting for performance optimized rdma-core driver from Benoit, no pressure, to properly benchmark 100GE
16:08:31 <mackonstan> #info number of other items progressed towards closure and ship for CSIT-2001 release
16:08:39 <mackonstan> #info CSIT-2001 plan tracked on wiki, will be updated with the latest status before CSIT call tomorrow
16:08:47 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit2001_plan
16:08:56 <mackonstan> #info tomorrow pulling CSIT-2001 branch from master, per rc1 milestone (aligned with VPP project timetable)
16:10:24 <DaveBarach> #topic release management
16:10:42 <DaveBarach> #info 20.01 on schedule, RC1 throttle pull tomorrow
16:11:26 <DaveBarach> #info 19.08.2 planned after 20.01 release
16:11:40 <DaveBarach> #info planning to put csit trending job in place
16:12:02 <DaveBarach> #action remove 19.04 from agenda
16:16:58 <mackonstan> #info one more update from CSIT
16:17:32 <mackonstan> #info Upgrade from from Ubuntu 18.04 LTS kernel 4.15.0-66 to Ubuntu 18.04 LTS kernel 4.15.0-72, introduced Xeon Processors’ ucode update increasing coverage to known (but not all announced) meltdown-spectre vulnerabilities (CSIT code is tracking those by executing spectre-meltdown-checker as part of the test suite). Skylake impact at 2-3%, Cascadelake impact at >30% !
16:17:48 <DaveBarach> thanks. Maciek...
16:18:39 <mackonstan> np!
16:20:22 <DaveBarach> #info Note that FEATURE.yaml files are published through fd.io, so please look at spelling, etc.
16:23:26 <DaveBarach> #topic Host Stack (Florin)
16:24:03 <DaveBarach> #info TCP port reuse supported for connections in TIMEDWAIT state
16:24:27 <DaveBarach> #info a bunch of small fixes
16:24:51 <DaveBarach> #info Coming Soon: major refactor of shared-memory FIFOs.
16:25:41 <DaveBarach> #info will not ship in 20.01
16:27:23 <DaveBarach> #info goal: to improve memory-scaling
16:28:17 <DaveBarach> #topic Documentation (John D)
16:28:24 <DaveBarach> #info whitepaper page
16:31:24 <DaveBarach> #endmeeting