16:01:25 <DaveBarach> #startmeeting fdio-vpp
16:01:25 <collabot`> Meeting started Tue Feb 11 16:01:25 2020 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:25 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:25 <collabot`> The meeting name has been set to 'fdio_vpp'
16:01:52 <DaveBarach> #topic CSIT (Maciek reporting)
16:02:28 <DaveBarach> #info 20.01 report expected tomorrow or Thursday, maybe 1 day late
16:02:54 <DaveBarach> #info Report will include pkt latency graphs
16:03:32 <DaveBarach> #info microcode upgrades for Spectre / Meltdown has had bad effects on Skylake, Cascade Lake
16:03:56 <DaveBarach> #info Intel recommendation is to revert microcode
16:04:48 <DaveBarach> #info will include release note to describe why we're not releasing Cascade Lake / Skylake data
16:05:50 <DaveBarach> #info skylake 5% perf hit, cascade lake 30% perf hit
16:06:45 <DaveBarach> #info Intel has reproduced the ucode issues, reproduced across a range of hardware platforms
16:07:11 <DaveBarach> #topic Host Stack (Florin reporting)
16:07:49 <DaveBarach> #info starting to add NUMA-aware fifo memory allocation
16:08:08 <DaveBarach> #info VCL udp support working well
16:08:24 <DaveBarach> #info also a number of misc fixes
16:08:54 <DaveBarach> #info major svm fifo refactor to reduce memory consumption. Patches published but not merged
16:09:06 <DaveBarach> #info plan to eventually support fifo-size autotuning
16:09:33 <DaveBarach> #info optimizing codebase for > 1M session scale cases
16:10:22 <DaveBarach> #topic Release Management(Dave Wallace)
16:10:29 <DaveBarach> #info 20.01 released on schedule
16:10:43 <DaveBarach> #info next release will be 20.05
16:11:03 <DaveBarach> #action Andrew to publish plan, etc. by March meeting
16:11:48 <DaveBarach> #info 19.08.1 is current, we've deferred 19.08.2 until now. Plan to coordinate test w/ csit community so we have perf trending info
16:12:11 <DaveBarach> #info expect 19.08.2 in the next couple of weeks
16:12:36 <DaveBarach> #topic Infra (Ed K reporting)
16:13:26 <DaveBarach> #info LF needs to schedule monthly updates, would like to do updates next week. Requires outages, etc.
16:13:55 <DaveBarach> #info Note LF infra support wiki page:
16:14:05 <DaveBarach> #link https://wiki.fd.io/view/Infrastructure_Support
16:15:12 <DaveBarach> #info packagecloud image release process, vpp already doing the right things, etc.
16:16:30 <DaveBarach> #info hicn project was accidentally filling the release directory with >10,000 images, etc.
16:19:01 <DaveBarach> #info Keyword "betacheck" will trigger Jenkins Ubuntu 20.04 / CentOS-8 jobs
16:22:35 <DaveBarach> #topic Documentation (John D)
16:23:27 <DaveBarach> #info LFN marketing still working on a blog post vis a vis 20.01.
16:24:11 <DaveBarach> #info whitepaper on its way. John DeGiglio involved, LFN project descriptions
16:24:54 <DaveBarach> #info 19.08, 19.04 doc merge jobs currently failing, Dave W and John D to address
16:25:25 <DaveBarach> #action Dave W / John D to address 19.08, 19.04 merge jobs
16:26:33 <DaveBarach> #topic aarch64 Juraj cross-compilation topic
16:44:10 <DaveBarach> #action dbarach to ask LF about a coverity license (TSC Thursday)
16:48:28 <DaveBarach> #topic HQoS support in fd.io (Ray, Steven Byrne)
16:49:08 <DaveBarach> #info original implementation was bolted together
16:49:18 <DaveBarach> #info want to do a 2.0 integration now
16:49:28 <DaveBarach> #info with actual maintenance, ownership
16:50:48 <DaveBarach> #info looking to have a next-stage technical / design
16:59:22 <DaveBarach> #action Steve Byrne to setup tech deep dive on hqos
16:59:52 <DaveBarach> #endmeeting