15:00:57 <DaveBarach> #startmeeting fdio-vpp
15:00:57 <collabot`> Meeting started Tue Apr 14 15:00:57 2020 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:57 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:57 <collabot`> The meeting name has been set to 'fdio_vpp'
15:03:33 <DaveBarach> #topic CSIT (Maciek reporting)
15:03:52 <mackonstan> #info CSIT-2001 tests and report done, except Skylake.
15:04:04 <mackonstan> #info VPP v20.01 / CSIT-2001 Skylake NDR and PDR performance data to be published this week
15:04:40 <mackonstan> #info Poor NDR (zero drop) performance root caused to mgmt interface Linux en0 interrupts disturbing TRex operation on SuperMicro boards with Skylake processors.
15:04:55 <mackonstan> #info Was not happening before environment upgrades (BIOS, CPU ucode).
15:05:04 <mackonstan> #info Those same interrupts are not present on the same SuperMicro motherboards equipped with Cascadelake processors.
15:05:58 <mackonstan> #info In progress: Number of CSIT infrastructure and framework enhancements, gearing up to regular weekly NDR and PDR performance comparisons.
15:08:05 <mackonstan> #info CSIT in the cloud - added AWS c5n instances as another testbed topology, completed ip4 and ipsec performance dry run tests.
15:08:49 <mackonstan> #info Mellanox tests - we are in the process of calibrating the MLX5 setup on both TRex side and SUT/VPP side, so pls take the current trending results with a pinch of salt.
15:09:41 <DaveBarach> #topic host stack (Florin)
15:10:21 <DaveBarach> #info tcp supports connection scheduling, Improves high scale efficiency when sessions can't send
15:10:37 <DaveBarach> #info Same treatment applied to TLS
15:11:28 <DaveBarach> #info iperf + tls + ld_preload works (albeit not perfectly) one connectio > 12gb/sec
15:12:02 <DaveBarach> #info udp session pinning to workers, similar to TCP
15:12:33 <DaveBarach> #info no longer supporting udp-c (connected) sessions
15:12:54 <DaveBarach> #info vcl udp iperf test added to "make test"
15:13:12 <DaveBarach> #info iperf w/ 9K datagrams fills a 40g pipe
15:13:42 <DaveBarach> #info 1500 MTU -> fragmentation -> less than 20gbit
15:14:15 <DaveBarach> #info "spring cleaning" effort - tcp features moved to separate files
15:14:32 <DaveBarach> #info session api errors switched to session layer errors
15:14:56 <DaveBarach> #info binary APIs now deprecated, as promised two releases ago
15:15:12 <DaveBarach> #info all api messages use session queues, not binary api queues
15:17:42 <DaveBarach> #topic Documentation (John, Ray)
15:18:17 <DaveBarach> #info multiple requests to add blog posts
15:18:18 <DaveBarach> #info adding csit / perf content, ask Maciek et al for review
15:18:19 <DaveBarach> #topic Release Management (Andrew, Dave)
15:18:19 <DaveBarach> #info 20.05 about 4 weeks prior to api freeze
15:18:20 <DaveBarach> #info 20.01 planning 20.01.1 planned for after 19.08.X
15:18:40 <florinc> #info thanks Dave! a few clarifications 1) we now support tcp descheduling 2) udp + fragmentation reaches less than 25Gbps
15:20:49 <DaveBarach> #topic infra status (Dave W)
15:21:11 <DaveBarach> #info an issue last Friday due to CentOS timestamp issue
15:21:23 <DaveBarach> #info no obvious reason, "went away by itself"
15:27:43 <DaveBarach> #topic planning / hoping to add 2x features to 20.05 (Ray K)
15:27:52 <DaveBarach> #info async crypto / crypto-dev work
15:28:22 <DaveBarach> #info DDP (dynamic device personalization) to be added
15:29:04 <DaveBarach> #action Damjan to take a look at async crypto when he can
15:29:55 <DaveBarach> #info DDP flow API to direct pkts to specific workers
15:30:06 <DaveBarach> #info adding L2tpv3, ipsec
15:30:24 <DaveBarach> #info direct specific ipsec tunnels to specific cores
15:30:39 <DaveBarach> #info direct specific l2tpv3 tunnels to specific cores
15:31:07 <DaveBarach> #info will be a work in progress for a while
15:31:58 <DaveBarach> #info involves dpdk feature backport to dpdkd 20.02
15:33:18 <DaveBarach> #info dpdk blast radius only in AVF driver
15:34:56 <DaveBarach> #info misc improvements, multiarch support, classifer perf tunes
15:35:54 <DaveBarach> #info multiarch (damjan) 18.04 gnu assembler bug backport
15:36:19 <DaveBarach> #info avx512 causes cpu power management glitches
15:37:04 <DaveBarach> #info on Skylake, Cascade lake
15:48:59 <DaveBarach> #endmeeting