#fdio-vpp: fd-io-vpp

Meeting started by DaveBarach at 14:58:38 UTC (full logs).

Meeting summary

  1. Host Stack (Florin reporting) (DaveBarach, 15:01:53)
    1. bunch of fixes committed to host stack components (DaveBarach, 15:02:24)
    2. improved tracking of half-open sessions (DaveBarach, 15:02:33)
    3. tcp switched to cubic as the default congestion control algorithm (DaveBarach, 15:02:48)
    4. tcp improved tracking of half-open sessions (DaveBarach, 15:03:04)
    5. vcl improved handling of select vis a vis half-opened sessions (DaveBarach, 15:03:19)
    6. better select notifications when sessions encounter read/write errors (DaveBarach, 15:03:36)
    7. fixed svm fifo alignment issues thanks to the change to clang (DaveBarach, 15:04:01)
    8. udp now supports sending of multiple datagrams per dispatch cycle (DaveBarach, 15:05:24)
    9. improves quic performance (DaveBarach, 15:05:37)

  2. CSIT (Maciek reporting) (DaveBarach, 15:06:13)
    1. CSIT (Maciek et al) covering following topics per agenda (mackonstan, 15:06:51)
    2. 1. Spectre-Meltdown (S-M): "pandemic" recovery in CSIT (mackonstan, 15:06:57)
    3. 2. Xeon Skylake: updated CSIT-2001 report with S-M RCAs (mackonstan, 15:07:03)
    4. 3. Improved trending: daily MRR, weekly NDR/PDR, analytics (mackonstan, 15:07:10)
    5. announce email (mackonstan, 15:07:16)
    6. https://lists.fd.io/g/vpp-dev/message/16343 (mackonstan, 15:07:22)
    7. slides for the meeting (mackonstan, 15:07:34)
    8. https://wiki.fd.io/view/Presentations (mackonstan, 15:07:39)
    9. https://docs.fd.io/csit/master/report/_static/vpp/performance-rca-2n-skx-2t1c-pdr.txt (mackonstan, 15:11:10)
    10. https://docs.fd.io/csit/rls2001/report/test_operational_data/vpp_performance_operational_data/index.html (mackonstan, 15:20:26)
    11. Quick Q: status of failed SSD replacement activity? (DaveBarach, 15:22:21)
    12. note that folks have made zero progress on root-causing the SSD failures (DaveBarach, 15:25:05)

  3. Documentation (John D) (DaveBarach, 15:26:09)
    1. 20.05 release note info pls send to john D (DaveBarach, 15:26:34)

  4. Release Management (Andrew, Dave W ) (DaveBarach, 15:26:57)
    1. 20.05 RC1 tag exercise tomorrow (DaveBarach, 15:27:28)
    2. please let andrew / dave know about patches which must be merged before RC1 (DaveBarach, 15:27:55)
    3. Jerome asks about API changes from last release. Andrew will generate listing after RC1 (DaveBarach, 15:28:31)
    4. Confirmed that we should not see any further (master/lates) API changes until release branch pulled (DaveBarach, 15:29:35)
    5. working on automatic cherry-pick scripts (DaveBarach, 15:29:57)
    6. O(200) cherry-picks needed for previous releases, maybe 70% can be automatically applied (DaveBarach, 15:30:45)
    7. 20.01 will have cherry-picks for the next month or so (DaveBarach, 15:31:59)
    8. will schedule 20.01.2 once the 20.05 release is published (DaveBarach, 15:32:19)
    9. 19.08 cherry pick catchup activity thereafter (DaveBarach, 15:32:39)
    10. 19.08 current LTS, 20.09 next LTS. May need some level of overlapping support (DaveBarach, 15:33:58)

  5. Infra (Dave W, Andrew) (DaveBarach, 15:35:09)
    1. from last Thursday, verify jobs became erratic (DaveBarach, 15:35:27)
    2. something is killing jobs for no obvious reason (DaveBarach, 15:35:40)
    3. may be a job placement issue. (DaveBarach, 15:36:11)
    4. made Jenkins nomad plugin config changes (DaveBarach, 15:36:36)
    5. as of this AM, the Jenkins server seems to be misbehaving (DaveBarach, 15:36:50)
    6. we may have to do a Jenkins emergency shutdown and revert the last set of Jenkins updates (DaveBarach, 15:37:24)
    7. first "funny" thing noticed on May 2 (DaveBarach, 15:38:04)

  6. please let Dave W and Andrew know if there are patches which must make RC1 (DaveBarach, 15:40:49)
    1. Benoit mentioned a vlib process stack overflow related to switching to clang-9 (DaveBarach, 15:54:31)
    2. AGREED: Fix that specific process, consider bumping default stack allocation to 64k from 32k if it becomes a widespread issue (DaveBarach, 15:55:08)
    3. the stack overflow was properly detected by running into the per-process guard page, so at least it wasn't horribly hard to work out what had happened (DaveBarach, 15:55:45)


Meeting ended at 15:55:47 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. DaveBarach (40)
  2. mackonstan (10)
  3. collab-meetbot (3)


Generated by MeetBot 0.1.4.