15:01:43 <DaveBarach> #startmeeting fdio-vpp
15:01:43 <collab-meetbot> Meeting started Tue Jun  9 15:01:43 2020 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:43 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:43 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
15:03:40 <DaveBarach> #topic CSIT (Maciek reporting)
15:04:04 <DaveBarach> #info 20.01 skylake update should make it into report shortly
15:04:06 <mackonstan> #link https://docs.fd.io/csit/rls2001/report/vpp_performance_tests/comparisons/current_vs_previous_release.html#n-skx
15:04:35 <DaveBarach> #info csit 20.05 slow progress due to Vexxhost connectivity issues
15:05:00 <DaveBarach> #info tests restarted this morning
15:05:23 <DaveBarach> #info Vexxhost has apparently root-caused the problem
15:06:05 <DaveBarach> #info csit 20.05 report won't be issued this week
15:06:33 <DaveBarach> #info thanks to Dave W et al. for cranking up ping monitor
15:07:25 <DaveBarach> #info now have csit test which runs in Amazon EC2 et al. to benchmark vpp cloud workloads
15:07:44 <DaveBarach> #info testing NAT up to 60M sessions
15:08:13 <DaveBarach> #topic Host Stack (Florin)
15:08:19 <DaveBarach> #info quiet over the last month
15:08:31 <DaveBarach> #info VCL removed udp-connected transport
15:08:50 <DaveBarach> #info can achieve same result w/ flags on normal sessions
15:09:01 <DaveBarach> #info simple implementation in LDP of sndmsg, recvmsg
15:09:15 <DaveBarach> #info fixed fcntl64 wrapper
15:09:36 <DaveBarach> #info TCP improved rtt estimation w/ SACKs
15:09:49 <DaveBarach> #info improved tracking of buffer allocations
15:10:20 <DaveBarach> #info fixed a sequence wrapping bug introduced by merged patch
15:10:34 <DaveBarach> #info fixed some clang-discovered issues
15:11:07 <DaveBarach> #topic Documentation (John D)
15:11:36 <DaveBarach> #info 20.05 release note sent to Jerome, will send to vpp-dev
15:13:05 <DaveBarach> #topic 20.05 release managment
15:13:32 <DaveBarach> #info 20.05 already a few fixes after release, need to add time to the release schedule next time
15:13:58 <DaveBarach> #info add a week between RC2 and formal release
15:15:08 <DaveBarach> #agreed add 1 week between RC2 and formal release - everyone likes the idea
15:16:20 <DaveBarach> #info 20.01 per usual cadence, will continue to cherrypick due to customer demand
15:16:54 <DaveBarach> #info will limit all-inclusive cherrypicking to LTS releases moving forward
15:20:52 <DaveBarach> #info API compatibility (crc checking) during checkstyle to catch as early as possible
15:21:53 <DaveBarach> #topic Infra Status
15:22:06 <DaveBarach> #info working to improve nomad cluster
15:22:17 <DaveBarach> #info many outages in the last month
15:22:56 <DaveBarach> #info Peter Mikus making all servers PXE / Ansible installed
15:23:04 <DaveBarach> #info to improve uniformity
15:23:27 <DaveBarach> #info revamping Nomad arch, where we're deploying servers / clients
15:23:40 <DaveBarach> #info spec for docker images now in CI repo
15:23:59 <DaveBarach> #info allows us to use Jenkins sandbox to test
15:25:51 <DaveBarach> #info Dave W weekly meeting w/ Vanessa, pls ping dave W unicast with LF issues
15:26:31 <DaveBarach> #info LF upgrading all of their infrastructure, which will give us better visibility into Jenkins machines
15:40:38 <florinc> #info Jerome's link: https://medium.com/fd-io-vpp/getting-to-40g-encrypted-container-networking-with-calico-vpp-on-commodity-hardware-d7144e52659a
15:41:06 <DaveBarach> #topic VPP/Calico (Jerome T)
15:41:35 <DaveBarach> #link https://medium.com/fd-io-vpp/getting-to-40g-encrypted-container-networking-with-calico-vpp-on-commodity-hardware-d7144e52659a
15:42:14 <DaveBarach> #info vpp roughly 40x faster than Linux IPSec. 40gbit container-to-container encrypted comms
15:43:05 <DaveBarach> #info alpha-quality at the moment
15:44:30 <DaveBarach> #endmeeting