14:58:17 <DaveBarach> #startmeeting fdio-vpp
14:58:17 <collab-meetbot> Meeting started Tue Jul 14 14:58:17 2020 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:17 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:58:17 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
15:02:44 <DaveBarach> #topic CSIT (maciek reporting)
15:02:56 <DaveBarach> #info just pushed the 20.05 report out the door
15:03:29 <DaveBarach> #info Highlights - lots of work on infra, infra monitoring
15:03:51 <DaveBarach> #info report now tracking environment / csit / trex changes
15:04:23 <DaveBarach> #info vpp mainly performance progressions
15:04:45 <DaveBarach> #info acls improved due to api changes
15:05:22 <DaveBarach> #info counter-intuitive, but confirmed by bisection
15:06:22 <DaveBarach> #info new data structures related to API changes appears to be responsible
15:06:51 <DaveBarach> #action Maciek to send commit ID for developer community analysis
15:07:13 <DaveBarach> #info ip6 scale test improved 15-20%
15:08:43 <DaveBarach> #info appears related to bihash tunes from DaveB, Damjan
15:09:08 <DaveBarach> #info no substantial regressions on vpp side
15:11:10 <DaveBarach> #info Ray asks: why aren't all tests being done on Denverton?
15:11:58 <DaveBarach> #info Maciek: test set in a config file
15:12:12 <DaveBarach> #action Maciek and Ray will work the Denverton list offline
15:12:36 <DaveBarach> #info will beef up nat44 tests for next release
15:13:41 <DaveBarach> #topic Release Management (Andrew Y, Dave W)
15:14:02 <DaveBarach> #info 20.05.01 will ship soon (this week)
15:14:15 <DaveBarach> #info shoot for Weds/Thurs.
15:14:54 <DaveBarach> #info 19.08 host doing automatic cherrypicks issues
15:15:13 <DaveBarach> #info Roughly 2/3rds of patches merge automatically
15:15:57 <DaveBarach> #info 20.09 kickoff beginning of August
15:16:43 <DaveBarach> #info Day 1 issue w/ artifact naming - RC2 builds have been inaccessible
15:17:18 <DaveBarach> #info To fix, add explicit commit ID's to artifact names
15:17:51 <DaveBarach> #action Andrew to send mail to vpp-dev describing artifact naming change
15:18:24 <DaveBarach> #info API change process - so far, reasonably smooth sailing. 3-4 exceptions detected so far
15:19:02 <DaveBarach> #info several API downgrades in progress
15:32:56 <DaveBarach> #topic Variable Naming Transition
15:33:57 <DaveBarach> #agreed follow API name change process for APIs with names in need of harmonization
15:34:27 <DaveBarach> #topic Infra Status (Dave W)
15:34:45 <DaveBarach> #info things have been fairly stable in terms of production
15:35:03 <DaveBarach> #info continuing to wrestle with Vexxhost to keep the wheels from falling off
15:35:44 <DaveBarach> #info process to rebuild Docker images has been delayed by the above
15:35:59 <DaveBarach> #info Docker image update process: need to update more than once a year,e tc.
15:36:09 <DaveBarach> #info goal to hit 20.09 timeframe
15:40:13 <DaveBarach> #info Zoom just dropped offline...
15:40:14 <DaveBarach> At least for me...
15:49:48 <DaveBarach> #action DaveB to work out who to ask about relicensing code written by former Panthone employees
15:50:10 <DaveBarach> #endmeeting