14:57:03 <DaveBarach> #startmeeting fdio-vpp
14:57:03 <collab-meetbot> Meeting started Tue Aug 11 14:57:03 2020 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:57:03 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:57:03 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
15:02:28 <DaveBarach> #topic CSIT (Maciek reporting)
15:02:47 <mackonstan> #info Continuing to focus on stateful tests, calls-per-second and throughput transactions-per-second tests. Initial target is VPP NAT44-ED 5-tuple tests for CSIT-2009.
15:03:57 <mackonstan> #info New hardware, adding AMD EPYC zen2 performance testbed.
15:04:17 <mackonstan> #info Trending pages updated, extended historical data coverage from 3mths to 6mths to fully cover release cycle.
15:04:49 <mackonstan> #info Lots of other housekeeping work.
15:05:15 <DaveBarach> #topic Host Stack (Florin)
15:05:52 <DaveBarach> #info tracking pending timers due to timer pacing algorithm
15:06:44 <DaveBarach> RTT estimates now kept in usec, no more rounding errors
15:07:13 <DaveBarach> #info network simulator now supports network reordering
15:07:51 <DaveBarach> #info 163.com working on a vcl patch to enable multi-threaded apps w/ workers
15:08:13 <DaveBarach> #info goal: to enable envoy to work with vcl / ld_preload. 30% latency reduction reported
15:08:39 <DaveBarach> #topic Documentation (John D)
15:08:57 <DaveBarach> #info expect to add infographic from the marketing team over the next week or so
15:09:08 <DaveBarach> #info 20.05 release notes avaliable on the websit
15:11:12 <DaveBarach> #topic Release Management (Andrew, DaveW)
15:11:22 <DaveBarach> #info 20.09 API freeze in about 4 weeks
15:11:57 <DaveBarach> #info deprecation tagging included in the API freeze, please make a note of it
15:12:32 <DaveBarach> #info 280 patches in master heading into 19.08
15:13:14 <DaveBarach> #info found out that bursts of more than 20 cherry-picks causes serious issues w/ jenkins
15:13:38 <DaveBarach> #info Andrew figured out how to dribble cherry-picks into 19.08
15:13:46 <DaveBarach> #info 20.05.1 is complete
15:14:12 <DaveBarach> #info Do we actually need to produce CSIT reports for 20.05.1?
15:14:35 <DaveBarach> #info resource limitation argue for not going there.
15:15:36 <DaveBarach> #agreed we will not create CSIT reports for point releases, specifically 20.05.1
15:16:17 <DaveBarach> #info artifact naming changes waiting for Damjan to return from PTO
15:17:07 <DaveBarach> #info coverity warnings (a number of false positive) 7 remain
15:17:16 <DaveBarach> #info please clean up
15:17:57 <DaveBarach> #info sonarcloud seems to catch real bugs in .py code
15:18:19 <DaveBarach> #action Andrew to dig into sonarcloud defects
15:19:24 <DaveBarach> #topic Infrastructure
15:19:41 <DaveBarach> #info nomad machines all running 18.04, installed by ansible
15:20:24 <DaveBarach> #info struggling with LF inability to understand / monitor their own infra
15:21:01 <DaveBarach> #info Havent seen Vexxhost timeouts recently
15:21:22 <DaveBarach> #info have somewhat better visibility on vm performance through DataDog
15:22:24 <DaveBarach> #info "git checkout" timeouts when 100 Jenkins jobs are trying at the same time
15:28:05 <DaveBarach> #info Probably no need to upload artifacts on verify job successes
15:30:35 <DaveBarach> #endmeeting