15:00:48 <DaveBarach> #startmeeting fdio-vpp
15:00:48 <collab-meetbot> Meeting started Tue Sep  8 15:00:48 2020 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:48 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
15:01:44 <DaveBarach> #topic CSIT (Maciek reporting)
15:01:46 <mackonstan> #info Maciek K.
15:01:59 <mackonstan> #info New / updated tests: lots of focus on nat44:
15:02:45 <mackonstan> #info i) nat44-deterministic throughput (TRex stateless, bi-dir), ii)nat44-endpoint-dependent throughput (TRex stateless, uni-dir), iii)nat44-ed CPS and throughput (TRex stateful, bi-dir).
15:02:59 <mackonstan> #info All nat44 tests at varying scale 64k to 16M UDP sessions. TCP to follow.
15:03:23 <mackonstan> #info Test framework, environment: TRex stateless and stateful calibration work, TRex multi-thread "tuning" for higher speeds to fill MLX / 100GE.
15:04:08 <mackonstan> #info CSIT-2009: f1 milestone on Wed, branch pull, dry run tests of VPP rc1.
15:04:43 <DaveBarach> #topic Host stack (Florin reporting)
15:05:09 <DaveBarach> #info TCP tracks reordering w/ SACKs
15:05:52 <DaveBarach> #info network simulator plugin now supports packet reordering
15:07:05 <DaveBarach> #info LDP / vcl added support for multiple workers working with multiple app workers
15:07:22 <DaveBarach> #info small fixes in vcl, session layer for cut-through sessions
15:07:56 <DaveBarach> #topic Docs (John D, Ray)
15:08:15 <DaveBarach> #info new infographic from Marketing, need tech review
15:08:56 <DaveBarach> #topic Release management (Andrew, DaveW)
15:09:09 <DaveBarach> #info 20.09 RC1 throttle pull tomorrow
15:09:54 <DaveBarach> #info Production APIs are effectively frozen all of the time
15:11:11 <DaveBarach> #info 2 weeks post-RC2, to see if we can avoid an immediate point release.
15:12:09 <DaveBarach> #topic 20.05.01 released over a month ago
15:12:46 <DaveBarach> #into 19.08.3 should be the "last" update to the 19.08 LTS release
15:13:51 <DaveBarach> #info 19.08.3 csit report deferred until 20.09 report is released
15:17:39 <DaveBarach> #info DaveBarach back...
15:18:43 <DaveBarach> #topic Infra (Dave W)
15:19:24 <DaveBarach> #info at least 3 unscheduled Jenkins restarts due to Vexxhost work, mistakes, etc.
15:19:47 <DaveBarach> #info network between 2 data centers simply not reliable
15:20:28 <DaveBarach> #info hope to relocate Nomad servers to the same DC. Budget input to LFN in progress
15:20:55 <DaveBarach> #info requesting larger VM instances for Jenkins; currently only 8g
15:23:22 <DaveBarach> #info still running on ancient Docker instances, working on automation for creating new instances
15:23:46 <DaveBarach> #info next week, will push new instances as documented in gerrit 28022
15:26:55 <DaveBarach> #info will deploy 20.04, centos8 and debian9 executors
15:27:43 <DaveBarach> #action Andrew to chase down static analysis nits
15:36:46 <DaveBarach> #topic Discussion of AMD Epyc performance
15:37:31 <DaveBarach> #info competitive with similar Intel h/w, ddio clearly counts for a good deal
15:43:54 <DaveBarach> #info AMD has testbeds going into CSIT, being onboarded now
15:44:23 <DaveBarach> #info expect to update 20.09 csit report w/ AMD perf numbers
15:46:13 <DaveBarach> #endmeeting