15:57:24 <DaveBarach> #startmeeting fdio-vpp
15:57:24 <collab-meetbot> Meeting started Tue Dec  8 15:57:24 2020 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:57:24 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:57:24 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
16:02:35 <DaveBarach> #topic CSIT (Maciek Reporting)
16:02:45 <mackonstan> #info Complete set of nat44 results published in maintenance version of CSIT-2009 report last week
16:03:03 <mackonstan> #info Includes stateless benchmarks: Det BiDir, ED UniDir
16:03:10 <mackonstan> #info Includes stateful benchmarks: ED UDP CPS, ED UDP PPS, ED TCP CPS, ED TCP PPS
16:04:57 <mackonstan> #info Methodology description see link below
16:05:03 <mackonstan> #link https://docs.fd.io/csit/rls2009/report/introduction/methodology_nat44.html
16:05:10 <mackonstan> #info Benchmark graphs see link below
16:05:15 <mackonstan> #link https://docs.fd.io/csit/rls2009/report/vpp_performance_tests/packet_throughput_graphs/nat44.html
16:06:50 <mackonstan> #info Finally, will be publishing first experimental set of AMD zen2 benchmarks tomorrow/day after
16:07:00 <mackonstan> #info Preview of AMD data in the draft report version in master, see link below
16:07:09 <mackonstan> #link https://docs.fd.io/csit/master/report/vpp_performance_tests/packet_throughput_graphs/ip4.html
16:07:21 <mackonstan> #info Note that rls2009 report will only publish base frequency data, no turbo numbers, as that how it is done for all other platforms
16:08:06 <mackonstan> #info Many other things  updates and goodies coming in 2101, see CSIT 2101 wiki for details as they are being filled in
16:09:34 <DaveBarach> #topic (Host Stack, Florin)
16:09:40 <DaveBarach> #info small updates
16:09:49 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit2101_plan
16:09:58 <DaveBarach> #info session layer removed support for binary API connections
16:10:07 <DaveBarach> #info over shared memory.
16:10:40 <DaveBarach> #info scheduler improvements, to coalesce pkts (per session)
16:10:55 <DaveBarach> #info TCP improvements to segment pushing
16:11:46 <DaveBarach> #info Codenomicon tests run pre-release: 70-80 "failures" out of 1.2M
16:12:10 <DaveBarach> #info ssvm merged some mutex improvements
16:12:51 <DaveBarach> #info DTLS draft work, will publish after 21.01
16:13:20 <DaveBarach> #info DTLS = "tls for UDP"
16:18:03 <DaveBarach> #topic (Documentation, Ole)
16:18:33 <DaveBarach> #info no updates, ole driving, try not to hit phone pole!
16:19:01 <DaveBarach> #topic Release Management (Andrew)
16:19:14 <DaveBarach> #info tomorrow is F0 for 21.01
16:19:41 <DaveBarach> #info hold off risky commits until we pull the release branch
16:20:01 <DaveBarach> #info RC1 pull in one week
16:20:20 <DaveBarach> #agreed let's not bother with F0 anymore
16:21:00 <DaveBarach> #info give the API change process, F0 isn't useful anymore
16:21:46 <DaveBarach> #info no updates for 20.09, 19.08
16:22:09 <DaveBarach> #info plan to remove the 19.08 CI jobs in January.
16:22:57 <DaveBarach> #info Note that the release after 21.01 will be 21.06
16:23:04 <DaveBarach> #topic (Infra, Dave Wallace)
16:23:10 <DaveBarach> #info "Jenkins sucks"
16:23:35 <DaveBarach> #info restarted Jenkins yesterday to unconstipate it
16:24:18 <DaveBarach> #info list of 20+ plugins which arent doing anything, to remove
16:24:28 <DaveBarach> #info another Jenkins restart later today
16:25:06 <DaveBarach> #info another patch in flight to fix CentOS issues. "PowerTools" repo name changed to "powertools."
16:26:51 <DaveBarach> #info Added non-voting address sanitizer job
16:28:29 <DaveBarach> #info improved capture / placement of failed unittest logs
16:29:47 <DaveBarach> #info (from Ray) Red Hat plans to EOL CentOS as it is, replace with something like Red Hat REL
16:30:41 <DaveBarach> #info Debian 9 status: proposal to remove from 21.01 release
16:31:17 <DaveBarach> #info Cisco internal customer apparently needs to move to Debian 10.
16:32:35 <DaveBarach> #info patch in progress to make vppctl statically-linked
16:35:41 <DaveBarach> #info Plan to move to Ubuntu 20.04 as our primary test distro. Csit runs on 18.04, so some effort required
16:36:02 <DaveBarach> #info can start as soon as the 21.01 release throttle is pulled
16:38:35 <DaveBarach> #topic Issues
16:39:20 <DaveBarach> #info Coverity Cleanup next week
16:40:29 <DaveBarach> #info Chris H: frame-queue fixes please review patch
16:40:44 <chopps> https://gerrit.fd.io/r/c/vpp/+/28980
16:41:38 <dwallacelf> #link https://gerrit.fd.io/r/c/vpp/+/28980
16:42:48 <DaveBarach> #action Dave B to review 28980
16:48:10 <DaveBarach> #info new native asm crypto w/ QAT supposedly 30% faster than dpdk ipsec code
16:50:12 <DaveBarach> #endmeeting