#fdio-vpp: fdio-vpp

Meeting started by dmarion at 15:59:36 UTC (full logs).

Meeting summary

    1. csit-2101 rls status: most benchmark testing for report completed, no major issues (mackonstan, 16:04:02)
    2. draft version of csit-2101 report already online, incl. comparison tables to v20.09 (mackonstan, 16:04:16)
    3. https://docs.fd.io/csit/master/report/ (mackonstan, 16:04:22)
    4. https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-2n-clx-xxv710-2t1c-pdr.txt (mackonstan, 16:04:30)
    5. report publish target date 10-Feb, tomorrow, and we should be on time (mackonstan, 16:04:47)
    6. some more updates going into rls notes and other static content e.g. methodology sections (mackonstan, 16:04:58)
    7. After CSIT release is done, we will be moving to Ubuntu 20.04 as the main stack for benchmarking (mackonstan, 16:05:25)
    8. There is also quite some work on the infra side, putting backend monitors in place, so that we can detect any issues early, thanks to Dave and Peter (mackonstan, 16:06:01)
    9. Will come handy during the LFN/Vexxhost DC consolidation expected in end of Feb, Mar (mackonstan, 16:06:14)
    10. svm area, custom queue implementation non-blocking when possible (DaveBarach, 16:08:15)
    11. slight performance-at-scale improvement: 10% for NGINX tested w/ WRK (DaveBarach, 16:08:39)
    12. next step: security improvements, private message queues for multiple applications (DaveBarach, 16:09:10)
    13. DTLS patch, hard to test with iperf (DaveBarach, 16:10:01)
    14. slightly less performant than tls. (DaveBarach, 16:10:47)
    15. don't have support for retries w/ timeout (DaveBarach, 16:11:02)
    16. SRTP trying to add support. Test difficulties adding RTP payloads (DaveBarach, 16:11:27)
    17. no updates beyond fixing links on the main website (DaveBarach, 16:11:56)
    18. Ray asks how we're planning to police doc / wiki bit-rot (DaveBarach, 16:13:54)
    19. wiki is really hard to keep straight, should invest in the docset (DaveBarach, 16:14:29)
    20. 21.01 shipped on schedule (DaveBarach, 16:15:02)
    21. RC1 / RC2 timing worked out pretty well (DaveBarach, 16:15:21)
    22. some last-minute churn, probably need to be more strict about avoiding churn post-RC2 for 21.06 (DaveBarach, 16:16:00)
    23. data center move; unless someone insists on point releases, let's wait (DaveBarach, 16:16:49)
    24. folks interested in Centos7 need to figure out where to go since Red Hat is moving away from Centos (DaveBarach, 16:18:41)
    25. DaveW: Centos7 is too old to add to our CI (DaveBarach, 16:19:41)
    26. Damjan: really need a list of package dependencies, vs. distro versions (DaveBarach, 16:20:58)
    27. same issue occurred with Debian9 vs Debian-10 (DaveBarach, 16:21:53)
    28. ACTION: DaveW and Andrew to investigate making minimum version listing (DaveBarach, 16:22:29)
    29. discuss again next time (DaveBarach, 16:22:43)
    30. infra breakages over the last month, dealt with, ping DaveW directly with ongoing infra issues (DaveBarach, 16:23:39)
    31. auto-abandon proposal / RFC. We have 600+ patches in the gerrit queue (DaveBarach, 16:24:09)
    32. costs cycles to have the queue that large (DaveBarach, 16:24:24)
    33. auto-abandon would address that aspect of the problem (DaveBarach, 16:24:47)
    34. Seems like most folks happy to enable auto-abandon, except for Paul V, Ole (DaveBarach, 16:26:19)
    35. of the outstanding patches, 477 are waiting for author actions (address comments, rebase, etc.) (DaveBarach, 16:26:52)
    36. 42 awaiting review (DaveBarach, 16:26:58)
    37. doing a reasonable review job (DaveBarach, 16:27:53)
    38. ACTION: send out list of patches to clean up (DaveBarach, 16:36:48)
    39. ACTION: Dave W to see if converting patches to work-in-progress will fix the problem (DaveBarach, 16:39:13)
    40. interesting exercise to run tests w/ 2 workers (DaveBarach, 16:40:36)
    41. patch to run this way by environment variable pushed (DaveBarach, 16:41:04)
    42. another patch in the works which tags tests which don't work multicore (DaveBarach, 16:41:58)
    43. one reason: tests which assume only one set of counters, blow up due to split counts (DaveBarach, 16:42:25)
    44. shout-out to Dave W for CI failure cause enhancements (DaveBarach, 16:46:00)
    45. aarch64 scalable vector enhancements (DaveBarach, 16:46:59)
    46. discuss changes in vpp to support / use these instruction-set changes (DaveBarach, 16:47:25)
    47. instrs are vector-length agnostic (DaveBarach, 16:49:53)
    48. coding style involves looping (DaveBarach, 16:53:36)
    49. topic really needs a full hour (DaveBarach, 16:55:55)
    50. ACTION: meet tomorrow same time slot to continue (DaveBarach, 16:58:18)


Meeting ended at 16:58:46 UTC (full logs).

Action items

  1. DaveW and Andrew to investigate making minimum version listing
  2. send out list of patches to clean up
  3. Dave W to see if converting patches to work-in-progress will fix the problem
  4. meet tomorrow same time slot to continue


People present (lines said)

  1. DaveBarach (49)
  2. mackonstan (9)
  3. collab-meetbot (4)
  4. dmarion (2)


Generated by MeetBot 0.1.4.