15:58:21 <DaveBarach> #startmeeting fdio-vpp
15:58:21 <collab-meetbot> Meeting started Tue Mar  9 15:58:21 2021 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:58:21 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:21 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
16:02:39 <DaveBarach> #topic agenda bashing
16:03:00 <DaveBarach> #info +coverity discussion
16:04:21 <DaveBarach> #info +API CRC
16:05:40 <DaveBarach> #topic CSIT (Maciek reporting)
16:06:24 <mackonstan> #info csit-2101 rls: Report published, last week added GSO benchmarks
16:06:47 <mackonstan> #info One known open items is async crypto benchmarks for fat tunnels - test logs and measurements are under review
16:07:13 <mackonstan> #info Other updates: move to Ubuntu 20.04 in progress,
16:07:47 <mackonstan> #info Vexxhost DC move of FD.io Nomad and CSIT testbed servers/HW: MTL2 (1 rack) move to YUL1 complete, MTL1 (4 racks) move to YUL1 to be scheduled
16:08:23 <mackonstan> #info Big thanks to Peter Mikus, Andrew Yourtchenko and Dave Wallace for assisting with the move, and working with Vexxhost to iron out some "teething issues"
16:09:42 <mackonstan> #info Major work areas: support AWS c5n environment, enhancing Linux&VPP telemetry, redesigning data backend, MLRsearch improvements, faster PAPI, tuning/adding tests.
16:10:07 <DaveBarach> #topic host stack (Florin reporting)
16:10:23 <DaveBarach> #info UDP fixes / enhancements over the past month
16:10:36 <DaveBarach> #info fix fifo segment leaks due to worker migration
16:11:04 <DaveBarach> #info remove rx spinlocks from udp sessions for connected sessions
16:11:28 <DaveBarach> #topic Documentation (report readout from Ole)
16:11:38 <DaveBarach> #info no updates
16:11:49 <DaveBarach> #topic 21.01 release (Andrew / DaveW)
16:12:04 <DaveBarach> #info holding off next point release until data center move complete
16:12:17 <DaveBarach> #info 21.06 release plan published
16:12:58 <DaveBarach> #info API process changes reflected in lack of API freeze milestone
16:13:27 <DaveBarach> #info continue with the extended milestone cadence
16:13:59 <DaveBarach> #info + "release gate" milestone
16:14:34 <DaveBarach> #info deadlines set to noon UTC so the LF folks are still online
16:15:09 <DaveBarach> #topic API status changes (Andrew)
16:15:20 <DaveBarach> #info daily reports added to github
16:17:47 <DaveBarach> #info api status ends up in .json files
16:18:50 <dmarion> #link https://github.com/vpp-dev/vpp-release-notes
16:19:54 <DaveBarach> #topic Coverity(Andrew)
16:20:02 <dmarion> #link https://github.com/vpp-dev/vpp-coverity-report
16:20:11 <DaveBarach> #info Coverity report also on github
16:25:43 <DaveBarach> #info 19.08 maintenance release not yet scheduled
16:26:02 <DaveBarach> #info plan to defer until data center move complete
16:26:49 <DaveBarach> #topic Infra Status (DaveW)
16:27:04 <DaveBarach> #Info move phase 1 went reasonably well
16:27:36 <DaveBarach> #info More reliable connections between two DC's than we've ever had
16:27:51 <DaveBarach> #info Need to finish retiring Nexus
16:28:43 <DaveBarach> #info Auto-abandon expect Ole to have script next week
16:29:06 <DaveBarach> #info probably pick 180 days as a threshold to start with
16:29:39 <DaveBarach> #topic Multicore Make Test (Andrew)
16:30:10 <DaveBarach> #info running now, non-voting
16:30:55 <DaveBarach> #info Damjan (kidding): Perhaps generate another report?
16:31:44 <DaveBarach> #info DaveW: deploying multi-core tests, log upload of core-file backtraces
16:32:38 <DaveBarach> #info Dave W: send failure cause analysis suggestions to Dave W
16:33:33 <DaveBarach> #topic API CRC issue (Ole email)
16:34:15 <DaveBarach> #info crc issue in compiler, will yield an API crc flag day
16:35:31 <DaveBarach> #info AndrewL matter of coordination (e.g. w/ CSIT), might as well push the button
16:36:01 <DaveBarach> #info Andrew: timing probably best sooner vs. later
16:36:26 <DaveBarach> #info Andrew: maybe give people a months' notice
16:37:45 <DaveBarach> #action Ole to put together a (date) proposal and communicate it
16:38:12 <DaveBarach> #topic Snort plugin + DAQ (Damjan)
16:38:43 <DaveBarach> #info zero-copy interface
16:39:52 <DaveBarach> #info sharing buffers w/ read-only memory map with snort
16:58:08 <DaveBarach> #endmeeting