#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:58:04 UTC (full logs).

Meeting summary

  1. Agenda Additions? (DaveBarach, 15:03:01)
  2. CSIT (Vratko reporting) (DaveBarach, 15:03:26)
    1. finishing prep work for 21.06 (DaveBarach, 15:03:43)
    2. still some issues, e.g. w/ memif tests (DaveBarach, 15:03:58)
    3. Damjan aware of one issue, will look into it (DaveBarach, 15:04:14)
    4. some minor issues with fixes in pipeline (DaveBarach, 15:04:55)
    5. occasional failures (1 in 100) without any clear pattern (DaveBarach, 15:05:12)
    6. one annoying scenario: PAPI unresponsive, vpp not crashing hence no core file (DaveBarach, 15:06:17)
    7. DaveW and Florin got one corefile from iperf + LDP (DaveBarach, 15:07:32)
    8. suspect binary API mmap address conflict with iperf process (DaveBarach, 15:09:01)
    9. changed number of RX queues - one queue per worker. Needed to increase number of mbufs (DaveBarach, 15:11:20)

  3. Host Stack (Florin) (DaveBarach, 15:13:26)
    1. close to release, doing cleanup/bugfixes (DaveBarach, 15:13:51)
    2. session layer polling on main thread to improve active-open performance (DaveBarach, 15:14:19)
    3. don't keep polling indefinitely (DaveBarach, 15:14:45)
    4. better tracking of half-open sessions (DaveBarach, 15:14:57)
    5. quic needs a bit of work to clean up half-open sessions (DaveBarach, 15:15:12)
    6. fixed and arm-specific memory ordering issue. Specific to our CI infra: ThunderX2 (DaveBarach, 15:15:47)
    7. affected tests: iperf cut-throughy (DaveBarach, 15:16:21)
    8. vcl cut-through performance improvements, e.g. with libev (DaveBarach, 15:16:41)
    9. TLS, DTLS memory pressure hardening (DaveBarach, 15:17:17)

  4. Documentation (DaveBarach, 15:17:42)
    1. dave W did some doc cleanups (DaveBarach, 15:17:55)
    2. struggling to put together a cleanup plan (DaveBarach, 15:18:13)
    3. need to move docs to readthedocs (Nexus retirement) (DaveBarach, 15:18:29)

  5. Release Managment (Andrew, DaveW) (DaveBarach, 15:19:11)
    1. new requirement to do 21.01.1, to generate artifacts (DaveBarach, 15:19:44)
    2. to update csit report (DaveBarach, 15:19:50)
    3. As people cherry-pick for 21.06, consider also cherry-picking for 21.01.1 (DaveBarach, 15:20:16)
    4. please get cherry-picks in... Now... (DaveBarach, 15:21:09)
    5. RC2 next Weds, no need to hold for memif fix... (DaveBarach, 15:22:00)

  6. Infra Status (DaveW) (DaveBarach, 15:25:03)
    1. lots of work / improvements (DaveBarach, 15:25:17)
    2. vexxhost data center move: thanks to Peter Mikus / Barret @ vexxhost (DaveBarach, 15:25:41)
    3. no outages at all..! (DaveBarach, 15:25:54)
    4. all of the hosts now run Ubuntu 20.04 (DaveBarach, 15:26:19)
    5. plan in 21.06 to retire old hardware (Haswell) (DaveBarach, 15:26:53)
    6. addressed "glt clone" / related failures (DaveBarach, 15:27:21)
    7. simplified the communications between components. (DaveBarach, 15:27:44)
    8. git clone failures reduced to O(3/week), removed Naginator (again) (DaveBarach, 15:28:03)
    9. additional change after 21.06: move ingress / Jenkins openstack instances from old data center to new data center (DaveBarach, 15:28:45)
    10. series of CI job failures not related to patch, e.g. vcl vpp cut-through tests (DaveBarach, 15:29:30)
    11. root cause of i40e issues: using old drivers... (DaveBarach, 15:30:12)
    12. chasing a couple of patch-unrelated issues w/ stats segment (DaveBarach, 15:31:07)
    13. continuing to work on using Amazon S3 logging to reduce costs (DaveBarach, 15:31:46)
    14. damjan: kudos to the team for huge improvements in CI infra stability (DaveBarach, 15:32:35)
    15. continuing to update docker images to eliminate repeated package downloads (DaveBarach, 15:33:16)
    16. using ccache to improve build times (DaveBarach, 15:33:37)
    17. Centos-8 is very old, propose to remove jobs from CI from master (DaveBarach, 15:34:02)
    18. unless someone steps up to fix RPM builds, lets remove them. No support on the horizon from Red Hat. CentOS 8 is EOL at the end of the year, etc. (DaveBarach, 15:35:05)
    19. Matt Smith: Netgate currently uses CentOS-8, in the process of switching to Ubuntu (DaveBarach, 15:35:55)
    20. dwallace: no need to remove build infra, but the verify jobs need to go (DaveBarach, 15:36:47)
    21. ACTION: Matt Smith to discuss removal w/ colleagues (DaveBarach, 15:38:23)
    22. Matt to advise by email (DaveBarach, 15:38:54)
    23. async crypto w/ worker threads seems to be completely broken (DaveBarach, 15:41:11)
    24. patches coming soon. Fan is the right person to work with. (DaveBarach, 15:41:52)


Meeting ended at 15:42:47 UTC (full logs).

Action items

  1. Matt Smith to discuss removal w/ colleagues


People present (lines said)

  1. DaveBarach (59)
  2. collab-meetbot (5)
  3. dmarion (0)


Generated by MeetBot 0.1.4.