#lfn-meeting: tac

Meeting started by dfarrell07 at 15:00:32 UTC (full logs).

Meeting summary

    1. TAC members please #info in (dfarrell07, 15:01:11)
    2. Daniel Farrell (dfarrell07, 15:01:15)
    3. Morgan Richomme (morgan_orange, 15:01:20)
    4. Rossella Sblendido (rossella_s, 15:01:29)
    5. edwarnicke (edwarnicke, 15:03:13)
    6. Frank Brockners (frankbrockners, 15:03:23)
    7. Tapio Tallgren (ttallgren, 15:03:36)
    8. Catherine Lefèvre of ONAP is here but can't get on IRC (dfarrell07, 15:05:46)
    9. Razanne Abu-Aisheh proxy Davide Cherubini (Vodafone) is here but not on IRC (dfarrell07, 15:05:58)
    10. Wenjing Chu is here but on IRC (dfarrell07, 15:06:41)
    11. topics today include TF induction updates, TAC leadership positions (dfarrell07, 15:07:31)
    12. edwarnicke asks if we want to discuss the Secretary to insure clean meeting minutes proposal? (edwarnicke, 15:08:13)
    13. Jason Hunt, IBM is here but not on IRC (dfarrell07, 15:10:06)

  1. TF Induction review (kennypaul, 15:10:42)
    1. CaseyLF talks about TF doc status, says there are sections that are difficult to find data for but are being worked on, Randy says he's still hacking on it and will try to show where data came from (dfarrell07, 15:11:14)
    2. dfarrell07 much appreciates Randy trying to clearly show data sources, how data was collected (dfarrell07, 15:11:50)
    3. https://gerrit.linuxfoundation.org/infra/#/c/12880/ TF project proposal gerrit (dfarrell07, 15:12:56)
    4. edwarnicke suggests adding clear links and dates in the meeting materials (kennypaul, 15:13:20)
    5. Jason Hunt, IBM (JasonHunt, 15:13:34)
    6. https://lists.lfnetworking.org/g/TAC/topic/tf_induction_documentation_is/27261286 this was message that started TF review, oct 11th (dfarrell07, 15:14:45)
    7. discussion regarding process (kennypaul, 15:17:10)
    8. Chaker Al-Hakim concerned over getting this right the first time (kennypaul, 15:17:59)
    9. dfarrell07 suggests that the community collectively work on the shortcomings in the process (kennypaul, 15:19:07)
    10. discussion of budget impact considerations. (kennypaul, 15:21:33)
    11. question about if there is a basically fixed amount of funds in LFN, and yes there is because there is a platinum cap and we are basically at it, so pie slices get smaller (dfarrell07, 15:22:42)
    12. TF clarifies that Juniper joined before platinum cap was hit, so there was room to grow at that point (dfarrell07, 15:23:51)
    13. Paul Carver - need better instructions in the template - (kennypaul, 15:24:58)
    14. question on tooling to collect metrics for the document => a priori no built-in mechanism (morgan_orange, 15:25:01)
    15. dfarrell07 intent is only 5K commits. (kennypaul, 15:26:08)
    16. formatting is bulleted at the same level in the doc currently and needs to be changed to sub-bullets (kennypaul, 15:27:03)
    17. Randy request if the 5K commits is provided today that the decision on induction take place at the next TAC meeting in 2 weeks (kennypaul, 15:29:28)

  2. TAC Chair (kennypaul, 15:29:39)
    1. https://gerrit.linuxfoundation.org/infra/gitweb?p=lfn/process.git;a=blob;f=docs/lifecycle/project_data_template.rst;h=271d7affb868eeed45f7e99fb0d98c4782bcc955;hb=HEAD#l53 (dfarrell07, 15:29:48)
    2. consensus to say that it is impossible for 1 person to have the full technical knowledge on all LFN projects (morgan_orange, 15:32:42)
    3. the TAC representation at the board is however necessary (morgan_orange, 15:32:58)
    4. dfarrell07 summarized the email threads regarding the TAC chair (kennypaul, 15:33:40)
    5. dfarrell07 thinks strongly that there needs to be direct reps to Board, per all recent experience (dfarrell07, 15:33:42)
    6. various discussions about TAC leadership positions, chair, vice-chair(s), etc (dfarrell07, 15:33:58)
    7. (kennypaul, 15:34:06)
    8. also discussion about minutes being not great, so very reasonable questions about where we had discussed/agreed/voted on issues (dfarrell07, 15:34:23)
    9. one going-forward idea from ed and others is that we've tried to meet their suggestions and it turned out to be impossible, bad idea, suggest they re-eval and accept our suggestion of direct reps (dfarrell07, 15:35:18)
    10. clarity that Morgan did not sign up for being TAC chair (kennypaul, 15:35:28)
    11. the key concept we all seem to agree on is that there needs to be direct project reps to Board (dfarrell07, 15:35:54)
    12. many boards have chairs and co-chair, secretaries why is this different? (mchiosi, 15:36:07)
    13. then just decide voting rights and who should participate whether they vote or not (mchiosi, 15:36:55)
    14. edwarnicke talks about mechanics of how votes could or could not be split among TAC project reps, want to leave that decision to Board (dfarrell07, 15:36:58)
    15. ttallgren suggests we formulate wording to focus on dialog, not voting, as that seems to be sticky point for Board (dfarrell07, 15:37:35)
    16. mchiosi the strong feeling amoung the TAC members is that no single person can represent all projects to the Board which is what the Board has requirste. (kennypaul, 15:37:44)
    17. phil suggests we work on a TAC chair description that doesn't assume they need to rep all projects, assumes will get direct reps to Board (dfarrell07, 15:40:10)
    18. dfarrell07 suggests we need to do all of this in one go, one single proposal, so it's all clear (dfarrell07, 15:40:24)
    19. it's not possible to do something where the tac chair tags in project reps as needed, as can't even know which topics need tag-ins from projects, and will be too late in meetings to tag-in (dfarrell07, 15:41:24)
    20. Wenjing and dfarrell07 +1 that we need to have all reps at all meetings in all discussions (dfarrell07, 15:42:01)
    21. edwarnicke talks about benefits of having voting roles, vs observer roles at Board (dfarrell07, 15:42:23)
    22. edwarnicke points out that observer status prevents people would be unable to be members of B oard subcommittees (kennypaul, 15:43:11)
    23. basically there are things observers can't take part in, so wouldn't be "full" board reps, would be out of some committees (dfarrell07, 15:43:20)
    24. #info correction, edwarnicke points out about the necessity of the privileges of board membership *other* than votes on the board (edwarnicke, 15:43:26)
    25. edwarnicke pointed out that even if the board assigned zero votes to be split amongst the community reps, it is still important that they be board members, not mere observers (edwarnicke, 15:45:03)
    26. https://gerrit.linuxfoundation.org/infra/#/c/10649/ dfarrell07 has started re-writing charter to provide per-project board reps (dfarrell07, 15:45:14)
    27. dfarrell07 thinks we need to do all of this in one effort, so maybe we can add to that change or build on it (dfarrell07, 15:45:30)
    28. edwarnicke also thinks this needs to be done in one effort (edwarnicke, 15:46:22)
    29. phil suggests again that we move forward with writing spec for chair that doesn't assume per-project rep work, something actually realistic (dfarrell07, 15:46:33)
    30. board joint meeting on dec 12, maybe that should be deadline for this work (dfarrell07, 15:47:10)
    31. phil suggests we focus on intent, ideas behind vs exact wording of charter (dfarrell07, 15:48:41)
    32. edwarnicke suggest we split the difference and send a 'term sheet' proposal to the board, noting it will require charter changes, and requesting that the board send proposed change language back to the TAC for review and commentary prior to adoption (edwarnicke, 15:49:59)
    33. charter edit may trigger board into legal world, so might be more effective to focus on ideas (dfarrell07, 15:50:15)
    34. looking to put together group of folks to drive this work, iterate on 10649 (dfarrell07, 15:51:41)
    35. volunteers for workgroup Tapio, Wenjing, (kennypaul, 15:51:48)
    36. edwarnicke volunteers as well (edwarnicke, 15:51:56)
    37. dfarrell07 will also help of course :) (dfarrell07, 15:52:06)
    38. AGREED: the TAC community will come up with a new TAC Chair proposal - starting with gerrit 10469 (kennypaul, 15:53:45)
    39. ACTION: workgroup will put together collection of ideas regarding gov structure we think is necessary (direct board reps, reasonable-scope tac chair/maybe-vice-chair(s), secretary) (dfarrell07, 15:54:23)
    40. AGREED: the TAC agrees that the key concept is that it's impossible for a single TAC Chair to rep all the projects, so we have to have direct project reps (dfarrell07, 15:57:04)
    41. given agree above, we can proceed on both new TAC Chair description and project reps recommendation in parallel (dfarrell07, 15:58:06)
    42. ttallgren highlights that we might want to do secretary discussion ASAP to get better minutes, edwarnicke suggests quick email discussion then vote (dfarrell07, 15:59:33)
    43. edwarnicke suggest closing on a definition of responsibilites for Secretary quickly via email, then proceeding to nomination and vote (edwarnicke, 16:00:28)

  3. cookies (dfarrell07, 16:00:52)


Meeting ended at 16:01:01 UTC (full logs).

Action items

  1. workgroup will put together collection of ideas regarding gov structure we think is necessary (direct board reps, reasonable-scope tac chair/maybe-vice-chair(s), secretary)


People present (lines said)

  1. dfarrell07 (43)
  2. kennypaul (18)
  3. edwarnicke (9)
  4. ttallgren (7)
  5. morgan_orange (4)
  6. collabot` (4)
  7. mchiosi (2)
  8. frankbrockners (1)
  9. JasonHunt (1)
  10. rossella_s (1)
  11. timirnich (0)
  12. zxiiro (0)
  13. CaseyLF (0)


Generated by MeetBot 0.1.4.