#onap-int: Integration Weekly

Meeting started by gwu at 13:03:13 UTC (full logs).

Meeting summary

    1. thanks to everyone for hard work and dedication; integration is done with Dublin release (gwu, 13:04:12)
    2. expect TSC to approve the release tomorrow (gwu, 13:04:24)
    3. s3p test results were good; most issues were environmental stability (gwu, 13:06:01)
    4. will request TSC to add more resources to the wind river lab: more RAM and CPUs (gwu, 13:06:55)

  1. any remaining dublin issues (gwu, 13:07:20)
    1. issues with SDNC UEB listener on oom master branch (gwu, 13:08:39)

  2. wiki page on CI testing (gwu, 13:11:36)
    1. 3 follow up items from last week: (gwu, 13:11:51)
    2. Brian has a video on testing (gwu, 13:12:06)
    3. Morgan release notes or wiki on the CI testing chain (gwu, 13:12:31)
    4. Yang already well referenced the postman collection, it is enough for the release (morgan_orange, 13:12:59)
    5. CI/CD "don't break the build" priority for El Alto (gwu, 13:13:05)

  3. lab capacity planning (gwu, 13:13:26)
    1. some rules are needed to garantee resources for integration team (and avoid being stuck few days before the release) (morgan_orange, 13:14:00)
    2. a cap shall be defined per project (50 Go? too small...) to motivate using shared resources when possible.. (morgan_orange, 13:15:05)
    3. proposed 50 GB RAM limit per project tenant; teams to share ONAP instances where full ONAP is required (gwu, 13:15:12)
    4. afenner: maybe there could be a way to tell if an ONAP instance is still being used, so we don't have unused ONAP instances taking up space (gwu, 13:18:46)
    5. wind river currently has about 5 TB of RAM, each instance of ONAP takes about 250 GB of RAM (gwu, 13:22:23)
    6. morgan: ONAP at 250 GB seems to take too much RAM for the functionality it provides; maybe TSC can consider this as well (gwu, 13:26:32)
    7. are all ONAP components required? we should identify exact list of components required for each use case (gwu, 13:30:04)
    8. ONAP CPU usage is also something to review; ONAP idle CPU consumption is too high; some pods are at 100% CPU all the time (gwu, 13:30:45)
    9. Brian started to establish a link between the tests / use cases and pods. There are more than 250 pods and 61 robot healthcheck + use cases. It seems that some pods are simply not used. (morgan_orange, 13:31:43)
    10. ACTION: yang create a story to follow-up on real resource usage in ONAP and see if it can be reduced (morgan_orange, 13:32:20)
    11. cost for Orange Lab RAM upgrade: 36K$ for 52x32 Go (Dell and Huawei) (morgan_orange, 13:37:33)
    12. probably one of the main issue: people start VMs and just forget to clean them (morgan_orange, 13:43:34)
    13. better visibility and garbarge collector mechanism could be useful (morgan_orange, 13:43:59)

  4. El Alto priorities (gwu, 13:44:55)
    1. the variety of CI systems for ONAP is hard for newbies to understand (gwu, 13:52:33)
    2. Jim Baker sharing El Alto roadmap (morgan_orange, 13:54:19)
    3. https://wiki.onap.org/display/DW/Release+Planning (morgan_orange, 13:54:24)
    4. Jim reminds us of Aug 12 early drop (full component release) date for El Alto (gwu, 13:54:26)
    5. Lasse has a question on jenkins job for CIST (morgan_orange, 13:56:50)
    6. who is responsible for the jenkins sandbox? see question on rocketchat (morgan_orange, 13:57:25)
    7. new LF ticketing system at support.linuxfoundation.org (gwu, 14:00:13)


Meeting ended at 14:04:15 UTC (full logs).

Action items

  1. yang create a story to follow-up on real resource usage in ONAP and see if it can be reduced


People present (lines said)

  1. gwu (24)
  2. morgan_orange (12)
  3. collabot` (3)


Generated by MeetBot 0.1.4.