#onap-int: integration weekly meeting 6/11/2019

Meeting started by morgan_orange at 13:01:31 UTC (full logs).

Meeting summary

  1. Action points follow-up from previous meeting (morgan_orange, 13:04:26)
    1. AP1: morgan_orange verify SO version on daily El Alto (morgan_orange, 13:04:35)
    2. answer sent, it was still 1.5.2, Introduction of 1.5.3 lead to a regression in SO tests, see elatlo discussion (morgan_orange, 13:04:45)
    3. AP2: morgan_orange christophe consider A&AI gating for frankfurt (morgan_orange, 13:05:23)
    4. first exchange with Sylvain, need to put Christophe in the loop and get a better idea of the A&AI docker build process (morgan_orange, 13:05:45)
    5. AP3: all review the page on category (morgan_orange, 13:06:59)
    6. see discussion on category and test priorization for automation (morgan_orange, 13:07:11)
    7. AP4: morgan_orange share the gating slide deck by mail and consolidate the list of dockers / tests (morgan_orange, 13:07:21)
    8. done, slide deck in the wiki + wiki page created to get feedback (morgan_orange, 13:07:42)

  2. Admin (morgan_orange, 13:07:58)
    1. Frankfurt Admin JIRA managed (morgan_orange, 13:17:00)
    2. https://wiki.onap.org/display/DW/Frankfurt+Milestone+Status (morgan_orange, 13:17:07)
    3. everything is done (morgan_orange, 13:17:11)
    4. committer cleaning done, maybe time to start promoting committers now (morgan_orange, 13:17:19)
    5. request to get new repo pending - more than 1 week (morgan_orange, 13:20:39)
    6. discussion on repositories to host use case code (morgan_orange, 13:20:46)
    7. marco reports concerns due to LF , very slow (morgan_orange, 13:22:46)
    8. oparent update (morgan_orange, 13:23:31)
    9. ACTION: Brian sync with Pam to finalize oparent / policy team (test) (morgan_orange, 13:24:19)
    10. regarding small repo => morgan suggests we give a try with a volunteer project => evaluate the overhead / manage 2 systems (morgan_orange, 13:25:08)

  3. El Alto status (morgan_orange, 13:25:26)
    1. bug SO: #link https://jira.onap.org/browse/OOM-2163 (morgan_orange, 13:25:34)
    2. Brian created a patch to adapt the robot test to the SO regression (http/https entry point declaration) (morgan_orange, 13:26:18)
    3. bug NBI: no patch seen so far (also a Http/https issue) (morgan_orange, 13:27:32)
    4. ACTION: Morgan get status (morgan_orange, 13:27:50)

  4. Frankfurt (morgan_orange, 13:28:21)
    1. demo Monitoring and resource optimization with kube-eagle (morgan_orange, 13:29:06)
    2. Sylvain is showing grafana dashboard using kube eagle. The goal was to have a deep look at the real consumption of resources and compare with the declarative limits & requests (morgan_orange, 13:31:16)
    3. https://github.com/cloudworkz/kube-eagle (morgan_orange, 13:31:51)
    4. connected to the prometheus installaed to monitor the ONAP solution (morgan_orange, 13:32:12)
    5. on our openlab CPU (8%) and RAM (32%) usage is very low compared to what is requested (morgan_orange, 13:33:01)
    6. we are using 14 CPU (request 88) (morgan_orange, 13:33:21)
    7. question from Brian: does it represent installation of idle state => we have both, we can see the consumtion during installation (see some CPU pikes: 1 at the very beginning but not after) (morgan_orange, 13:35:33)
    8. request should be the average usage, limit the "reasonable" max (morgan_orange, 13:36:42)
    9. discussion Andrew/brian => could make sense to create a helm chart for this tooling (morgan_orange, 13:44:41)
    10. sylvain insists on the fact that we should keep external tool => nothing specific (morgan_orange, 13:45:44)
    11. category review (morgan_orange, 13:48:31)
    12. https://wiki.onap.org/pages/viewpage.action?pageId=71835330 (morgan_orange, 13:48:35)
    13. OSJI team is doing security related tests (morgan_orange, 13:52:11)
    14. CSIT follow-up (morgan_orange, 13:56:01)
    15. https://jenkins.onap.org/view/CSIT/ (morgan_orange, 13:56:06)
    16. jenkins page has been updated to exclude verify jjb (morgan_orange, 13:56:14)
    17. deadline indicated to PTL during PTL meeting + by mail. Clean-up of the CSIT tests planned beginning of December => grey jjb will be cleaned if no objection (morgan_orange, 13:56:19)
    18. new use cases for Frankfurt (morgan_orange, 13:57:38)
    19. 5G SON, a meeting is planned on the 8th of November 2 PM UTC (morgan_orange, 13:57:49)
    20. https://zoom.us/j/225581627 (morgan_orange, 13:57:56)
    21. other use cases known? (morgan_orange, 13:58:08)
    22. are all the El Alto reference use case automatically included for Frankfurt? (morgan_orange, 13:58:45)
    23. for El Alto, copy/paste Dublin list, clean a little bit (morgan_orange, 13:59:02)
    24. use case automation priorization, as it will not possible to automate everything, wich use cases are the easiest ones to start (morgan_orange, 14:00:15)
    25. unformal discussion with brian on ete-k8s-sh robot tags (morgan_orange, 14:00:19)
    26. lots of tags (morgan_orange, 14:00:22)
    27. best candidates: health, core, small, medium, healthdist (already the case) + ete, pnf_registrate, stability72h,instantiateVFWCL, cds, HVVES (morgan_orange, 14:00:28)
    28. some timeout issue in Selenium processing => same preload data, VNF and GR API can be used, seems to work fine (morgan_orange, 14:00:54)
    29. to be checked with vCPE (not using VID) (morgan_orange, 14:01:11)
    30. at the moment we have to wait a lottle (camunda cleaning) (morgan_orange, 14:01:38)

  5. Lab status (morgan_orange, 14:01:46)
    1. new results pushed from DT labs (morgan_orange, 14:02:48)
    2. refactory of Daily master/staging in windriver lab to be refactored (morgan_orange, 14:03:39)

  6. AoB (morgan_orange, 14:04:59)
    1. ACTION: morgan_orange sync with Dan for the python3 migration status, what is missing => we coudl already remove the python2.7 target of python-test-utils (morgan_orange, 14:05:26)


Meeting ended at 14:05:28 UTC (full logs).

Action items

  1. Brian sync with Pam to finalize oparent / policy team (test)
  2. Morgan get status
  3. morgan_orange sync with Dan for the python3 migration status, what is missing => we coudl already remove the python2.7 target of python-test-utils


Action items, by person

  1. morgan_orange
    1. morgan_orange sync with Dan for the python3 migration status, what is missing => we coudl already remove the python2.7 target of python-test-utils
  2. UNASSIGNED
    1. Brian sync with Pam to finalize oparent / policy team (test)
    2. Morgan get status


People present (lines said)

  1. morgan_orange (63)
  2. collabot (3)


Generated by MeetBot 0.1.4.