#onap-int: Integration weekly meeting

Meeting started by morgan_orange at 13:58:46 UTC (full logs).

Meeting summary

  1. action points follow-up from previous meeting (morgan_orange, 13:58:53)
    1. no irc bot last time but no AP logged in the minutes (morgan_orange, 13:58:58)

  2. Lab status (morgan_orange, 13:59:04)
    1. Windriver lab Move in progress (morgan_orange, 14:09:00)
    2. wait for end of the week (morgan_orange, 14:09:06)
    3. Catherine asked if there was a plan B in case we got some issues restarting the lab, especially for the developpers. (morgan_orange, 14:09:28)
    4. an option could be to deploy new ONAP on Azure (as we do for the gating) (morgan_orange, 14:09:53)
    5. wait and see windriver lab status (prefered option) (morgan_orange, 14:13:12)
    6. people using windriver lab are not necessrily known by the PTLs (morgan_orange, 14:13:35)
    7. Orange lab: some operations to be planned (new hardware is coming, and current hardware must be given back to vendors (morgan_orange, 14:17:05)

  3. DDF (morgan_orange, 14:17:31)
    1. Who will be there? (morgan_orange, 14:17:48)
    2. several discussions planned lead by integration and/or oom: test strategy evolution, robustness/resiliency/load, python sdk, gating retrospective, news from oom (morgan_orange, 14:23:09)
    3. draft slide decks avaialble in the minutes (morgan_orange, 14:23:16)
    4. feel free to comment/criticise, we will use them for Prague and as a baseline for future discussions (morgan_orange, 14:23:27)
    5. https://wiki.onap.org/display/DW/%5Bintegration%5D+ONAP+2%2C+Wed+UTC+14%3A00?preview=/6593670/76874877/testing_strategy_evolution.pdf (morgan_orange, 14:23:34)
    6. https://wiki.onap.org/display/DW/%5Bintegration%5D+ONAP+2%2C+Wed+UTC+14%3A00?preview=/6593670/76874878/performance_robustness_tests.pdf (morgan_orange, 14:23:40)
    7. https://wiki.onap.org/display/DW/%5Bintegration%5D+ONAP+2%2C+Wed+UTC+14%3A00?preview=/6593670/76874879/onap-pythonsdk.pdf (morgan_orange, 14:23:45)

  4. admin (morgan_orange, 14:24:06)
    1. still some issues to update INFO for csit repos (ticket open) (morgan_orange, 14:24:20)
    2. onap-java repository created last night (request end of november): work done on gitlab.com see later but need to redo on ONAP + docker (morgan_orange, 14:25:50)

  5. El Alto status (morgan_orange, 14:28:26)
    1. light regression observed on Orange El Alto chain (https://orange-opensource.gitlab.io/lfn/tools/results_ts_view/) (morgan_orange, 14:29:16)
    2. https://orange-opensource.gitlab.io/lfn/tools/results_ts_view/ (morgan_orange, 14:29:21)
    3. error on VID not due to VID => due to the move to python3.8 in xtesting-healthcheck (same issue with pnf registrate) (morgan_orange, 14:30:17)
    4. ACTION: morgan investigate the Chromedriver issue introduced with the move to python3.8 => possibility to revert to 3.7 (as it it was OK in 3.7) (morgan_orange, 14:30:24)
    5. Basic Modeling genericparser API Health Check not working well in el alto and master => I would suggest to remove this test from healthcheck (create healthcheck-addons category?) (morgan_orange, 14:31:18)
    6. pod aai-aai-graphgraph still not running (removed in master but change not backported in El Alto) (morgan_orange, 14:32:01)

  6. Frankfurt status (morgan_orange, 14:32:17)
    1. CI status: it seems that we moved away from the rolling release, in gating there are lots of pods in errors (no JIRA created yet) - at least on Azure on Orange (morgan_orange, 14:32:40)
    2. 3 step OOM aaproachs to be reexplained in PTL meeting (morgan_orange, 14:34:40)
    3. https://wiki.onap.org/display/DW/OOM+Gating?preview=/60883390/71831856/3steps%20gating.png (morgan_orange, 14:39:04)
    4. some healthcheck test cases shall be removed from the healthcheck suites as the projects are no more maintained for Frankfurt (Holmes, Pomba, CLI, LOG) (morgan_orange, 14:39:15)
    5. Integration jenkins jobs: no verification jobs in integration? shall we put some? add pylint + unit tests for python based code (possible issues due to the heterogeneity of the repository) (morgan_orange, 14:49:20)
    6. any volunteer to update the jenkins jobs to include a verification on integration repo (morgan_orange, 14:49:29)
    7. ACTION: morgan_orange check if we can add verify job on integration (morgan_orange, 14:49:42)
    8. JIRA: https://jira.onap.org/secure/RapidBoard.jspa?rapidView=207&quickFilter=630 (morgan_orange, 14:49:48)

  7. Status on use cases (morgan_orange, 14:51:21)
    1. vcpe_tosca (@liping Yan Yang) (morgan_orange, 14:51:28)
    2. Video available on the minutes. (morgan_orange, 14:51:35)
    3. vFW DT (Lukasz Rajewski Marco Platania) (morgan_orange, 14:52:31)
    4. implementation is fine (morgan_orange, 14:52:48)
    5. how to integrate them in Ci chains (morgan_orange, 14:54:02)
    6. pnf_registrate (Marcin PrzybyszKrzysztof Ku?micki ) (morgan_orange, 15:00:27)
    7. vFW CDT (Lukasz Rajewski Marco Platania) (morgan_orange, 15:00:43)
    8. 5G-SON (Reshmasree c ) (morgan_orange, 15:00:53)
    9. vCPE (Bartek Grzybowski ) (morgan_orange, 15:00:59)

  8. onap-java (morgan_orange, 15:01:15)
    1. docker created on gitlab.com: https://gitlab.com/onap-integration/docker/onap-java/ (morgan_orange, 15:01:22)
    2. docker shared with policy project for testing (morgan_orange, 15:01:28)
    3. ONAP onap-java repo available since last night (need to commit the code here + put in place the jenkins processing to generae the docker and push them to a registry) (morgan_orange, 15:01:38)


Meeting ended at 15:02:23 UTC (full logs).

Action items

  1. morgan investigate the Chromedriver issue introduced with the move to python3.8 => possibility to revert to 3.7 (as it it was OK in 3.7)
  2. morgan_orange check if we can add verify job on integration


Action items, by person

  1. morgan_orange
    1. morgan_orange check if we can add verify job on integration


People present (lines said)

  1. morgan_orange (59)
  2. collabot` (6)


Generated by MeetBot 0.1.4.