#onap-int: Integration weekly report 28/01/2020

Meeting started by morgan_orange at 13:59:17 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 13:59:23)
    1. AP1: Krzysztof investigate on the driver issue (Selenium chromium not working / firefox OK) (morgan_orange, 14:00:30)
    2. AP2: morgan_orange set a daily CI chain on windriver (morgan_orange, 14:02:23)
    3. not done hopefully this week.. (morgan_orange, 14:02:31)
    4. AP 3morgan_orange create a wiki page for verification job in integration repositories (morgan_orange, 14:03:26)
    5. page created (morgan_orange, 14:03:34)
    6. https://wiki.onap.org/display/DW/Verification+jobs+on+Integration+repositories (morgan_orange, 14:03:38)
    7. AP3: morgan_orange send mail for rocketchat/slack (morgan_orange, 14:04:01)
    8. done but only 3 answers, for the moment everybody seems happy with the rocket chat (morgan_orange, 14:04:07)
    9. Brian answered "https://onap-integration.eastus.cloudapp.azure.com/channel/general" will also work (port 443) but its a self signed certificate so the smart phone apps dont like that in all cases. (Browsers you just need to accept the certificate.) (morgan_orange, 14:04:16)
    10. We really need this to move to an LF FQDN and real certificate. (morgan_orange, 14:04:31)
    11. ACTION: morgan asks for LF FQDN + certificates (morgan_orange, 14:05:21)
    12. AP5: David look at edge controller to see if they can be used for emulator (morgan_orange, 14:05:40)
    13. WIP (morgan_orange, 14:05:42)
    14. AP6: morgan_orange send mail to use case leaders (morgan_orange, 14:05:50)
    15. done, already some answers see next topic on Frankfurt (morgan_orange, 14:06:03)
    16. there is a dedicated integration channel on rocket chat => you can ask Marco for access if needed (morgan_orange, 14:08:26)

  2. Admin (morgan_orange, 14:13:42)
    1. We are green for M2/M3 (but we should not..just found old pending gerrit (> 36h) on testsuite... (morgan_orange, 14:13:50)
    2. if you have patch pending for a while, do not hesitate to add the integration alias in review to give more visibility to your patch (morgan_orange, 14:13:57)
    3. Request from Release management to adjust Milestone criteria to Integration: Frankfurt Deliverables by Milestone (morgan_orange, 14:14:08)
    4. if you have any idea on the good/relevant criteria for Integration (different from component project) (morgan_orange, 14:14:43)
    5. Integration verification jenkins jobs (morgan_orange, 14:15:16)
    6. page created (morgan_orange, 14:15:20)
    7. https://wiki.onap.org/display/DW/Verification+jobs+on+Integration+repositories (morgan_orange, 14:15:25)
    8. we will introduce a python verification in integration (with limited scope for the moment) (morgan_orange, 14:15:49)
    9. introduction of tox.ini to be done (morgan_orange, 14:16:13)
    10. ACTION: bartek add tox for vCPE and vagrant files (morgan_orange, 14:16:27)
    11. ACTION: morgan_orange add verification-python in ci-management for integration (morgan_orange, 14:17:10)
    12. rocketchat still OK? move to slack? IRC, still time to answer to the survey: https://framadate.org/GqWLxFrflGPEZDDR (morgan_orange, 14:19:12)
    13. we keep on rocket chat (morgan_orange, 14:19:20)
    14. Mentorship 2020 program launched (morgan_orange, 14:21:56)
    15. https://wiki.lfnetworking.org/display/LN/Project+Proposal (morgan_orange, 14:22:33)
    16. you can become a mentor if you want (morgan_orange, 14:22:42)

  3. lab status (morgan_orange, 14:22:45)
    1. windriver lab no update (morgan_orange, 14:24:05)
    2. gitlab runner VM restarted (morgan_orange, 14:24:16)
    3. some errors seen in horizon but no mail received so far (morgan_orange, 14:24:29)
    4. DT (src Andreas): we updated our second part of the Lab, where we now test our ElAlto Pipeline. (morgan_orange, 14:24:49)
    5. DT (src Andreas) one of my team members (Michał Jagiełło), which was contributing to the CDS project, will have a look to the PythonSDK and check if he would be able to contribute. (morgan_orange, 14:24:55)
    6. Open discussion on monitoring tools used in the different labs (morgan_orange, 14:26:24)
    7. no lab owner present today (morgan_orange, 14:26:29)
    8. ACTION: organize ad hoc meeting with lab owners to share tooling and best practices (morgan_orange, 14:27:16)

  4. Frankfurt status: (morgan_orange, 14:27:48)
    1. Orange Daily Master (we use master and no overide staging dockers): only 2 pods (on 242) not running onap-oof-oof-cmso-optimizer-577ccbd874-gxvql,onap-oof-oof-cmso-service-84c77bcd65-wgx68 (morgan_orange, 14:35:26)
    2. we removed several tests (NOFO for frankfurt) but they are still deployed in master: shall we keep them or remove them from the installation (Holmes, Pomba, logs, ..) (morgan_orange, 14:36:34)
    3. Use case update (morgan_orange, 14:40:05)
    4. review use case page (based on use case leader feedback) (morgan_orange, 14:59:11)
    5. already several answers, need to follow up with some projects, but everybody looks confident for Frankfurt (morgan_orange, 14:59:40)
    6. JIRA: https://jira.onap.org/secure/RapidBoard.jspa?rapidView=207&quickFilter=630 (morgan_orange, 14:59:47)
    7. Gate update (morgan_orange, 14:59:55)
    8. New security tests added and shared with PTL - missing limits, still docker run as root, cis tests failing + first scan tests (thanks to Pawel) (morgan_orange, 14:59:59)
    9. sync meeting to be planned with Seccom / OOM / Integration => who will fix all the security issues.. (morgan_orange, 15:00:05)
    10. any update on pnf_registrate? (morgan_orange, 15:00:11)
    11. ACTION: morgan_orange contact Kzrysztof for several updates (dcae discussion/pnf_registrate/..) (morgan_orange, 15:00:37)

  5. AoB (morgan_orange, 15:00:43)
    1. Bartek question on xtesting, will continue offline (morgan_orange, 15:00:49)
    2. Pawel: security alignment move security robot tests to python/bash and integrate in xtesting (morgan_orange, 15:01:04)
    3. Vishal: first meeting listen and learn more work on SDNC/APPC integration for El Alto (morgan_orange, 15:01:10)


Meeting ended at 15:01:12 UTC (full logs).

Action items

  1. morgan asks for LF FQDN + certificates
  2. bartek add tox for vCPE and vagrant files
  3. morgan_orange add verification-python in ci-management for integration
  4. organize ad hoc meeting with lab owners to share tooling and best practices
  5. morgan_orange contact Kzrysztof for several updates (dcae discussion/pnf_registrate/..)


Action items, by person

  1. morgan_orange
    1. morgan_orange add verification-python in ci-management for integration
    2. morgan_orange contact Kzrysztof for several updates (dcae discussion/pnf_registrate/..)
  2. UNASSIGNED
    1. morgan asks for LF FQDN + certificates
    2. bartek add tox for vCPE and vagrant files
    3. organize ad hoc meeting with lab owners to share tooling and best practices


People present (lines said)

  1. morgan_orange (64)
  2. collabot` (4)


Generated by MeetBot 0.1.4.