#onap-int: integration weekly meeting 15/04/2020
Meeting started by morgan_orange at 13:01:10 UTC
(full logs).
Meeting summary
- Action points follow-up (morgan_orange, 13:01:36)
  - AP1 morgan_orange plan new JIRA to address the
    points mentioned by SECCOM (morgan_orange,
    13:01:44)
 
  - started but not completed (morgan_orange,
    13:01:49)
 
  - ACTION: morgan_orange
    plan new JIRA to address the points mentioned by SECCOM (morgan_orange,
    13:01:54)
 
  - AP2 morgan_orange contact Daniel to share view
    on the status of the robot deployment for Frankfurt (morgan_orange,
    13:06:23)
 
  - done, too late for micro service architecture,
    secure simple evolution (update of the repositories + build
    chain) (morgan_orange,
    13:06:29)
 
  - micro services archi postpone to Guilin
    (morgan_orange,
    13:06:34)
 
  - AP3 marco launch scripts to reinstall ONAP on
    SB-04 for VNFSDK (morgan_orange,
    13:06:43)
 
  - crosscheck with him offline (morgan_orange,
    13:06:59)
 
  - AP4 morgan_orange reschedule a 15 slots for ATT
    new test framework (morgan_orange,
    13:07:10)
 
  - done see next topic (morgan_orange,
    13:07:18)
 
  - AP5 morgan_orange continue mailthread, discuss
    on possible testsuite + list ATT integration contributors
    (morgan_orange,
    13:07:26)
 
  - done (morgan_orange,
    13:07:35)
 
  - AP6 morgan_orange initiate a wiki page to
    initiate discussion on Guilin priorities (morgan_orange,
    13:07:40)
 
  - done (morgan_orange,
    13:07:44)
 
  - AP3 done (morgan_orange,
    13:09:10)
 
 
- Admin (morgan_orange, 13:09:16)
  - Ready for self release testsuite 1.6.0: did
    anyone test the new docker? (morgan_orange,
    13:09:26)
 
  - Introduction of a verification on doc (rst +
    md) in progress...to avoid regression in doc (morgan_orange,
    13:10:37)
 
  - externalization of pnf-simulator seems on good
    track (morgan_orange,
    13:12:27)
 
 
- Introduction AT&T SDN testing framework (morgan_orange, 13:14:30)
  - ACTION: morgan_orange
    update new version of the pdf describing the SDN framework
    (morgan_orange,
    13:14:48)
 
  - legacy ONAP Robot Framework  => refactored
    with focus on //ization (morgan_orange,
    13:17:41)
 
  - framework targeting Dev and Operation
    community (morgan_orange,
    13:21:10)
 
  - portable, up to 65% reusable code (morgan_orange,
    13:23:16)
 
  - question on the opportunity  to test this
    framework for G version (morgan_orange,
    13:30:58)
 
  - open question onf the capability to decouplet
    opensource part from proprietary (morgan_orange,
    13:32:23)
 
 
- Frankfurt status (morgan_orange, 14:05:22)
  - almost all the components have been integrated
    in OOM Master (morgan_orange,
    14:05:27)
 
  - https://wiki.onap.org/display/DW/Frankfurt+Readiness+dashboard
    (morgan_orange,
    14:05:32)
 
  - CLI, MSB and Music still in the OOM gates
    (security issues with hardcoded certificates) (morgan_orange,
    14:05:36)
 
  - Blocking issues: 1: Frankfurt Release
    Integration Test Blocking Issues (morgan_orange,
    14:05:41)
 
  - https://wiki.onap.org/display/DW/1%3A+Frankfurt+Release+Integration+Test+Blocking+Issues
    (morgan_orange,
    14:05:47)
 
  - CI status (Daily Master) (morgan_orange,
    14:05:52)
 
  - https://gating-results.onap.eu/results/
    (morgan_orange,
    14:05:56)
 
  - test status: (morgan_orange,
    14:06:01)
 
  - Security (last miles for rooted pods (<20)
    and http public end points (Music and CLI) (morgan_orange,
    14:06:05)
 
  - E2E: pnf_registrate looks better (1/2 OK - DCAE
    part OK), E2E better since AAI update on service-schema (basic_vm ok
    on some gating), freeradius_nbi: discussion in progress with NBI and
    SO, APi could have been modified (morgan_orange,
    14:06:10)
 
  - Andreas reported a pb on onap-tests, as we are
    doing the test in // but not always using a unique ID, it seems that
    the SDC gets lost and distributions are not really completed, all
    are said to be OK but SO saw only hte first one (morgan_orange,
    14:07:20)
 
  - no resources to go further on vCPE for the
    moment (morgan_orange,
    14:07:36)
 
  - JIRA: think to update your Jira (close / fix or
    move to G or H) (morgan_orange,
    14:07:44)
 
 
- Use cases (morgan_orange, 14:07:48)
  - Health of SB-01 => shall we reinstall it on
    master (without staging assuming that 90% of the docker have been
    released (music, MSB and CLI missing) Frankfurt Readiness
    dashboard (morgan_orange,
    14:07:53)
 
  - Marco indicates that SB-01 is used (all the
    components have not been installed, expalining why there are so many
    healthcheck errors) (morgan_orange,
    14:08:14)
 
  - morgan indicates that robot has been updated to
    1.6.0-staging (morgan_orange,
    14:08:31)
 
  - SB-04 installed last week (morgan_orange,
    14:08:39)
 
  - SB-02 or 03 to be installed begining of next
    week (morgan_orange,
    14:08:56)
 
  - could use OOM Master (95% of RCO with possibly
    staging for MSB, CLI, MUSIC and OOF?) (morgan_orange,
    14:09:25)
 
  - Review of the use cases page (morgan_orange,
    14:09:30)
 
  - https://wiki.onap.org/display/DW/2%3A+Frankfurt+Release+Integration+Testing+Status
    (morgan_orange,
    14:09:35)
 
  - ACTION: morgan_orange
    send a mail to use case owner to indicate the availability of a lab
    next week + see how we will manage the progress reporting (during
    weekly meeting?) (morgan_orange,
    14:10:13)
 
  - question from marcin => current page with
    baisc status indicators (<90 <95 completed) is very limited
    => init / in progress / done (morgan_orange,
    14:10:51)
 
  - we do not have information on the number of use
    cases / test plan status / ... (morgan_orange,
    14:11:11)
 
  - morgan_orange indicates that ideally we should
    move from wiki to gate (as for pnf_registrate) but it is not
    trivial..and it will take time but he agrees that declarative status
    is misleading - test case may work in specific environement and be
    very difficult to replay in another, that is why a gate would be
    better.. (morgan_orange,
    14:12:35)
 
 
- guiling (morgan_orange, 14:12:43)
  - no meeting next week due to vF2F (morgan_orange,
    14:12:44)
 
  - topic submitted to defined Guilin
    priorities (morgan_orange,
    14:12:50)
 
  - wiki page initiated (morgan_orange,
    14:12:55)
 
  - https://wiki.onap.org/display/DW/Integration+Priorities+for+Guilin
    (morgan_orange,
    14:12:59)
 
 
Meeting ended at 14:13:01 UTC
(full logs).
Action items
  - morgan_orange plan new JIRA to address the points mentioned by SECCOM
 
  - morgan_orange update new version of the pdf describing the SDN framework
 
  - morgan_orange send a mail to use case owner to indicate the availability of a lab next week + see how we will manage the progress reporting (during weekly meeting?)
 
Action items, by person
  -  morgan_orange 
    - morgan_orange plan new JIRA to address the points mentioned by SECCOM
 
    - morgan_orange update new version of the pdf describing the SDN framework
 
    - morgan_orange send a mail to use case owner to indicate the availability of a lab next week + see how we will manage the progress reporting (during weekly meeting?)
 
  
 
People present (lines said)
  - morgan_orange (63)
 
  - collabot` (4)
 
Generated by MeetBot 0.1.4.