14:17:55 <morgan_orange> #startmeeting Integration weekly meeting 10/06/2020
14:17:55 <collab-meetbot> Meeting started Wed Jun 10 14:17:55 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:17:55 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:17:55 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_10_06_2020'
14:18:04 <morgan_orange> #topic Action point follow-up
14:18:16 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/onap-int.2020-06-03-14.23.html
14:18:27 <morgan_orange> #info AP1 morgan_orange share presentation with windriver lab then onap-discuss , plan cleaning
14:18:41 <morgan_orange> #info done, mal sent + wiki page created, goal end of June, see next topic
14:18:51 <morgan_orange> #info AP2 morgan_orange study articulation TEST / INT on jira
14:20:06 <morgan_orange> #info TEST (testsuite) and INT (intégration) are 2 different JIRA projects. So far I was mainly considering INT for everything (Epic, task,..). TEST could be used for test case (robot, pythonsdk, bash,..) associated with Integration
14:20:47 <morgan_orange> #info only concern could be to miss JIRA (with 1 project, it is easier to track) but it makes sense and conforts the ideas that there are several projects in Integration :)
14:21:05 <morgan_orange> #info AP3 morgan_orange initiate the request for repository creation
14:21:26 <morgan_orange> #info mail thread with Daniel and Marek, see next topic on Robot util wrapper
14:21:35 <morgan_orange> #topic Admin
14:21:47 <morgan_orange> #info windrevier cleaning operation planned end of June
14:22:01 <morgan_orange> #info wiki page created to track the resources used on wondriver lab
14:22:09 <morgan_orange> #link https://wiki.onap.org/display/DW/Windriver+lab+Frankfurt+cleaning+campaign
14:22:42 <morgan_orange> #info surprisingly it seems that APPC was the project consuming the more resources over the last 6 months (stats done from El Alto Release on the 24th of October)
14:22:57 <morgan_orange> #info lots of projects identified only by their uuid
14:23:23 <morgan_orange> #info first projects already indicated they want to keep some resources
14:23:35 <morgan_orange> #action morgan_orange give a status to PTL during PTL meeting
14:23:42 <morgan_orange> #info vF2F event
14:23:53 <morgan_orange> #info several interesting topics for people dealing with Integration
14:24:18 <morgan_orange> #info presentation on pythonsdk, robot, automation in CI, Integration priorities, vFW use case, CDS,...
14:24:30 <morgan_orange> #link https://wiki.lfnetworking.org/pages/viewpage.action?pageId=34606297
14:27:41 <morgan_orange> #action morgan_orange add Marcin + Krzysztof as co speaker for from robot to CI session
14:33:44 <morgan_orange> #info add also S.Goosh for windriver talk
14:34:19 <morgan_orange> #info daily logs can now be pushed to LF
14:34:23 <morgan_orange> #link https://logs.onap.org/onap-integration/
14:35:01 <morgan_orange> #info results of SB-00 lab status reinstallation of yesterday pushed to https://logs.onap.org/onap-integration/windriver-SB00/2020-06-09/
14:35:11 <morgan_orange> #topic frankfurt
14:36:01 <morgan_orange> #info RC2 blocked by issue detected on Mnday on AAF-SMS/OOF, hardcoded AAF-SMS certificate expired on the 3rd of June leading to OOF init errors
14:36:14 <morgan_orange> #info error was reported by Master and Frankfurt daily chains
14:36:47 <morgan_orange> #info Jira created => https://jira.onap.org/browse/AAF-1159
14:37:44 <morgan_orange> #info this hardcoded certificate was fixed by OOM team, but another was detected (quorum) - fix needed (SECCOM no go)
14:38:02 <morgan_orange> #info new gating will be attempt to see if OOF start issue is systematically reproducible or not
14:38:21 <morgan_orange> #info meanwhile SB-00 has been reinstalled on windriver/Intel Lab (OOF issues)
14:38:43 <morgan_orange> the RC2 dockers have been provided by all the projects, so it is possible to perform regression tests with RC2
14:38:52 <morgan_orange> #info the RC2 dockers have been provided by all the projects, so it is possible to perform regression tests with RC2
14:39:21 <morgan_orange> #info mail sent to the use case owner to perform verification and get feedback on RC2 column of https://wiki.onap.org/display/DW/2%3A+Frankfurt+Release+Integration+Testing+Status
14:39:51 <morgan_orange> #info note that during the reinstallation, it was detected that the kubernetes and helm versions were no more correct in SB-0x installation scripts
14:40:46 <morgan_orange> #info Brian provided a fix to consider right recommended versions (new versions needed to leverage new kubernetes functions)
14:41:22 <morgan_orange> #info note has been added to S3P documentation to explain that the test has been performed on an old infrastructure (El Alto) even if the dockers were the frankfurt one.
14:50:26 <morgan_orange> #link https://gerrit.onap.org/r/c/integration/+/108969
14:51:04 <morgan_orange> #info remaining work: 1) RC2 regression tests (except OOF)
14:51:23 <morgan_orange> #info remaining work: 2) reinstallation of dockers with OOF fix
14:51:44 <morgan_orange> #info remaining work: 3) regression test for OOM test
14:51:53 <morgan_orange> #info remaingin work 4) update of the documentation
14:52:21 <morgan_orange> #info note on documentation minor updates added in the patch for S3P update
14:52:37 <morgan_orange> #info gerrit voting -1 because one link in CCVPN doc (Amsterdam) is broken
14:52:58 <morgan_orange> #action morgan_orange contact CCVPn team to see if the link can be fixed (part of procedure so hard to remove)
14:53:03 <morgan_orange> #topic Guilin
14:53:11 <morgan_orange> #info python sdk update planned for next week
14:53:31 <morgan_orange> #ino first tag about to be created - regression tests on frankfurt in progress
14:53:39 <morgan_orange> #link Action point follow-up
14:53:43 <morgan_orange> #unfo
14:53:45 <morgan_orange> #undo
14:53:46 <collab-meetbot> Removing item from minutes: #link Action
14:53:55 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk
14:54:15 <morgan_orange> #info discussion on the possible scenation to be created in https://git.onap.org/testsuite/pythonsdk-tests/
14:54:34 <morgan_orange> #info basic_vm, clearwater_vim, freeradius_nbi => to replace existing tests
14:55:03 <morgan_orange> #info to be included basic_cnf, basic policy, basic_network, basic_cds, basic_closedloop, vfw_closedloop,...
14:55:53 <morgan_orange> #action all brainstorm on all the basic tests we need to ensure a better coverage ONAP by dedicated tests (not by use cases)
14:56:12 <morgan_orange> #info presentation robot-util to leverage pythonsdk by marek
14:56:22 <morgan_orange> #info Bell contributors interested to join the effort
14:56:44 <morgan_orange> #action morgan_orange initiate the request to create a new repository testsuite/robot-utils
14:57:08 <morgan_orange> #info goal is to simplify the usage of pythonsdk for robot use case
14:57:24 <morgan_orange> #info Marek interested also to work on a Test developer guide, to help newcommers to create tests
14:57:28 <morgan_orange> #info currently few info
14:57:37 <morgan_orange> #info there is a page for robot end users
14:57:57 <morgan_orange> #link https://docs.onap.org/en/frankfurt/submodules/integration.git/docs/docs_robot.html?highlight=robot
14:58:08 <morgan_orange> #info and some Q&A but nothing really structured
14:58:30 <morgan_orange> #action morgan_orange create an Guilin Epic for this new doc and assign Marec to it
14:58:46 <morgan_orange> #info presentation vnfsdk by Krrzysztof
14:59:42 <morgan_orange> #info VNFSDK allows to verify tosca/zip packages, implementation done in SDC by E/// and on vnfsdk by Nokia following SOL-000 and SOl-004 ETSI reco
14:59:56 <morgan_orange> #info a use case is available pnf preonboarding
15:00:01 <morgan_orange> #info robot tag is available
15:00:18 <morgan_orange> #action morgan_orange krzysztof integrate this use case in CI Master
15:00:40 <morgan_orange> #info currently runnable in robot pod + bash script (to generate and push scripts)
15:01:11 <morgan_orange> #info shall be possible to re-use hvves approach to execute it as precondition in a xtesting docker
15:01:22 <morgan_orange> #link https://docs.onap.org/en/latest/submodules/integration.git/docs/docs_pnf_onboarding_preonboarding.html?highlight=pre%20onboarding
15:01:41 <morgan_orange> #info work started in Casablanca and most of the dev done for Dublin
15:01:44 <morgan_orange> #endmeeting