05:26:00 <morgan_orange> #startmeeting Integration weekly meeting 17/06/2020
05:26:00 <collab-meetbot`> Meeting started Thu Jun 18 05:26:00 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:26:00 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:26:00 <collab-meetbot`> The meeting name has been set to 'integration_weekly_meeting_17_06_2020'
05:26:14 <morgan_orange> #topic action point follow-up
05:26:36 <morgan_orange> #info AP1 morgan_orange give a status on windriver lab to PTL during PTL meeting
05:26:39 <morgan_orange> #info done
05:26:49 <morgan_orange> #info AP2 morgan_orange add Marcin + Krzysztof as co speaker for from robot to CI session
05:27:03 <morgan_orange> #info done, first draft of the slide deck planned for today
05:27:14 <morgan_orange> #info AP3 morgan_orange contact CCVPn team to see if the link can be fixed (part of procedure so hard to remove)
05:28:00 <morgan_orange> #info done, the section has been removed from the doc + mail exchange with CCVPN use case owner for a depper update in G version
05:28:10 <morgan_orange> #info AP4 all brainstorm on all the basic tests we need to ensure a better coverage ONAP by dedicated tests (not by use cases)
05:28:14 <morgan_orange> #info see next section
05:28:28 <morgan_orange> #info AP5 morgan_orange initiate the request to create a new repository testsuite/robot-utils
05:29:28 <morgan_orange> #info green light from TSC, procedure of self creation tried but missing rights. problem reported to Jessica, if not possible, usual way will be used
05:29:40 <morgan_orange> #info AP6 morgan_orange create an Guilin Epic for this new doc and assign Marec to it
05:29:43 <morgan_orange> #info done
05:30:05 <morgan_orange> #link https://jira.onap.org/browse/TEST-236
05:30:21 <morgan_orange> #info AP7 morgan_orange krzysztof integrate this use case in CI Master
05:30:31 <morgan_orange> #info not done yet
05:30:46 <morgan_orange> #action morgan_orange krzysztof integrate preonboarding  use case in CI Master
05:30:56 <morgan_orange> #topic admin
05:31:26 <morgan_orange> #info Windriver/Intel lab: cleaning operation planned for end of June
05:31:36 <morgan_orange> #link https://wiki.onap.org/display/DW/Windriver+lab+Frankfurt+cleaning+campaign
05:31:53 <morgan_orange> #info presentation done during PTL meeting on Monday
05:32:57 <morgan_orange> #link https://wiki.onap.org/display/DW/PTL+2020-06-15?preview=/84647587/84653034/Certificates_PTLmeeting_15062020.pdf
05:33:44 <morgan_orange> #info discussion on the resources needed for integration
05:33:59 <morgan_orange> #info proposal shared with integration team
05:34:12 <morgan_orange> #info no objection for refactoring
05:34:28 <morgan_orange> #info Andreas aggrees that it will be clearer
05:34:45 <morgan_orange> #info morgan_orange indicates that an approval is needed from Marco and Brian
05:35:12 <morgan_orange> #action morgan_orange contact Marco & Brian to get their feedback on Windriver/Intel Integration resources
05:35:19 <morgan_orange> #info new request for resources for terraform based installation
05:36:04 <morgan_orange> #link https://jira.onap.org/browse/OOM-2425
05:36:17 <morgan_orange> #action morgan_orange create new project Integration-Terraform
05:36:56 <morgan_orange> #info patchset on oparent/cia repository but no activity on this repo since 2 years
05:37:34 <morgan_orange> #info proposal to archive oparent/cia
05:37:37 <morgan_orange> #agreed
05:37:54 <morgan_orange> #topic
05:37:59 <morgan_orange> #undo
05:37:59 <collab-meetbot`> Removing item from minutes: #topic
05:38:04 <morgan_orange> #topic Frankfurt
05:39:22 <morgan_orange> #info CI status good since the AAF-SMS patch merge, CI criteria are OK, see Daily frankfurt reports
05:39:33 <morgan_orange> #info demo artifact published yesterday
05:40:28 <morgan_orange> #link https://nexus.onap.org/content/repositories/releases/org/onap/demo/vnf/
05:41:28 <morgan_orange> #info issues with some use cases (dealing with CDS), Lukasz working on workaround
05:41:56 <morgan_orange> #info Lukasz reports that use case was OK for RC0 and RC1, bug fix on SO heatbridge leads to regression
05:42:29 <morgan_orange> #info SO heatbridge does less than the robot heatbridge and requires adaptations in the tests
05:42:45 <morgan_orange> #infoservice release will be needed to fix the use cases
05:44:13 <morgan_orange> #info it shows a process issue, heatbridge code has been introduced after M4 (not a simple bug fix)
05:45:51 <morgan_orange> #info Lukasz would have liked to have more time after RC2 (RC2 and sign-off merged) but as RC0 and RC1 were OK, no such regression was expected
05:46:02 <morgan_orange> #topic Guilin
05:46:11 <morgan_orange> #info update on onapsdk by Michal
05:46:23 <morgan_orange> #info a presentation is planned next week during the vF2F
05:46:35 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk
05:47:10 <morgan_orange> #info new test scenarios leveraging this SDK can be hosted in https://git.onap.org/testsuite/pythonsdk-tests/
05:47:32 <morgan_orange> #info open discussion on the scenarios
05:47:35 <morgan_orange> #link https://etherpad.opnfv.org/p/onap_integration_onapsdk_scenarios
05:47:52 <morgan_orange> #action all complete the etherpad to list possible scenarios
05:48:18 <morgan_orange> #info new Guilin Jira board created
05:48:25 <morgan_orange> #link https://jira.onap.org/secure/RapidBoard.jspa?rapidView=221&selectedIssue=INT-1268
05:48:51 <morgan_orange> #info no specific filters for this board (as for frankfurt) but if needed I can recreate some filters
05:49:03 <morgan_orange> #info new robot pod architecture
05:49:11 <morgan_orange> #info testsuite/oom helm chart to be moved back to OOM
05:49:18 <morgan_orange> #info leveraging on new architecture proposed by Daniel Rose (3 pods: 1 robot, 1 DB, 1 web server)
05:50:58 <morgan_orange> #info resources needed to implement this new version of the ropot pod => proposal to keep old (testsuite/oom) and new system (oom) in // before removing the legacy one
05:51:11 <morgan_orange> #info new use cases
05:51:21 <morgan_orange> #info first try on check certificates (+ pres done for PTL)
05:51:28 <morgan_orange> #link https://gerrit.onap.org/r/c/integration/+/109207/2
05:52:02 <morgan_orange> #info we can already see that some certificates are already no more valid, dgbuilder expired 280 days ago, refrep in 3 days and so-vnfm in 31 days
05:52:16 <morgan_orange> #info preonboarding, vcpe_tosca still in the loop
05:52:24 <morgan_orange> #info Upstream cds tests are coming
05:52:45 <morgan_orange> #action trevor provide the Bell upstream suite (need to select the place and check legal issues first)
05:53:04 <morgan_orange> #info security test: cleaning of the xfail lists on master?
05:53:16 <morgan_orange> #info http enpoint => update: switch to nonssl?
05:53:41 <morgan_orange> #action Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
05:54:02 <morgan_orange> #info success criteria for the pod limit test to be defined
05:54:13 <morgan_orange> #info check version according to SECCOM recommentations => ask SECCOm to  move their list through a file in their repo to get a gerrit reference  rather than a wiki page?
05:54:47 <morgan_orange> #aciton morgan_orange contact SECCOM for xfail/version list in SECCOM repo
05:54:51 <morgan_orange> #topic AoB
05:55:23 <morgan_orange> #action thierry/Andreas discuss onapsdk scenario structure and push first scenario in ONAP repo
05:55:48 <morgan_orange> #info discussion on SO/Multicloud scenario in CI chain
05:55:58 <morgan_orange> #info 2 options: 2 chains or reconfiguration during one chain
05:56:11 <morgan_orange> #info config change can be done by a modification in a configmap (no deep dive into Database needed)
05:56:50 <morgan_orange> #info morgan_orange precises that it is possible to create 2 stages smoke_config_so then smoke_config_multicloud in the CI chain to cover the 2 configurations
05:57:25 <morgan_orange> #info question on the need of an El Alto CI chain
05:58:13 <morgan_orange> #info morgan_orange indicates that keeping the 2 last Stable chains in CI should be the target. In Orange, El Alto was disabled to be replaced by daily frankfurt by lack of resources.
05:58:33 <morgan_orange> #info presentation in TSC will report such lack of resources
05:59:17 <morgan_orange> #action morgan_orange contacts OOM to precise that it would be great to keep last 2 stable versions in CI
05:59:21 <morgan_orange> #endmeeting