#onap-meeting: ONAP F2F

Meeting started by CaseyODL at 01:07:58 UTC (full logs).

Meeting summary

    1. https://wiki.onap.org/pages/viewpage.action?pageId=4719246 (kennypaul, 01:09:17)

  1. Service Orchestrator (CaseyODL, 01:11:13)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=4719246 (kennypaul, 01:11:28)
    2. 14 TSC members present in the meeting room. (kennypaul, 01:24:20)
    3. 13 voted for approval (SteveT, 01:27:35)
    4. vote passed (SteveT, 01:27:44)
    5. VOTE: Voted on "Shall the TSC approve the SO Project as an incubation project within ONAP provisional on alignment with the overall architecture if such dependencies are identified?" Results are (phrobb, 01:29:01)
    6. AGREED: The Service Orchestration is approved as an incubation project provisional on alignment with overall architecture.. (CaseyODL, 01:29:12)

  2. DCAE (kennypaul, 01:29:25)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3247121 (kennypaul, 01:29:55)
    2. DCAE vote deferred pending additional evaluation. (kennypaul, 02:05:12)

  3. Network Function Change Management (kennypaul, 02:06:19)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=4719331 (kennypaul, 02:06:28)
    2. Emmanouil states that the NFCM project will be primarily focused on Change Management at first rather than Architecture. (CaseyODL, 02:16:25)
    3. the vote for NFCM will be delayed pending further adjustments. (CaseyODL, 02:21:36)

  4. Common Controller Framework (kennypaul, 02:22:00)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3247135 (kennypaul, 02:22:08)
    2. the key message is that the CCF is that usage is optional. (CaseyODL, 02:46:31)
    3. 12 hands raised in positive, 2 opposed in the room. (SteveT, 02:47:16)
    4. passed (SteveT, 02:47:36)
    5. AGREED: The Common Controller SDK Project is approved as an incubation project within ONAP. (CaseyODL, 02:47:52)
    6. VOTE: Voted on "Shall the TSC approve the Common Controller SDK Project as an incubation project within ONAP on the condition that it is clear that the use of these functions are optional?" Results are (phrobb, 02:48:33)

  5. SDN-C (kennypaul, 02:55:04)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3247281 (CaseyODL, 03:11:26)
    2. The SDN-C is designed to run one instance per enterprise. (CaseyODL, 03:11:33)
    3. SDN-C will support 3rd party controllers in the future with an adapter. (CaseyODL, 03:12:50)
    4. relation between the common controller framework and the SDN-C is that the ccf provides components to build a controller, and the SDN-C is actually a controller. (SteveT, 03:19:24)
    5. Question - for e.g. Volte connection between ran and core, is that supported. Answer is yes. (SteveT, 03:21:27)
    6. SDN-C could call SDN-agent if needed (SteveT, 03:22:33)
    7. interfaces can be part of the application, even if the use components from CCF to realize (SteveT, 03:25:36)
    8. look at multi-vim interfaces (SteveT, 03:25:47)
    9. clarification, this doesn't speak to cloud infra. (SteveT, 03:26:41)
    10. vote started. 11 approved, 0 abstain, 0 objection. Vote passes, the project is approved (SteveT, 03:29:05)
    11. VOTE: Voted on "Shall the TSC approve the SDN-C project as an incubation project within ONAP?" Results are (phrobb, 03:29:42)
    12. AGREED: The SDN-C Project is approved as an incubation project within ONAP. (CaseyODL, 03:29:57)

  6. Modeling (kennypaul, 03:30:00)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3247202 (kennypaul, 03:30:09)
    2. modelling is providing information modelling. expectation is that other projects will do the data model. (SteveT, 03:30:54)
    3. in the case that multiple projects use the same model, then modelling project will work with those projects on the need to specificy teh data model based on the concensous with the other projects (SteveT, 03:31:52)
    4. comment on project description: don't assume the top level is imperative, but be more open (SteveT, 03:36:42)
    5. here is a proposal to seperate out the modelling activities and make that a subcommittee and remaining aspects such as tools remain in the modelling project. (SteveT, 03:42:06)
    6. will come back later today. The idea is to remove the parts that would be in the sub-committee. There will be a breakout. (SteveT, 03:53:48)

  7. Documentation (kennypaul, 03:54:22)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3247185 (kennypaul, 03:54:36)
    2. a F2F vote was cast and 11 member voted to approve the project. 0 opposed. (CaseyODL, 04:03:19)
    3. AGREED: the Documentation Project is approved as an incubation project within ONAP (CaseyODL, 04:03:21)

  8. External API Framework (CaseyODL, 04:03:32)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246995 (kennypaul, 04:03:46)
    2. Common set of APIs for Carriers to utilize ONAP for OSS/BSS. (CaseyODL, 04:04:30)
    3. A vote was cast and 13 votes were cast in favor and no objections were cast. (CaseyODL, 04:13:19)
    4. AGREED: External API Framework was approved as a incubation project within ONAP. (CaseyODL, 04:14:36)

  9. VNF Requirements (kennypaul, 04:14:38)
    1. https://wiki.onap.org/display/DW/VNF+Requirements (kennypaul, 04:14:53)
    2. remove the open-o and open ecomp from depenancies (SteveT, 04:21:12)
    3. this is a common set of requirements, but there could be optionality etc that has to be done. (SteveT, 04:25:08)
    4. 10 votes for approval, 0 abstains and 0 against. (CaseyODL, 04:32:00)
    5. VOTE: Voted on "Shall the TSC approve the VNF Requirements project as an incubation project within ONAP?" Results are (CaseyODL, 04:32:04)
    6. AGREED: the VNF Requirements project is approved as an incubation Project within ONAP. (CaseyODL, 04:32:31)

  10. A&AI (kennypaul, 04:32:33)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246952 (kennypaul, 04:33:12)
    2. goals of A&AI is to provide real-time views of Resources and Services and their relationships. (CaseyODL, 04:34:49)
    3. A vote was cast to approve the A&AI project and 13 voted in favor, 0 abstained, 0 voted against. (CaseyODL, 04:56:18)
    4. VOTE: Voted on "Shall the TSC approve the A&AI project as an incubation project within ONAP?" Results are (CaseyODL, 04:56:23)
    5. AGREED: the TSC approved the A&AI project as an incubation project within ONAP. (CaseyODL, 04:56:47)

  11. APPC (kennypaul, 06:04:44)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246996 (kennypaul, 06:04:52)
    2. There a comment that some of the functionality regarding lcm seems to overlap with SO. (SteveT, 06:21:42)
    3. There was a comment that this would have to be resolved with the discussions planned with SO, VNF-C (SteveT, 06:22:20)
    4. 13 hands raised in the room, 0 abstained, 0 objection. Vote passes (SteveT, 06:22:50)

  12. breakout sessions (kennypaul, 06:23:14)
    1. openlab room 1612 (kennypaul, 06:23:55)
    2. modeling room 1614 (kennypaul, 06:24:52)
    3. a&ai 1616 (cdonley, 06:25:07)
    4. directed grap 1629 (SteveT, 06:26:03)
    5. VOTE: Voted on "Shall the TSC approve the APP-C Project as an incubation project within ONAP provisional on alignment with the overall architecture if such dependencies are identified?" Results are (phrobb, 06:27:25)
    6. voted in room 13 +1, no -1, no 0 (kennypaul, 09:03:31)
    7. AGREED: Vulnerability Management" Process as documented on the wiki page (kennypaul, 09:04:18)
    8. VOTE: Voted on "Shall the TSC approve the "Vulnerability Management" Process as documented on the wiki page of the same name?" Results are (phrobb, 09:05:12)

  13. DCAE update (kennypaul, 09:05:38)
    1. voted in room 14 +1 (kennypaul, 09:14:54)
    2. VOTE: Voted on "Shall the TSC approve the DCAE project as an incubation project within ONAP?" Results are (phrobb, 09:15:31)

  14. ESR (kennypaul, 09:15:35)
    1. voted in room 13 +1, 0-1, 0 0 (kennypaul, 09:26:57)
    2. VOTE: Voted on "Shall the TSC approve the Holmes project as and incubation project within ONAP?" Results are (phrobb, 09:27:43)

  15. modeling (kennypaul, 09:30:56)
    1. voted in room 14 +1, 0 -1, 0 0 (kennypaul, 09:31:38)
    2. VOTE: Voted on "Shall the TSC approve the Modeling Project as an incubation project within ONAP?" Results are (phrobb, 09:35:55)
    3. votes in room for Gildas 14 +1, 0 -1, 0 0 (kennypaul, 09:36:13)

  16. next F2f meeting (kennypaul, 09:46:30)
    1. ACTION: doodle pole for July f2f (kennypaul, 09:47:29)

  17. labs (kennypaul, 09:49:41)
    1. ACTION: kennypaul to start a doodle poll to determine if the developers would like to do a face to face meeting in July (phrobb, 09:50:33)


Meeting ended at 19:55:05 UTC (full logs).

Action items

  1. doodle pole for July f2f
  2. kennypaul to start a doodle poll to determine if the developers would like to do a face to face meeting in July


Action items, by person

  1. kennypaul
    1. kennypaul to start a doodle poll to determine if the developers would like to do a face to face meeting in July


People present (lines said)

  1. kennypaul (49)
  2. CaseyODL (38)
  3. collabot (37)
  4. phrobb (23)
  5. SteveT (23)
  6. bhedstrom (6)
  7. cdonley (1)
  8. Dsauvageau (1)


Generated by MeetBot 0.1.4.