13:50:38 <kennypaul> #startmeeting Amsterdam M1 Review #2
13:50:38 <collabot`> Meeting started Fri Jul  7 13:50:38 2017 UTC.  The chair is kennypaul. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:50:38 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:50:38 <collabot`> The meeting name has been set to 'amsterdam_m1_review__2'
13:51:26 <kennypaul> #chair CaseyODL phrobb
13:51:26 <collabot`> Current chairs: CaseyODL kennypaul phrobb
13:53:47 <kennypaul> #chair gildaslanilis
13:53:47 <collabot`> Current chairs: CaseyODL gildaslanilis kennypaul phrobb
14:01:01 <RannyHaiby> #info Ranny Haiby, Nokia
14:01:17 <JasonHunt> #info Jason Hunt, IBM
14:01:31 <Sonu> #Sonu covering for Rajesh from Intel
14:01:40 <Jamil> hello Jamil from Orange
14:01:47 <Xiaojun> #info Xiaojun Xie, China Telecom
14:02:22 <Huabing_Zhao> #info Huabing Zhao on behalf of Zhaoxing Meng, ZTE
14:02:36 <SteveT> #info stephen terrill, Ericsson
14:03:57 <alla> #info Alla Goldner, Amdocs
14:04:17 <alla> can't say :my pleasure", but :-)
14:05:09 <Lingli_Deng> #info Lingli Deng, China Mobile
14:05:10 <cdonley> #info Chris Donley, Huawei
14:05:59 <xinhuili> #info Xinhui Li, VMware
14:07:44 <kennypaul> #info simple voice vote
14:08:14 <kennypaul> #info approval considered to be granted if no objections
14:08:28 <kennypaul> #topic modeling
14:09:30 <Sonu> #info Sonu covering for Rajesh from Intel
14:11:34 <kennypaul> #info concerns over the number of committers
14:13:22 <kennypaul> #info if a committer is also a code contributor that person's name should be in both locations
14:14:01 <kennypaul> #info a committer should not be committing their own code.
14:14:40 <kennypaul> #info the code for this is already very mature
14:17:33 <kennypaul> #info Deng recommends waiting until code freeze to lock down committers
14:19:48 <kennypaul> #info discussion over "parser" definition
14:21:18 <Jamil> Committer should deliver code
14:22:58 <kennypaul> #agree w/ contingency of clarification of committers and resource allocation updates
14:23:23 <kennypaul> #topic Service Orchestrator
14:23:25 <JasonHunt> The risk with committers signing up on their own is that they have the power to commit code.  Typically, you have to demonstrate your technical credentials and contributions before being named a committer.  If I were a project lead, that would concern me.
14:24:05 <kennypaul> #info (JasonHunt) "The risk with committers signing up on their own is that they have the power to commit code.  Typically, you have to demonstrate your technical credentials and contributions before being named a committer.  If I were a project lead, that would concern me."
14:24:40 <kennypaul> #info (Jamil) "Committer should deliver code"
14:28:23 <kennypaul> #info (Seshu) TBDs in the checklist are pending a meeting- not concerned with ability to complete
14:28:46 <helenychen> #info (Helen) A committer should be a contributor, plus a committer has right to review other's code.
14:30:05 <kennypaul> #info same contingency on resource allocation
14:30:48 <kennypaul> #info discussion of proposals w/ architecture committee
14:31:16 <kennypaul> #agree review approved w/ contingency
14:31:58 <kennypaul> #topic Multi VIM/Cloud
14:37:36 <kennypaul> #action in PTL meeting need to follow up on API risks
14:38:04 <kennypaul> #info team has agreement w/ APPC but not with DCAE yet
14:40:36 <kennypaul> #info potential misunderstandings can be made worse with many committers
14:42:13 <kennypaul> #action add risk section to checklist
14:44:11 <kennypaul> #info in addition to weekly PTL meeting suggest assigning roles for xfunc coordination
14:45:11 <kennypaul> #agree with contingency on resource allocation and action of risk section
14:46:01 <kennypaul> #topic CLI
14:46:22 <kennypaul> #info need updates to inbound APIs
14:51:40 <kennypaul> #action -gildas review commit/code review best practices at the PTL meeting
14:51:52 <kennypaul> #agree Review approved
14:52:25 <kennypaul> #topic Integration
14:54:04 <kennypaul> #info need to clarify what testing is specific to Amsterdam
14:54:19 <kennypaul> #undo
14:54:19 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x226d190>
14:54:42 <kennypaul> #info need to clarify what testing is covered in Amsterdam
14:56:29 <kennypaul> #info testing for vCPE and VoLTE use cases but not Demos
14:57:06 <kennypaul> #info discussion over responsibility for owning the Demos.
15:00:40 <kennypaul> #info would like updates on progress of automation
15:02:42 <kennypaul> #info Helen would like to see better defined committer crtiteria from TSM
15:03:07 <kennypaul> #undo
15:03:07 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2284910>
15:03:27 <kennypaul> #info Helen would like to see better defined committer criteria from TSC
15:03:49 <kennypaul> #action gildas take issue of Demos to TSC
15:04:08 <kennypaul> #agree Review Approved
15:04:40 <kennypaul> #topic CCSKD
15:06:16 <kennypaul> #info docker can be removed from the list of API dependenies
15:07:04 <kennypaul> #agreed Review Approved
15:08:19 <kennypaul> #topic Documentation
15:15:48 <kennypaul> #info using 3 repos versus an umbrella project approach
15:18:57 <kennypaul> #info (Lingli) need to formalize the self-committer policy
15:19:06 <kennypaul> #agreed Review approved
15:19:48 <kennypaul> #topic External API Framework
15:22:28 <kennypaul> #link https://wiki.onap.org/display/DW/Committer+Best+Practices
15:22:51 <kennypaul> #info above related to committer best practices
15:23:06 <kennypaul> #agreed Review approved
15:24:18 <kennypaul> #topic ONAP Operations Manager
15:25:42 <kennypaul> #info Release Deliverables - defined, but not linked to the page yet.
15:27:48 <kennypaul> #info need better understanding of roll back capabilities
15:29:01 <kennypaul> #action PTL fill in check list.
15:30:51 <kennypaul> #info roll back will need joint testing
15:31:12 <kennypaul> #agreed Review Approved w/ contingency on resource allocation
15:31:30 <kennypaul> #undo
15:31:30 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2673650>
15:31:58 <kennypaul> #agreed Review Approved w/ contingency on resource allocation and checklist
15:32:36 <kennypaul> #topic VNF Requirements
15:34:34 <kennypaul> #undo
15:34:34 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2673650>
15:35:27 <kennypaul> #topic follow up reviews from last review
15:37:49 <kennypaul> #info (Hui Deng) concerns over violations to charter by paring down committer list.
15:38:30 <kennypaul> #info (Chris D) PTL should ask committers to voluntarily step down
15:39:10 <kennypaul> #info (Helen C) if no one steps down, then what?
15:40:38 <kennypaul> #info (Chris D) can take a vote among  committers once there is experience w/ the team
15:43:53 <kennypaul> #topic Project Review of Network Function Change Management proposal
15:44:40 <kennypaul> #info this would be an end-to-end across all projects-  more logical as a Subcommittee
15:45:33 <kennypaul> #info OR as a usecase for Beijing release
15:48:13 <kennypaul> #info project proposal will be withdrawn
15:48:44 <kennypaul> #endmeeting