#onap-meeting: TSC-July-13-2017

Meeting started by kennypaul at 13:44:50 UTC (full logs).

Meeting summary

    1. Chris Donley, Huawei (cdonley, 14:01:27)
    2. Ranny Haiby, Nokia (RannyHaiby, 14:01:37)
    3. mazin gilbert, AT&T (gilbert, 14:01:39)
    4. Rajesh Gadiyar Intel (Rajesh-Intel, 14:01:57)
    5. edwarnicke (edwarnicke, 14:02:05)
    6. Lingli Deng, China Mobile (Lingli_, 14:02:23)
    7. Xinhui Li, VMware (xinhuili, 14:02:29)
    8. Huabing Zhao, on behalf of Zhaoxing Meng, ZTE (Zhaoxing, 14:02:43)
    9. munish, Ericsson,proxy for Stephen (munish, 14:03:01)
    10. Jason Hunt, IBM (JasonHunt, 14:03:10)
    11. Xiaojun Xie, China Telecom (Xiaojun, 14:03:26)

  1. subcommittee election status (kennypaul, 14:04:59)
    1. small subcommittee that will be providing recommended charter changes next week (kennypaul, 14:05:37)
    2. one week for comment, and 2 days for TSC decision (kennypaul, 14:06:27)

  2. Amsterdam M1 Reviews (kennypaul, 14:08:01)
  3. VID review (kennypaul, 14:08:21)
    1. form imcomplete (kennypaul, 14:09:55)

  4. Logging Enhancements (kennypaul, 14:10:34)
    1. Amir Levy, GigaSpaces (amir_levy, 14:12:31)
    2. AGREED: review for logging approved (kennypaul, 14:17:36)

  5. Application Authorization Framework (kennypaul, 14:18:46)
    1. ACTION: -Varun update API section of document (kennypaul, 14:21:27)
    2. checklist complete (kennypaul, 14:21:39)
    3. PTL needs to take an active roll in socializing AAF across the projects (kennypaul, 14:23:42)
    4. AGREED: AAF review approved (kennypaul, 14:23:59)

  6. DMaap (kennypaul, 14:24:11)
    1. ACTION: Varun- update the API section (kennypaul, 14:26:42)
    2. checklist complete (kennypaul, 14:27:03)
    3. ACTION: varun- clean up contributor list (kennypaul, 14:27:57)
    4. AGREED: DMaaP review approved (kennypaul, 14:28:19)

  7. VNF Requirements (kennypaul, 14:28:43)
    1. Helen- unlikely for all VNF to be tested on this release (kennypaul, 14:32:52)
    2. ACTION: -Steve Wright- meeting with other PTLs to understand deliverables. (kennypaul, 14:33:47)
    3. documentation created would be text files treated as code. (kennypaul, 14:36:40)
    4. AGREED: VNF Requirements review approved (kennypaul, 14:37:30)

  8. SDC (kennypaul, 14:38:01)
    1. ACTION: - Eden fill in arch and API sections (kennypaul, 14:39:28)
    2. info exists, but be linked in (kennypaul, 14:39:56)
    3. checklist complete within the next week. (kennypaul, 14:40:13)
    4. AGREED: SDC review approved w/ AI contingencies and an update on checklist in a week. (kennypaul, 14:42:00)

  9. Developer Best Practices adoption\ (kennypaul, 14:43:04)
    1. lironsh- question about the size of commits (kennypaul, 14:47:36)
    2. ed- recommend breaking up into themes (kennypaul, 14:48:47)
    3. andy- there is a draft feature which is not a commit. Drafts are private by default. (kennypaul, 14:49:28)
    4. -andy making drafts public needs to be approved by the TSC (kennypaul, 14:50:02)
    5. ed- recommends not enforcing % of code coverage (kennypaul, 14:51:48)
    6. helen- focus would be on new code (kennypaul, 14:52:52)
    7. edwarnicke actually points out the dangers and tradeoffs of enforcing high code coverage bars to early, as it can lead to tests that mistakenly bake *bugs* into code, making it much harder to fix those bugs (edwarnicke, 14:53:41)
    8. some of these best practices cover a subset of CII requirements (kennypaul, 14:57:42)
    9. VOTE: Voted on "Shall the TSC approve the ONAP Development Best Practices as documented in the slide deck presented by Gildas?" Results are, +1: 10 (phrobb, 14:59:57)
    10. I have to drop now (Rajesh-intel, 15:00:19)
    11. AGREED: the Best Practices as presented by Gildas is approved by the TSC (phrobb, 15:00:32)

  10. July Virtual meeting (kennypaul, 15:01:56)
    1. AGREED: DAYS: July 24, 25, 26 (Mon, Tue, Wed), TIMES: UTC noon-4PM / China 8PM-midnight / Eastern 8AM-noon / Pacific 5AM-9AM (kennypaul, 15:09:45)


Meeting ended at 15:09:59 UTC (full logs).

Action items

  1. -Varun update API section of document
  2. Varun- update the API section
  3. varun- clean up contributor list
  4. -Steve Wright- meeting with other PTLs to understand deliverables.
  5. - Eden fill in arch and API sections


People present (lines said)

  1. kennypaul (47)
  2. collabot` (11)
  3. phrobb (4)
  4. gilbert (3)
  5. Lingli_ (3)
  6. edwarnicke (3)
  7. bhedstrom (2)
  8. Jamil (2)
  9. JasonHunt (2)
  10. munish (2)
  11. Guest73002 (2)
  12. cdonley (2)
  13. tykeal (2)
  14. amir_levy (2)
  15. Rajesh-intel (2)
  16. Xiaojun (2)
  17. Rajesh-Intel (1)
  18. Zhaoxing (1)
  19. Liron (1)
  20. RannyHaiby (1)
  21. xinhuili (1)
  22. CaseyODL (0)


Generated by MeetBot 0.1.4.