12:05:08 <phrobb> #startmeeting July2017Face2Face
12:05:08 <collabot> Meeting started Mon Jul 24 12:05:08 2017 UTC.  The chair is phrobb. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:05:08 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:05:08 <collabot> The meeting name has been set to 'july2017face2face'
12:05:43 <phrobb> #topic Dependency Validation
12:05:47 <alla> #info Alla Goldner, Amdocs
12:06:09 <SteveT> #info Stephen Terrill, Ericsson
12:09:03 <SteveT> #info Gildas shared the dependancies between the projects based on the project release reviews
12:11:21 <SteveT> #info it was commented that there is no holmes to clam direct link
12:11:51 <SteveT> #info that was no holmes to clamp direct link (not clam)
12:12:10 <phrobb> #action gildaslanilis to update the graph to reflect that Holmes and CLAMP do not have a direct link
12:13:22 <SteveT> #action gildaslanilis to also check the source (project release)
12:17:15 <SteveT> #info Question was rasied whether the dependancies are in the form of an API.  This was confirmed and that the API should be documented in the M2 milestone
12:19:01 <SteveT> #info SDNC should have a dependency on multi-vim
12:21:31 <SteveT> #info There was a question regarding the double dependancies and whether that is an issue.  It was recomended that the teams with double depencies communite to understand whether there are issues
12:22:11 <Lusheng> under integrated ONAP design for VoLTE, DCAE has a dependency on Holmes because Holmes is used as DCAE analytics.
12:22:30 <SteveT> #info There was a question about should we have a dependancy id to be used later in the release planning activities
12:23:51 <SteveT> #info Looking at the interface is also part of the architecture sub-committee charter
12:26:47 <SteveT> #info there was a question about whether its possible to add a link to each API description in the graph.  The answer from Gildas was that he recognized the value, but wasn't sure how it could be done and is open to suggestions on how
12:28:20 <SteveT> #info Question.  Is the external API only dependant on SO?  PLease check
12:28:41 <SteveT> #info Add dependancy on holmes and DCAE
12:29:25 <SteveT> #action #gildaslinus to add holmes and DCAE dependancy
12:31:43 <amir_levy> #Info Amir Levy Gigaspaces/Cloudify
12:33:06 <phrobb> #action gildaslanilis to research if SDC has a dependency on Portal FW
12:33:45 <SteveT> #Gildas will add the dependancy capture will be part of the M2 checklist
12:35:34 <SteveT> #topic Release Status, Release Process and Scrum Board Usage
12:35:41 <phrobb> #action gildaslanilis  to capture dependencies as part of the M2 checklist
12:36:23 <phrobb> #topic Release Status, Release Process and Scrum Board Usage
12:36:39 <phrobb> #chair SteveT gildaslanilis kennypaul
12:36:39 <collabot> Current chairs: SteveT gildaslanilis kennypaul phrobb
12:39:59 <SteveT> #info gildaslanilis described the overall status of the planned epics from information obtained from jira, as well the tasks and subtasks
12:46:18 <JasonHunt> I'd like to hear more discussion on this topic.  My impression, based on meeting schedules, is that there was a lot of activity happening, but the graphs seem to indicate otherwise?
12:46:44 <SteveT> #info Gildas asked whether there were any questions or concenrs on the graphs.
12:47:02 <SteveT> #info I'd like to hear more discussion on this topic.  My impression, based on meeting schedules, is that there was a lot of activity happening, but the graphs seem to indicate otherwise?
12:48:28 <alla> #info my impression from some of the meetings I've participated in is that there are activities around planning, aligning with architecture, use cases etc. and less the actual development at this point, this probably explains
12:49:26 <alla> #info most of the use cases related discusions has already completed
12:49:42 <alla> there are still some remaining issues though
12:50:01 <alla> #there are still some remaining issues though
12:50:11 <alla> #info there are still some remaining issues though
12:50:41 <Catherine_> Remaining bugs: 54 -
12:52:32 <alla> #info we have R1 architecture since last week only
12:52:34 <Catherine_> 38 open; 6 in progress; 6 submitted; 4 to do
12:52:53 <alla> #info we need to make sure that all involved projects are aligned on this architecture view
12:53:05 <SteveT> #info Gildas requested whether there was belief that we can make it.  It was pointed out that the next milestone was 3rd August, which is functionality freeze.   It felt it was reasonabil.e
12:53:32 <alla> #info as, when we approved projects, some of them were approved conditionally depending on the architecture, once agreed
12:54:01 <alla> can you unmute me?
12:54:03 <Catherine_> It is only about bugs; we have also 592 stories; 224 epics; 72 tasks ans 52 sub-tasks but it does not mean all are for R1
12:57:06 <SteveT> #info   There is architecture meeting tomorrow and the project scope discussion can handle there
12:58:02 <SteveT> #info Gildas described "what is M2"
13:00:41 <SteveT> #info Gildas requested PTLs to fill in checklist for the next milestone
13:02:56 <SteveT> #info It was suggested that we should finalize the components that are used by many others first.
13:16:10 <SteveT> #info question about the dependencies on the open-o nexus repo.   Info that was to be closed, but the code will remain accessible.  Relivant code should be moved into ONAP repositories.
13:17:55 <SteveT> #info  Question about when is FOSSology available on LF infra.  The answer is that FOSSology has already be run on the current code base, and feedback is expected in the next 1-2 weeks.  It was clarified that the FOSSology scan is done monthly .
13:20:07 <SteveT> #info  There was a question about the software packing of our deliverables, docker images, deb, rpm etc.  The answer was that the expectation was docker images
13:24:48 <SteveT> #info  If there are changes in the API after api freeze, this may have to be done, but it is important to communicate this.  It was suggested that API changes after M3 are lifted to the TSC for communication purposes at least
13:26:41 <SteveT> #info  TSC would be grateful for information regarding implications of the API change when this is requested
13:32:34 <SteveT> #info when disucssing the APIs, it was questioned whether it also goes to YANG models as well.  the answer was yes.
13:32:48 <SteveT> #info gildas introduced the scrumboard.
14:04:09 <SteveT> #topic Release Versioning
14:05:21 <SteveT> Oliver started presenting the release versioning
14:05:37 <SteveT> #info oliver lead a discusson in release versioning
14:05:59 <SteveT> #info Symentic version is assumed as a way to express the versions
14:08:29 <SteveT> #info Helen version can be defined in o-parent project
14:18:52 <SteveT> #info proposal to have an overall release, and that each project/repo can have independant values that are tied to the main release (and can be independantly released)
14:19:08 <SteveT> #info correction:  independantly stepped
14:24:50 <SteveT> #info Gildas asked about a manifest file
14:29:00 <sakth> gildaslanilis: Hi, how did you contribution stats from gerrit?
14:30:23 <sakth> *how did you get
14:33:24 <SteveT> #info The conclusion for the versioning is :  Each project decides its own versioning per project and/or repo.  Then an overall version is captured in o-parent.    This was with inline with the proposal on the additional page, and was considered to be a baseline.  Oliver will further describe this properly and bring it to the TSC.
14:36:18 <SteveT> #action Oliver to expand on the description of the release versioning and bring it to the TSC
14:38:41 <SteveT> #info While this enables a independant releases schedules per project/repo, that is not the intention at this time
14:41:49 <kennypaul> #topic . Security Review
14:48:24 <kennypaul> #info looking for a volunteer project for CII badging
14:49:15 <kennypaul> #info (Roberto KUNG) "Comment on vulnerability team: Ruan He from Orange has also volunteered"
14:50:43 <kennypaul> #info CLAP volunteered as a pilot
14:52:27 <kennypaul> #UNDO
14:52:27 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x34b9710>
14:52:42 <kennypaul> #info CLAMP volunteered as a pilot
14:55:00 <kennypaul> #info show of hands 12 people prefer maturity model
15:00:34 <kennypaul> #info FLOSS vs. FOSS  the same in the eyes of this project
15:01:05 <SteveT> Roberto, you are correct I don't know why I missed that.
15:05:05 <kennypaul> #info (Helen) what level of code coverage are we comfortable with for each project?
15:06:05 <kennypaul> #info need to have common sense procedures
15:07:09 <kennypaul> #info introduced static code scanning concepts
15:08:27 <kennypaul> #info (Catherine LeFfevre) I have put some suggested tools on the wiki page
15:08:27 <kennypaul> https://wiki.onap.org/display/DW/ONAP+Vulnerability+Management
15:11:46 <kennypaul> #info PKI needs to be discussed further by team
15:13:08 <kennypaul> #info (Catherine LeFfevre)  it would be great to integrate with Jenkins so it part of our CI/CD suite
15:14:32 <kennypaul> #topic E2E Test Cases
15:16:53 <kennypaul> #info need more specific definition of "similar labs" on slide 2
15:21:20 <kennypaul> #info delivery of vendor HW is at risk.
16:03:50 <kennypaul> #endmeeting