08:18:48 <phrobb> #startmeeting Amsterdam M4 Review
08:18:48 <collabot`> Meeting started Thu Sep 28 08:18:48 2017 UTC.  The chair is phrobb. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:18:48 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:18:48 <collabot`> The meeting name has been set to 'amsterdam_m4_review'
08:19:06 <phrobb> #topic Roll Call
08:19:35 <phrobb> #info TSC Members Please #info In
08:20:25 <phrobb> #chair kennypaul SteveT
08:20:25 <collabot`> Current chairs: SteveT kennypaul phrobb
08:22:41 <phrobb> #info VFC passes the M4 review
08:23:06 <phrobb> #agreed the VFC project has passed the M4 Milestone
08:25:42 <phrobb> #topic UI
08:28:01 <phrobb> #topic Use Case UI
08:41:57 <kennypaul> #info from zoom chat: From shentao to All panelists: (10:36 AM)
08:41:57 <kennypaul> sonar has been well finished, but percentage doesn't show
08:41:57 <kennypaul> I will seek help from integration team and fix it.
08:41:57 <kennypaul> maybe it is uui configuration problem. we have done uui test
08:46:44 <rajeshgadiyar> +1
08:46:54 <rajeshgadiyar> #vote +1
08:50:25 <phrobb> #info A vote was held asking  Shall the TSC approve to remove any non-gating Project contingent on the Release Manager not being able to validate that all M4 requirements have been met by Monday 5:00pm PDT Oct. 2nd
08:50:41 <phrobb> #info the vote passed with 11 votes
08:51:14 <phrobb> #agreed by consensus that Use Case UI has not passed M4
08:52:24 <phrobb> #agreed  the CLI project has passed M4
08:52:52 <phrobb> #agreed the CLAMP project has passed M4
08:53:19 <phrobb> #info A&AI - A gating project
08:54:20 <phrobb> #agreed A&AI passes M4 under the condition that the outstanding CSIT tests are fixed by RC0
08:54:59 <phrobb> #info CCSDK
08:58:42 <phrobb> #info CCSDK passes M4
09:02:58 <phrobb> #agreed CCSDK passes M4 under the condition that the project has ReadTheDoc structure by Monday and 30% code coverage by 5pm PDT Monday Oct. 2
09:05:17 <phrobb> #info to reiterate, non gating projects that don't pass M4 by 5pm Monday PDT will be dropped.  Gating project that don't pass by then will be closely evaluated to determine the best course for the Amsterdam project
09:07:00 <phrobb> #info SDNC
09:09:12 <phrobb> #agreed SDNC passes M4 under condition that all their M4 deliverables are met by Monday 5pm PDT
09:11:22 <phrobb> #agreed DCAE passes M4
09:11:43 <phrobb> #info Logging Enhancements
09:15:35 <phrobb> #agreed Logging Enhancement passes M4 under the condition that they meet all M4 requirements by Monday at 5pm PDT
09:15:42 <phrobb> #info SO
09:21:20 <phrobb> #info SO had a large code drop from MSO 2 week ago with reduced their sonar code coverage from 25% to 12%.  The code coverage needs to be 30% as per M4 requirements
09:27:00 <phrobb> #agreed SO does not pass M4
09:27:34 <phrobb> #info Policy
09:30:02 <phrobb> #agreed SO passes conditional on having all M4 deliverables completed by Monday 5pm PDT
09:30:58 <phrobb> #info Integration
09:31:42 <phrobb> #agreed the Integration project passes M4
10:36:28 <phrobb> #info MultiVIMCloud
10:37:53 <phrobb> #agreed MultiVIM Cloud passes M4
10:41:15 <phrobb> #info SDC
10:42:02 <phrobb> #agreed SDC passes M4 conditional on their ReadTheDocs being in place by Monday 5pm PDT
10:43:33 <phrobb> #info MSB
10:47:03 <phrobb> #info MSB passes M4 conditional on sufficient code coverage verified by 5pm Monday PDT
10:47:11 <phrobb> #info WP
10:47:40 <phrobb> #undo
10:47:40 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x356aa90>
10:47:46 <phrobb> #info VVP
10:56:31 <phrobb> #info The project has been behind.  It recently brought seed code forward and is awaiting inbound activities from the Linux Foundation.
10:56:55 <phrobb> #info VVP is independent from the rest of the ONAP release
10:57:41 <phrobb> #agreed that VVP is dropped from the Amsterdam release but the TSC will continue to monitor progress to understand when they will be distributing
10:58:00 <phrobb> #info APPC
10:58:34 <phrobb> #agreed APPC passes M4
10:59:30 <phrobb> #info VNF Requirements
11:06:45 <phrobb> #agreed VNF Requirements passes M4 - It also is not directly tied to the rest of the ONAP Amsterdam release
11:06:56 <phrobb> #info Portal
11:11:15 <phrobb> #info Portal passes M4 conditional on ReadTheDocs being in place and Sonar updated by 5pm PDT Monday
11:11:23 <phrobb> #info OOM
11:33:59 <phrobb> #info The OOM Project passes M4
11:35:31 <phrobb> #info much discussion on releasing OOM based on the limited testing the project will recieve in integration.  We may need to mark OOM as "experimental" or "developer only" type of release so it can be accessible but clearly indicated as not fully tested
11:35:41 <phrobb> #info DMAAP
11:37:27 <phrobb> #info project is short on code coverage and estimates they will be at 30% on Oct. 5th.
11:41:34 <phrobb> #info DMAPP passes M4 conditional on having code coverage to 30% by Monday 5pm PDT - if not met, status to be provided
11:41:39 <phrobb> #info AAF
11:42:32 <phrobb> #info AAF does not pass M4 and needs to provide code coverage by Monday at 5pm PDT or the project will be dropped from the release
11:42:40 <phrobb> #info Modelling
11:49:32 <phrobb> #info Modelling project is depended upon by VFC
11:50:31 <phrobb> #info hence the Modelling project is proposed as an MVP project
11:52:57 <phrobb> #info we also learned there are 4 tosca parsers being used in Amsterdam.
11:53:30 <phrobb> #action Chris Donley volunteered to facilitate a discussion across the projects to consolidate their tosca parser usage
11:53:50 <phrobb> #info Modelling is now identified as an MVP project
11:54:03 <phrobb> #info VID
11:54:47 <phrobb> #info Modelling passes M4 conditional on their satisfying the M4 criteria by Monday 5PM
11:54:55 <phrobb> #info VID
11:56:15 <phrobb> #info VID does not yet pass M4.,  They need to satisfy test code coverage and docs requirements by Monday 5pm or they will need to be monitored closely until M4 complete'
11:56:27 <phrobb> #info Doc Project
11:56:54 <phrobb> #info Doc project passes M4
11:57:09 <phrobb> #info Homes
11:57:44 <phrobb> #agreed Holmes passes M4
11:57:56 <phrobb> #info API
12:00:42 <phrobb> #info External API project will only deliver documentation for Amsterdam
12:01:10 <phrobb> #agreed External API project  passes M4 with a doc only deliverab le
12:01:18 <phrobb> #info VNF SDK
12:01:53 <phrobb> #agreed VNF SDK passes M4
14:43:46 <phrobb> #endmeeting