13:47:04 <kennypaul> #startmeeting tsc 2018-01-04
13:47:04 <collabot> Meeting started Thu Jan 4 13:47:04 2018 UTC. The chair is kennypaul. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:47:04 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:47:04 <collabot> The meeting name has been set to 'tsc_2018_01_04'
13:47:20 <kennypaul> #chair phrobb
13:47:20 <collabot> Current chairs: kennypaul phrobb
13:48:30 <kennypaul> #topic rollcall
14:00:33 <frankbrockners> #info Frank Brockners, Cisco (will be on IRC only for the first 30min)
14:01:26 <JasonHunt> #info Jason Hunt, IBM
14:01:27 <kennypaul> #info Alla Goldner, AMDOCS
14:01:41 <DhananjayPavgi> #info Dhananjay Pavgi, Tech Mahindra
14:01:52 <RannyHaiby> #info Ranny Haiby, Nokia
14:02:26 <cdonley> #info Chris Donley Huawei
14:02:54 <Filipe_> #info Filipe_
14:03:18 <Filipe_> #info Filipe Caetano (Coriant)
14:03:33 <Zhaoxing> #info Zhaoxing Meng, ZTE
14:03:46 <RajeshGadiyar> #info Rajesh Gadiyar Intel
14:05:04 <munish> #info Munish, Proxy for Stefen Terrill, Ericsson
14:09:19 <kennypaul> #info Xinhui Li, VMWare
14:09:46 <kennypaul> #info Lingli Deng, CMCC
14:09:53 <jamil> #info jamil for Orange
14:11:10 <kennypaul> #topic housekeeping
14:11:33 <kennypaul> #info collaboration dates.
14:12:03 <kennypaul> #info virtual meeting week of Feb 12.
14:12:29 <kennypaul> #undo
14:12:29 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2fc7a90>
14:12:42 <kennypaul> #info virtual meeting week of Feb 5th.
14:13:06 <kennypaul> #action kenny coordinate VF2F
14:13:58 <kennypaul> #info more days rather than longer hours.
14:16:05 <kennypaul> #startvote Does the TSC confirm the election of Pam Dragosh as the Chair of the Control-Loop Subcommittee? +1, 0, -1
14:16:05 <collabot> Begin voting on: Does the TSC confirm the election of Pam Dragosh as the Chair of the Control-Loop Subcommittee? Valid vote options are +1, 0, -1.
14:16:05 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:16:16 <cdonley> #vote +1
14:16:18 <munish> #vote +1
14:16:20 <RannyHaiby> #vote +1
14:16:20 <gilbert> #vote +1
14:16:23 <JasonHunt> #vote +1
14:16:31 <jamil> #vote +1
14:16:33 <RajeshGadiyar> #vote +1
14:16:41 <Ning> #vote +1
14:16:53 <kennypaul> #vote +1
14:17:01 <DhananjayPavgi> #vote +1
14:17:14 <kennypaul> #info my vote representing Alla Goldner
14:17:23 <Zhaoxing> #vote +1
14:18:01 <phrobb> #vote +1
14:18:23 <phrobb> #info my vote is on behalf of Xinhui
14:18:51 <kennypaul> #endvote
14:18:51 <collabot> Voted on "Does the TSC confirm the election of Pam Dragosh as the Chair of the Control-Loop Subcommittee?" Results are
14:18:51 <collabot> +1 (12): jamil, phrobb, RajeshGadiyar, DhananjayPavgi, JasonHunt, kennypaul, cdonley, Zhaoxing, Ning, gilbert, RannyHaiby, munish
14:19:57 <kennypaul> #topic multi-cloud confirmation vote.
14:20:31 <kennypaul> #startvote Does the TSC confirm the promotion of Liang Ke
14:20:31 <collabot> Unable to parse vote topic and options.
14:20:31 <kennypaul> as a committer on the Multi-Cloud project? +1, 0, -1
14:20:58 <kennypaul> #startvote Does the TSC confirm the promotion of Liang Ke as a committer on the Multi-Cloud project? +1, 0, -1
14:20:58 <collabot> Begin voting on: Does the TSC confirm the promotion of Liang Ke as a committer on the Multi-Cloud project? Valid vote options are +1, 0, -1.
14:20:58 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:21:21 <gilbert> #vote +1
14:21:23 <munish> #vote +1
14:21:25 <RannyHaiby> #vote +1
14:21:26 <DhananjayPavgi> #vote +1
14:21:26 <phrobb> #vote +1
14:21:30 <cdonley> #vote +1
14:21:32 <Zhaoxing> #vote +1
14:21:36 <JasonHunt> #vote +1
14:21:38 <Ning> #vote +1
14:21:48 <kennypaul> #vote +1
14:21:48 <phrobb> #info phrobb vote is on behalf of Xinhui
14:21:56 <jamil> #vote +1
14:22:19 <kennypaul> #info my vore representing Alla Goldner
14:22:45 <gildaslanilis> #vote +1
14:23:10 <gildaslanilis> #info gildas lanilis voted on behalf of Lingli
14:23:26 <kennypaul> #endvote
14:23:26 <collabot> Voted on "Does the TSC confirm the promotion of Liang Ke as a committer on the Multi-Cloud project?" Results are
14:23:26 <collabot> +1 (12): jamil, phrobb, JasonHunt, cdonley, kennypaul, DhananjayPavgi, Zhaoxing, Ning, gildaslanilis, gilbert, RannyHaiby, munish
14:24:59 <phrobb> #topic TSC Election Process
14:30:02 <phrobb> #topic Release Status (Beijing)
14:31:06 <phrobb> #info gildaslanilis reviewed the Project Proposal status for new projects wanting to join the ONAP project
14:31:51 <phrobb> #info Container Based Network Service/Function Deployment is going back to Arch committee next week
14:33:06 <phrobb> #info "Image Manager" project is recommended to put under the A&AI project
14:34:08 <phrobb> #info gilbert Notes that we need to ensure that the A&AI project scope is not enlarged by inclusion of this new project
14:40:17 <phrobb> #info Run-Time Catalog project Has had advice to talk to SDC project for possible inclusion. They will talk next week
14:41:04 <phrobb> #info Certificate and Secret Mgmt Service - This project has outstanding questions still
14:42:13 <phrobb> #info ONAP Benchmark project has been approved to be a subproject of 'Integration"
14:43:55 <phrobb> #info Open Source Access Mgmt - still need to go back to Arch. committee.
14:44:33 <phrobb> #info Distributed KV Store - The recommendation was to join another project. No further info known at this time
14:45:47 <phrobb> #info CHAP (Now known as MUSIC) Presented to Arch this week.
14:47:51 <phrobb> #info Centralization & Externalization of Parser Distribution - Is being discussed as part of Functional Requirement for Beijing in Use Case subcommittee. This is likely not going to be a separate project request
14:48:10 <amir_levy> #info Amir Levy Cloudify
14:48:22 <phrobb> #info gildaslanilis reviews the upcoming Beijing milestones.
14:50:55 <phrobb> #info Gildas notes that the TSC approved OOM as the main method for ONAP deployment. The question of support, or level of support for Heat Templates is still open.
14:52:32 <phrobb> #info gilbert notes that we may be supporting OOM as primary with Heat as a secondary (deprecated) deployment method for Beijing, and have it removed from support in Cassablanca and beyond
14:52:53 <phrobb> #info The question is really to the Integration team on what they can support for Beijing testing of deployment methods
14:54:27 <phrobb> #info Gildas asks on the regard of upgrading from Amsterdam to Beijing. What is the TSC stance on any support from Amsterdam to Beijing.
14:59:28 <kennypaul> #info discussion of approach to driving upgrade approach.
14:59:36 <kennypaul> #undo
14:59:36 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2faed10>
14:59:43 <phrobb> #info TSC consensus is that no upgrade path will be required from Amsterdam to Beijing. For Beijing and beyond, upgrade mechanisms need to be in place
15:00:34 <phrobb> #info the Arch committee is requested to start a sub-team now to create a recommendation on upgrades for Beijing and beyond
15:01:39 <phrobb> #info It is noted that OOM has migration capabilities. Hence work on migration needs to include OOM has part of the plans/discussions
15:02:38 <phrobb> #info Gildas asks TSC to vote on the request to make the Fix and Affect version fields in Jira mandatory.
15:04:53 <phrobb> #info Some questions on the impact to PTLs with this change
15:06:11 <phrobb> #info Key point is that at defect creation we don't know if the bug was found in Amsterdam or Beijing and what the request is. Having that info is very helpful, hence the request
15:06:56 <phrobb> #info Noted that more should be heard from the PTLs because this impacts them with a level of effort.
15:08:31 <phrobb> #info Noted that the Affect field should be mandatory on creation so that the project/PTL knows what is affected.
15:11:19 <phrobb> #agree the TSC notes that the Affect field is mandatory for bugs submitted at creation and the Fix field is mandatory at progress/transition
15:12:50 <phrobb> #info API Stability - Noted in discussion that the Docs project can oversee a more defined set of guidelines for use/delivery of Swagger in Beijing
15:13:56 <phrobb> #info Gildas walks through the Amsterdam bugs fixed that are targeted for SR1
15:16:31 <kennypaul> #topic Platform Maturity (S3P) Requirements Update
15:17:04 <kennypaul> #info JasonHunt reviewed his slides
15:18:25 <kennypaul> #info some additional input is required for resiliency & scalability
15:20:53 <kennypaul> #info requesting guidance from the Benchmark team on areas such as tooling that can be leveraged by others
15:22:53 <kennypaul> #info Manageability is more focused on consolidated logging rather than user experience at this time.
15:25:18 <kennypaul> #topic MUSIC (formerly named CHAP) Project Proposal
15:25:50 <kennypaul> #info Bharath reviewed the proposal
15:26:11 <kennypaul> #link https://wiki.onap.org/display/DW/MUSIC-Multi-site+State+Coordination+Service
15:31:47 <kennypaul> #info primary role is to coordinate states across sites.
15:32:35 <kennypaul> #info review has been approved by the Arc-Subcommittee.
15:33:49 <kennypaul> #info would like to understand what the specific S3P deliverable would be.
15:35:38 <kennypaul> #info need to classify as MVP or not
15:37:30 <kennypaul> #topic OOM and AAI committer promotions
15:38:12 <kennypaul> #info email vote for both Boris [oom] and Venkata [aai] were approved.
15:38:24 <kennypaul> #endmeeting