13:09:32 <mgkwill> #startmeeting SDNC 9/13/2017
13:09:32 <collabot> Meeting started Wed Sep 13 13:09:32 2017 UTC.  The chair is mgkwill. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:09:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:09:32 <collabot> The meeting name has been set to 'sdnc_9_13_2017'
13:09:55 <mgkwill> #topic Generic Resource API - Overview
13:15:14 <mgkwill> #info Generic Resource API works on - vnfs, vfs, networks, alloted resources
13:15:55 <mgkwill> #info GR-API is based on service model
13:18:56 <mgkwill> #link https://wiki.onap.org/display/DW/SDNC+APIs
13:19:40 <mgkwill> #link https://wiki.onap.org/download/attachments/13599902/Generic_Resource_ONAP_AID.docx?version=1&modificationDate=1505308737223&api=v2
13:24:55 <mgkwill> #info top level is service and then we have config under it
13:28:40 <mgkwill> #info under service is service data and service status
13:43:26 <mgkwill> #info Possible VoLTE use case could use network create, vCPE would use TunnelXConn
13:44:15 <mgkwill> #info Generic Resource API will be used for underlay creation in VoLTE use case as well as overlay for vCPE use case
13:46:24 <mgkwill> #info Q: would tunnelXConn be used for VoLTE A: Network Topology Create would be used.
13:53:22 <mgkwill> #topic Directed Graphs + Builder
13:53:58 <mgkwill> #info use directed graphs as tool in developing
13:54:35 <mgkwill> #info use docker container from ccsdk_dgbuilder as tool
13:55:15 <mgkwill> #action Dan to put instruction for use of ccsdk_dgbuilder on wiki
13:57:58 <mgkwill> #info loading directed graph from import in dgbuilder will show you what that API action does visually
14:07:29 <mgkwill> #topic VoLTE use case in SDNC
14:07:52 <mgkwill> #info Routing table info needs to be propagated through SDNC when overlay is created
14:09:42 <mgkwill> #info Q: What is API of third party controller A: Dan: There is email chain with Brian Freeman that discusses that
14:11:18 <mgkwill> #info Q: What is wan descriptor in Vo
14:11:27 <mgkwill> #undo
14:11:27 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x312cb90>
14:11:51 <mgkwill> #info Q: What is wan descriptor in VoLTE use case?
14:13:24 <mgkwill> #info Zhuoyao Huang working on TOSCA overlay model now
14:16:43 <mgkwill> #topic M2/M3 Status for SDNC
14:17:06 <mgkwill> #info Currently being tracked as Red, but a lot is paper work and Dan said he would work on it.
14:18:46 <mgkwill> #info Discussion about CSIT Functional Robot Test Cases
14:19:31 <mgkwill> #info Dan mentions that we need robot test cases in integration repo to run on CI/CD interval
14:21:18 <mgkwill> #info need unit tests for northbound to close 30% requirement for M3 in sonar
14:24:00 <mgkwill> #action Dan add jira tasks for unit tests for sdnc-northbound
14:24:06 <mgkwill> #endmeeting