#opencontainers: 2016-01-06 discussion

Meeting started by wking at 18:03:52 UTC (full logs).

Meeting summary

    1. http://wking.github.io/nmbug-oci/ (mrunalp, 18:04:23)
    2. We'll start with existing issues and then discuss planning (RobDolinMS, 18:04:46)

  1. Feedback on --state (wking, 18:04:50)
    1. https://groups.google.com/a/opencontainers.org/forum/#!searchin/dev/state/dev/q6TYqVZOcX8/W1RVyCXCCQAJ (wking, 18:06:00)
    2. https://github.com/wking/oci-command-line-api/pull/14 (wking, 18:06:18)
    3. https://github.com/opencontainers/runc/blob/master/main.go#L60 (crosbymichael, 18:11:23)
    4. ACTION: wking to check for a concrete example of an unprivileged user and add one if missing (wking, 18:11:31)

  2. separating device cgroups and mknod (wking, 18:13:43)
    1. https://groups.google.com/a/opencontainers.org/forum/#!searchin/dev/mknod/dev/y_Fsa2_jJaM/SydzptqPBQAJ (wking, 18:14:19)
    2. http://github.com/opencontainers/specs/pull/99 (wking, 18:17:47)
    3. ACTION: rebase #99 and re-submit (wking, 18:19:21)
    4. ACTION: wking rebase #99 and re-submit (wking, 18:19:28)
    5. ACTION: mrunalp will post with an example of why this is useful (wking, 18:19:37)
    6. ACTION: single, unified config file (wking, 18:19:46)

  3. single, unified config file (wking, 18:19:51)
    1. https://groups.google.com/a/opencontainers.org/forum/#!searchin/dev/unified$20config$20file/dev/0QbyJDM9fWY/VP-tGxG_DgAJ (wking, 18:20:13)
    2. https://github.com/opencontainers/specs/pull/88#issuecomment-126516625 (wking, 18:21:55)
    3. https://github.com/opencontainers/specs/pull/284 (wking, 18:36:54)
    4. ACTION: vbatts|work to write-up perspective on why two files (RobDolinMS, 18:36:59)

  4. Disable new privileges (wking, 18:37:27)
    1. https://github.com/opencontainers/specs/pull/290 (mrunalp, 18:37:33)
    2. https://github.com/opencontainers/specs/pull/290 (wking, 18:37:34)
    3. Mrunal: we'll just record this in the PR and take it forward next week (RobDolinMS, 18:41:07)
    4. ACTION: mrunalp to investigate a split-out security section and post notes (wking, 18:42:01)

  5. splitting the rootfs into a content-addressable entity, not embedded in the bundle (wking, 18:43:38)
    1. https://github.com/opencontainers/specs/pull/293 (wking, 18:44:58)
    2. https://groups.google.com/a/opencontainers.org/forum/#!topic/dev/6ZKMNWujDhU (wking, 18:45:31)
    3. https://groups.google.com/a/opencontainers.org/forum/#!search/messageid$3A%22CAD2oYtN-9yLLhG_STO3F1h58Bn5QovK$2Bu3wOBa$3Dt$2B7TQi-hP1Q@mail.gmail.com%22/dev/xo4SQ92aWJ8/NHpSQ19KCAAJ (wking, 18:46:19)
    4. ACTION: will post a new thread to the list explaining this approach (wking, 18:46:56)
    5. ACTION: vbatts|work will post a new thread to the list explaining this approach (wking, 18:47:02)

  6. milestones (wking, 18:48:30)
    1. It makes sense to discuss next week (RobDolinMS, 18:48:40)

  7. discussing the face-to-face meeting (wking, 18:50:16)
    1. Day 1: 10am - 6pm (Pacific) (RobDolinMS, 18:52:45)
    2. Day 2: 8:30am - 4pm (Pacific) (RobDolinMS, 18:53:14)
    3. Thumbs-up to dinner on day 2 (RobDolinMS, 18:53:35)
    4. https://docs.google.com/document/d/1AtpEgQOc0lzuwRIJuPZgCHdYz4olpTwszsCoeRR1_r4/edit please review topics and add at least a one-liner to the document in advance (RobDolinMS, 18:55:06)
    5. Doug: We'll decide order when we get there (RobDolinMS, 18:55:17)
    6. Lunch on Day 1 looks like Jimmy John's (RobDolinMS, 18:56:02)


Meeting ended at 18:57:16 UTC (full logs).

Action items

  1. wking to check for a concrete example of an unprivileged user and add one if missing
  2. rebase #99 and re-submit
  3. wking rebase #99 and re-submit
  4. mrunalp will post with an example of why this is useful
  5. single, unified config file
  6. vbatts|work to write-up perspective on why two files
  7. mrunalp to investigate a split-out security section and post notes
  8. will post a new thread to the list explaining this approach
  9. vbatts|work will post a new thread to the list explaining this approach


Action items, by person

  1. mrunalp
    1. mrunalp will post with an example of why this is useful
    2. mrunalp to investigate a split-out security section and post notes
  2. vbatts|work
    1. vbatts|work to write-up perspective on why two files
    2. vbatts|work will post a new thread to the list explaining this approach
  3. wking
    1. wking to check for a concrete example of an unprivileged user and add one if missing
    2. wking rebase #99 and re-submit
  4. UNASSIGNED
    1. rebase #99 and re-submit
    2. single, unified config file
    3. will post a new thread to the list explaining this approach


People present (lines said)

  1. wking (61)
  2. RobDolinMS (57)
  3. duglin (9)
  4. collabot` (4)
  5. mrunalp (2)
  6. crosbymichael (1)
  7. vbatts|work (1)
  8. mikebrow (1)


Generated by MeetBot 0.1.4.